[Réglé] MàJ 3.1.9 réussie, erreur générale à la connexion et à la déconnexion.

Forum concernant les demandes de support pour tout problème de mise à jour d'un forum phpBB 3.1.x depuis une version antérieure ou d'une conversion de phpBB2 ou phpBB3 vers phpBB 3.1

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.
Partager sur FacebookPartager sur TwitterPartager sur Google+

[Réglé] MàJ 3.1.9 réussie, erreur générale à la connexion et à la déconnexion.

Messagepar YvenG » 24 Juin 2016 à 12:45

Bonjour,

Je viens tout juste d'effectuer la mise à jour en suivant le protocole (dans la douleur, cf. ce topic), et j'ai maintenant un nouveau problème. Lors de la connexion et de la déconnexion, je reçois le message d'erreur suivant :

Erreur générale
Vous avez tenté de rediriger vers une URL potentiellement dangereuse.

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/functions.php
LINE: 2377
CALL: trigger_error()

FILE: [ROOT]/ucp.php
LINE: 110
CALL: redirect()


Pourtant ensuite la connexion ou la déconnexion fonctionnent normalement. J'ai purgé le cache (dans le doute), mais ça ne change rien.
Je n'ai pas trouvé de sujet correspondant sur Google ou ici, donc je me permets de créer un nouveau post. Est-ce déjà arrivé à quelqu'un ? Suis-je l'heureux premier ?
YvenG
Posteur néophyte
Posteur néophyte
 
Messages: 6
Enregistré le: 21 Juin 2016 à 10:12

Re: MàJ 3.1.9 réussie, erreur générale à la connexion et à la déconnexion.

Messagepar YvenG » 24 Juin 2016 à 14:27

Résolvation :
J'ai trouvé un peu d'aide sur le forum anglophone de phpBB : https://www.phpbb.com/community/viewtopic.php?f=46&t=1187795&start=15.
Ce n'est pas la même erreur, mais ça y ressemblait.
J'ai donc ouvert functions.php, j'ai bidouillé l'intérieur en remplaçant notamment :
Code: Tout sélectionner
trigger_error('INSECURE_REDIRECT', E_USER_ERROR);

par des
Code: Tout sélectionner
trigger_error('INSECURE_REDIRECT {'.$url.'}', E_USER_ERROR);

pour afficher l'url incriminée.

Ce qui m'a indiqué que le problème de l'url venait d'un triple "slash" au début de l'url.
Code: Tout sélectionner
http:///forum.adresseduforum.fr
       ^----- le 3e slash

Après quelques tests, je me suis rendu compte que c'était la variable "server_name" dans la table phpbb_config qui posait problème. Je l'ai donc transformée de /repertoireSurLeServeur à forum.adresseduforum.fr .
Et maintenant ça fonctionne.
YvenG
Posteur néophyte
Posteur néophyte
 
Messages: 6
Enregistré le: 21 Juin 2016 à 10:12


Retourner vers Mises à jour/Conversions

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité

cron