[Réglé] Message d'erreur lors de l'installation d'une MAJ 3.0.14 vers 3.1.8

Forum concernant les demandes de support pour tout problème de mise à jour d'un forum phpBB 3.1.x depuis une version antérieure ou d'une conversion de phpBB2 ou phpBB3 vers phpBB 3.1

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.

[Réglé] Message d'erreur lors de l'installation d'une MAJ 3.0.14 vers 3.1.8

Messagepar Darloup » 22 Mar 2016 à 04:43

Bonjour,

J'ai scrupuleusement suivi les instructions de ce fil : documentation/mise-a-jour/31x-mise-a-niveau-de-phpbb-30x-vers-31x-a209-view.html pour faire la mise à jour vers mon forum 3.0.14 vers 3.1.8 - du moins je pensais l'avoir fait.

Ce que je devais maintenant faire :

Depuis votre navigateur exécutez le fichier install/database_update.php.
Attention ! Selon l'hébergement où se trouve le forum et la taille de la base de données, cette action peut durer plusieurs minutes, voire plusieurs heures.


Mais, à ce stade, je reçois ce message d'erreur:

Code: Tout sélectionner
Fatal error: Composer dependencies have not been set up yet, run 'php ../composer.phar install' from the phpBB directory to do so. in /home/darlou5/public_html/darloup.com/forum/includes/startup.php on line 170


Quelle est mon erreur ?

Merci d'avance !

Henry
Modifié en dernier par Darloup le 23 Mar 2016 à 23:55, modifié 1 fois.
Avatar de l’utilisateur
Darloup
Roi des posts
Roi des posts
 
Messages: 543
Enregistré le: 14 Mar 2009 à 21:49
Localisation: Barranquilla (Colombie)

Re: Message d'erreur lors de l'installation d'une MAJ 3.0.14 vers 3.1.8

Messagepar FoFa » 22 Mar 2016 à 08:37

Hello

Où as-tu pris le pack 3.1.8 ? Quel est ton hébergeur ?
De retour parmi vous :wink:
FoFa
Resp. des supporters
Resp. des supporters
 
Messages: 10592
Enregistré le: 15 Nov 2008 à 19:04
Localisation: Auxonne

Re: Message d'erreur lors de l'installation d'une MAJ 3.0.14 vers 3.1.8

Messagepar Darloup » 22 Mar 2016 à 14:39

Bonjour Fofa,

Où as-tu pris le pack 3.1.8 ?

Ici, sur phpBB : http://www.phpbb-fr.com/telechargements/#phpbb31 (1ère option : Pack Complet)

Quel est ton hébergeur ?

http://www.webhostinghub.com/

Je les ai contacté au préalable avec la liste de la configuration requise :

Code: Tout sélectionner
Prérequis pour phpBB 3.1 :
Un serveur Web supportant PHP 5.3.3 ou supérieur.
L'un des systèmes de base de données SQL suivants :
MySQL 3.23 ou supérieur (MySQLi supporté)
MariaDB 5.1 ou supérieur
MS SQL Server 2000 ou supérieur (via ODBC)
MS SQL Server 2005 ou supérieur (via le connecteur SQLSRV)
Oracle
PostgreSQL 8.3+
SQLite 2
SQLite 3
La fonction getimagesize() doit être activée.
L'extension PHP JSON doit être activée
.

et ils m'ont assuré (par écrit !) qu'ils étaient aux niveaux - et même plus !

Cordialement,

Henry
Avatar de l’utilisateur
Darloup
Roi des posts
Roi des posts
 
Messages: 543
Enregistré le: 14 Mar 2009 à 21:49
Localisation: Barranquilla (Colombie)

Re: Message d'erreur lors de l'installation d'une MAJ 3.0.14 vers 3.1.8

Messagepar Darloup » 23 Mar 2016 à 23:54

Bonjour,

Apparemment le message d'erreur que j'avais obtenu :

Fatal error: Composer dependencies have not been set up yet, run 'php ../composer.phar install' from the phpBB directory to do so. in /home/darlou5/public_html/darloup.com/forum/includes/startup.php on line 170


signifie que j'avais omis de télécharger un (ou plusieurs) fichier(s) du nouveau pack.

J'ai donc repris l'installation à zéro en faisant encore plus attention :mrgreen: et, cette fois, tout s'est bien passé !

Encore merci !

Cordialement,

Henry
Avatar de l’utilisateur
Darloup
Roi des posts
Roi des posts
 
Messages: 543
Enregistré le: 14 Mar 2009 à 21:49
Localisation: Barranquilla (Colombie)

Re: Message d'erreur lors de l'installation d'une MAJ 3.0.14 vers 3.1.8

Messagepar FoFa » 23 Mar 2016 à 23:58

Merci du retour Colombiano :wink:
De retour parmi vous :wink:
FoFa
Resp. des supporters
Resp. des supporters
 
Messages: 10592
Enregistré le: 15 Nov 2008 à 19:04
Localisation: Auxonne


Retourner vers Mises à jour/Conversions

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité