[Réglé] Pertes de données après une mise à jour 3.1.7-PL1 vers 3.1.8

Forum concernant les demandes de support pour tout problème de mise à jour d'un forum phpBB 3.1.x depuis une version antérieure ou d'une conversion de phpBB2 ou phpBB3 vers phpBB 3.1

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.

[Réglé] Pertes de données après une mise à jour 3.1.7-PL1 vers 3.1.8

Messagepar bonnaphil » 18 Mar 2016 à 02:54

Je viens d'effectuer la mise à jour de mon fofo de 3.1.7-PL1 vers 3.1.8. La mise à jour s'est passée correctement, la base de données à été mise à jour => OK.

Mais gros problème ! Lors de la réactivation de mon forum en 3.1.8 je constate que ma date de dernière connexion est le 1er Mars 2016, alors que mon dernier accès au fofo était hier le 17 Mars 2016 et que je suis à 65 inscrits au lieu de 83 et qu'il me manque des posts et des fils de discussion créés pendant la période du 1 au 17 Mars.

Du coup j'ai réinstallé la sauvegarde 3.1.7-PL1 faite avant la MàJ hier soir et j'ai réinstallé la Base de données associée que j'avais également sauvegardé en même temps.

Tout est à nouveau rentré dans l'ordre, MAIS, je suis toujours en 3.1.7-PL1.

Je précise que j'ai fait deux fois la mise à jour et 'à chaque fois je me retrouve avec un fofo en date du 1er Mars après la mise à jour en 3.1.8.

Que se passe-t-il avec cette mise à jour et que faire pour que mon fofo reste à la bonne date.

Je précise que j'ai migré mon forum de online chez infomaniack et que cela s'est bien passé (j'ai suivi le tuto). J'ai cependant eu pendant quelque temps un mot de passe d'accès à la base de données qui était erroné (dans config.php) et je m'en suite rendu compte lors d'une première tentative de mise à jour en 3.1.8. Ce problème étant réglé, est-ce là la cause du problème ? Y-a-t-il dans la base de donnée une variable qui n'aurait pas été mise à jour et qu'il faudrait que je modifie dans phpmyadmin ? Intuitivement je pense à cela, mais je ne sais pas où regarder pour le vérifier. Mon forum fonctionne sinon parfaitement en 3.1.7-PL1.

Merci pour votre aide.
Modifié en dernier par bonnaphil le 03 Jan 2017 à 04:15, modifié 1 fois.
Philippe Bonnaure
macvf.fr - GitHub - Forum phpBB
Avatar de l’utilisateur
bonnaphil
Posteur néophyte
Posteur néophyte
 
Messages: 22
Enregistré le: 30 Déc 2015 à 18:05
Localisation: Toulon

Re: Pertes de données après une mise à jour 3.1.7-PL1 vers 3.1.8

Messagepar Skouat » 19 Mar 2016 à 16:12

Bonjour,

Votre problème est étrange car la mise à jour d'un forum ne supprime pas de données.
Comment procédez-vous à la mise à jour ?
Quel pack de mise à jour avez-vous utilisé ? ou l'avez-vous récupéré ?
Quelle est l'url de votre forum ?

Cordialement.

PS : la version 3.1.7 c'est 3.1.7-PL1 et non 3.1.7L ;)
Mes MODS

Ultima-World Hébergé par phpBB-Services
Code parrainage : 1241646554
Skouat
Traducteur
Traducteur
 
Messages: 13708
Enregistré le: 02 Avr 2008 à 20:47

Re: Pertes de données après une mise à jour 3.1.7-PL1 vers 3.1.8

Messagepar bonnaphil » 19 Mar 2016 à 19:51

Le pack de mise à jour a été récupéré en cliquant sur le lien Téléchargement de ce site.
La procédure de mise à jour est celle préconisée ici et que j'ai déjà mis en oeuvre pour le passage de 3.1.6 en 3.1.7-PL1.
Je rappelle juste que j'ai fait une migration de Online à Infomaniak sans problème (en version 3.1.7-PL1).
Mon forum est ici.

En restaurant mon site en 3.1.7-PL1 (ftp et base SQL) après constat de la pertes de données en 3.1.8, je récupère bien tout. D'où mon interrogation sur cette pertes de données.

PS : Désolé pour l'erreur de version.
Philippe Bonnaure
macvf.fr - GitHub - Forum phpBB
Avatar de l’utilisateur
bonnaphil
Posteur néophyte
Posteur néophyte
 
Messages: 22
Enregistré le: 30 Déc 2015 à 18:05
Localisation: Toulon

Re: Pertes de données après une mise à jour 3.1.7-PL1 vers 3.1.8

Messagepar Skouat » 20 Mar 2016 à 21:53

Bonjour,

Le forum a toujours été en version 3.1.x ou il était auparavant en 3.0.x ?
Donc, depuis que vous êtes chez Infomaniak c'est la première mise à jour de votre forum ?
Mes MODS

Ultima-World Hébergé par phpBB-Services
Code parrainage : 1241646554
Skouat
Traducteur
Traducteur
 
Messages: 13708
Enregistré le: 02 Avr 2008 à 20:47

Re: Pertes de données après une mise à jour 3.1.7-PL1 vers 3.1.8

Messagepar bonnaphil » 23 Mar 2016 à 00:37

Le forum a été créé en v3.1.6 chez online.
Mis à jour en v3.1.7-PL1 chez online
Transféré chez infomaniak en v3.1.7-PL1 en suivant le tutoriel indiqué sur ce site => RAS
1ère Tentative de mise à jour en v3.1.8 chez infomaniak, avec une erreur générale m'indiquant un problème d'accès à la base SQL (pb de mot de passe). Je précise que je suis sur un serveur mutualisé et que l'accès à la base SQL n'est pas accessible directement depuis une connexion externe (comme avec Sequel Pro par exemple)
Reinstallation du fofo en v3.1.7-PL1 (ftp+sql) et correction du mot de passe dans le fichier config.php => Tout est OK Fofo tourne bien pas de pertes de données.
Retentative d'installation de v3.1.8, ok cette fois pour l'accès base SQL, mais mon package de mise à jour semble incomplet, problème de téléchargement direct du lien avec Safari qui semble ne pas copier tous les fichiers pour une raison que j'ignore.
Reinstallation du fofo en v3.1.7-PL1 (ftp+sql). Téléchargement du package de mise à jour en utilisant "Télécharger le lien" et pas un simple clic sur le lien.
Retentative d'installation de v3.1.8, ok cette fois tout se passe bien tant pour la base sql que pour les fichiers. Fin de la mise à jour => RAS
Relance en version 3.1.8 du fofo => Il me manque 15 jours de données et il m'indique que ma dernière connexion remonte au 1er Mars alors que ma dernière connexion était le 17 et le nombre d'utilisateurs inscrit est celui en date du 1er mars et pas du 17 mars.
Reinstallation du fofo en v3.1.7-PL1 et depuis tout est à nouveau OK. Qu'en conclure ? et surtout comment faire cette MàJ !
Philippe Bonnaure
macvf.fr - GitHub - Forum phpBB
Avatar de l’utilisateur
bonnaphil
Posteur néophyte
Posteur néophyte
 
Messages: 22
Enregistré le: 30 Déc 2015 à 18:05
Localisation: Toulon

Re: Pertes de données après une mise à jour 3.1.7-PL1 vers 3.1.8

Messagepar FoFa » 23 Mar 2016 à 01:11

Bonsoir,

Pourriez-vous, s'il vous plaît, nous transmettre le contenu initial d'un message dont le contenu aurait disparu après la conversion ?
De retour parmi vous :wink:
FoFa
Resp. des supporters
Resp. des supporters
 
Messages: 10582
Enregistré le: 15 Nov 2008 à 19:04
Localisation: Auxonne

Re: Pertes de données après une mise à jour 3.1.7-PL1 vers 3.1.8

Messagepar bonnaphil » 24 Mar 2016 à 08:46

Ce que je vais faire, c'est dupliquer mon forum et ensuite le mettre à jour en 3.1.8. Je vous donnerai les liens des deux forums. Ca sera plus simple pour comprendre.
Philippe Bonnaure
macvf.fr - GitHub - Forum phpBB
Avatar de l’utilisateur
bonnaphil
Posteur néophyte
Posteur néophyte
 
Messages: 22
Enregistré le: 30 Déc 2015 à 18:05
Localisation: Toulon

Re: Pertes de données après une mise à jour 3.1.7-PL1 vers 3.1.8

Messagepar Skouat » 24 Mar 2016 à 15:48

Le truc c'est que cette perte de données n'a pas de sens logique. D'où notre incompréhension.
S'il faut, la mise à jour du forum dupliquée va bien se dérouler.
Mes MODS

Ultima-World Hébergé par phpBB-Services
Code parrainage : 1241646554
Skouat
Traducteur
Traducteur
 
Messages: 13708
Enregistré le: 02 Avr 2008 à 20:47

Re: Pertes de données après une mise à jour 3.1.7-PL1 vers 3.1.8

Messagepar FoFa » 25 Mar 2016 à 02:44

Il y a un sujet ouvert chez .com concernant un problème a priori similaire. Faut que je retrouve. Pas sûr encore des différentes versions concernées).
De retour parmi vous :wink:
FoFa
Resp. des supporters
Resp. des supporters
 
Messages: 10582
Enregistré le: 15 Nov 2008 à 19:04
Localisation: Auxonne


Retourner vers Mises à jour/Conversions

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité