Blocage avec MAJ 3.1.6 vers 3.1.8

Forum concernant les demandes de support pour tout problème de mise à jour d'un forum phpBB 3.1.x depuis une version antérieure ou d'une conversion de phpBB2 ou phpBB3 vers phpBB 3.1

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.
Partager sur FacebookPartager sur TwitterPartager sur Google+

Blocage avec MAJ 3.1.6 vers 3.1.8

Messagepar tipi64 » 07 Mar 2016 à 15:52

Hello all :)

C'est mon premier post sur ce forum et, aussi, mon premier souci sur mon premier forum.

Voilà, je tente de faire la MAJ depuis 3.1.6 vers 3.1.8 de manière automatique.

J'ai téléchargé l'archive phpBB-3.1.6_to_3.1.8.zip, j'ai mis les dossiers sur mon FTP à la place des anciens dossiers et je suis allé sur /install.

Tout va bien dans les débuts puis, au moment de synchroniser les fichiers modifiés, il y a un blocage. J'ai tenté plusieurs fois, c'est toujours bloqué sur 43/169 fichiers...

Code: Tout sélectionner
Collecte des différences des fichiers

Actuellement, 43 des 169 fichiers vérifiés comportent des différences.
Veuillez patienter jusqu’à ce que tous les fichiers soient vérifiés.


J'ai d'ailleurs une demande de redirection qui est refusée par le navigateur mais, que je le fasse (j'arrive sur une erreur en frontend du au dossier install) ou pas, cela n'avance toujours pas.

Je ne suis pas pro de phpBB alors si vous avez une idée, je suis preneur. Sinon, comment puis-je faire une MAJ propre de mon forum sans soucis ? Merci ;)
tipi64
Posteur néophyte
Posteur néophyte
 
Messages: 8
Enregistré le: 07 Mar 2016 à 15:47

Re: Blocage avec MAJ 3.1.6 vers 3.1.8

Messagepar Manard » 07 Mar 2016 à 16:16

Bonjour,


A mon avis il te faut d'abord passer par la mise à jour de 3.1.6 vers 3.1.7Pl1 et ensuite de 3.1.7Pl1 vers 3.1.8

Bonne après-midi

Bernard
Manard
Roi des posts
Roi des posts
 
Messages: 921
Enregistré le: 31 Mar 2012 à 09:24

Re: Blocage avec MAJ 3.1.6 vers 3.1.8

Messagepar Bid0uille » 07 Mar 2016 à 16:52

Manard a écrit:A mon avis il te faut d'abord passer par la mise à jour de 3.1.6 vers 3.1.7Pl1

:? Dans ce cas, pourquoi proposer un pack phpBB-3.1.6_to_3.1.8.zip ?
Enfin un Forum francophone pour OpenOffice et ses dérivés !
L'ensemble des forums officiels pour OpenOffice (10 langues) est propulsé par PhpBB
Avatar de l’utilisateur
Bid0uille
Roi des posts
Roi des posts
 
Messages: 569
Enregistré le: 18 Nov 2005 à 17:42
Localisation: Saumur, France

Re: Blocage avec MAJ 3.1.6 vers 3.1.8

Messagepar Manard » 07 Mar 2016 à 16:58

Bonjour,


Je n'ai pas vu ce pack FR, où est-il ? si c'est celui de phpBB.com, je n'utilise pas ceux-là, ceux de phpBB-fr étant adaptés par nos traducteurs

Bernard
Modifié en dernier par Manard le 07 Mar 2016 à 17:03, modifié 1 fois.
Manard
Roi des posts
Roi des posts
 
Messages: 921
Enregistré le: 31 Mar 2012 à 09:24

Re: Blocage avec MAJ 3.1.6 vers 3.1.8

Messagepar tipi64 » 07 Mar 2016 à 17:02

Hello.

Manard a écrit:Je n'ai pas vu ce pack FR, où est-il ?


https://www.phpbb.com/downloads/?mode=u ... sion=3.1.6
tipi64
Posteur néophyte
Posteur néophyte
 
Messages: 8
Enregistré le: 07 Mar 2016 à 15:47

Re: Blocage avec MAJ 3.1.6 vers 3.1.8

Messagepar Manard » 07 Mar 2016 à 17:04

bonjour,

J'ai complété mon précédent message en indiquant que je n'utilise que les packs de phpBB-fr

Bernard
Manard
Roi des posts
Roi des posts
 
Messages: 921
Enregistré le: 31 Mar 2012 à 09:24

Re: Blocage avec MAJ 3.1.6 vers 3.1.8

Messagepar Steph » 07 Mar 2016 à 17:06

Salut,

Cela reste possible de sauter des versions, mais effectivement nous conseillons de le faire par version une à une, car cela évite bien des soucis.
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 17924
Enregistré le: 29 Déc 2008 à 16:48
Localisation: Alsace / Bas-Rhin / France

Re: Blocage avec MAJ 3.1.6 vers 3.1.8

Messagepar tipi64 » 07 Mar 2016 à 17:13

Du coup, comment je fais pour partir sur 3.1.7 ? Merci :)
tipi64
Posteur néophyte
Posteur néophyte
 
Messages: 8
Enregistré le: 07 Mar 2016 à 15:47

Re: Blocage avec MAJ 3.1.6 vers 3.1.8

Messagepar Steph » 07 Mar 2016 à 17:21

Je ne sais pas où tu en es dans ta mise à jour, mais tu peux récupérer l'archives de mise à jour automatique sur notre page de téléchargement dont le lien se trouve dans le menu ci-dessus :wink:
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 17924
Enregistré le: 29 Déc 2008 à 16:48
Localisation: Alsace / Bas-Rhin / France

Re: Blocage avec MAJ 3.1.6 vers 3.1.8

Messagepar tipi64 » 07 Mar 2016 à 18:05

Cela me donne de 3.1.7 vers 3.1.8 et j'en suis à la 3.1.6 :)
Modifié en dernier par Steph le 07 Mar 2016 à 18:57, modifié 1 fois.
Raison: Suppression de la citation inutile du message auquel tu réponds directement
tipi64
Posteur néophyte
Posteur néophyte
 
Messages: 8
Enregistré le: 07 Mar 2016 à 15:47

Re: Blocage avec MAJ 3.1.6 vers 3.1.8

Messagepar Mazeltof » 07 Mar 2016 à 18:57

'jour ici,

Sur la page de téléchargement, cadre "quel pack de téléchargement choisir ?" (en bas) tu cliques sur "archives des anciennes versions" et dans la fenêtre qui s'affiche, tu choisis la version que tu désires :wink:
Image Image Image
Avatar de l’utilisateur
Mazeltof
Resp. des graphistes
Resp. des graphistes
 
Messages: 2500
Enregistré le: 09 Mar 2009 à 23:02
Localisation: Arras

Re: Blocage avec MAJ 3.1.6 vers 3.1.8

Messagepar tipi64 » 09 Mar 2016 à 19:23

Merci @Mazeltof je n'avais pas vu ces "subtilités" même en faisant attention (et le pire, c'est que c'est mon travail) :)

Merci à toi, je vais faire mes 2 MAJ d'affilée alors :lol:
tipi64
Posteur néophyte
Posteur néophyte
 
Messages: 8
Enregistré le: 07 Mar 2016 à 15:47

Re: Blocage avec MAJ 3.1.6 vers 3.1.8

Messagepar tipi64 » 18 Juin 2016 à 18:30

Hello ici :)

Je m'attèle (un peu en retard) à la MAJ, je suis sur la MAJ 3.1.7pl1.

J'ai fait les ajouts par FTP manuel, ensuite contrôle des fichiers (2/5) et, quand j'ai mis à jour par FTP automatiquement les fichiers, la seconde vérification déconne.

La mise à jour a été effectuée

Tous les fichiers ont été mis à jour. La prochaine étape consiste à vérifier de nouveau tous les répertoires afin de vous assurer que les fichiers ont été mis à jour correctement.


Quand je fais Continuer la mise à jour, il lance le contrôle d'intégrité mais actualise la page au boude quelques 2, peut-être 3 secondes, je pars sur une page d'erreur (où on m'indique que je dois supprimer le dossier Install - on tourne en rond), URL /index.php/install/index.php?language=fr&mode=update&sub=file_check.

L'astuce, c'est de faire Retour pour revenir sur la page de demande de contrôle d'intégrité et, du coup, je relance la manipulation et je vois l'avancée mais sur cette étape 4/5, je bloque :

Actuellement, 38 des 161 fichiers vérifiés comportent des différences.


Image

Je peux faire quoi pour résoudre ce souci ? Un problème de conflit avec un plugin peut-être ?

Image

J'ai toujours eu ce souci de rafraichissement de page qui m'envoie vers une erreur...

Merci ;)
tipi64
Posteur néophyte
Posteur néophyte
 
Messages: 8
Enregistré le: 07 Mar 2016 à 15:47

Re: Blocage avec MAJ 3.1.6 vers 3.1.8

Messagepar Manard » 18 Juin 2016 à 20:42

Bonjour,

Normalement il est conseillé de réaliser la mise à jour des fichiers en téléchargeant l'archive du serveur vers ton PC et de la renvoyer par FTP.

Effectivement une vérification de 2 à 3 s est plus que douteuse, surtout qu'en dernier lieu il y a la mise à jour de la base de données qui ne semble pas avoir été effectuée.

As-tu essayé de relancé la mise à jour, normalement il ne doit pas y avoir de risques, si tous les fichiers sont à jour il ne te demandera pas un deuxième passage.

Bons essais

Bernard
Manard
Roi des posts
Roi des posts
 
Messages: 921
Enregistré le: 31 Mar 2012 à 09:24

Re: Blocage avec MAJ 3.1.6 vers 3.1.8

Messagepar tipi64 » 18 Juin 2016 à 22:17

Hello Manard.

Je suis novice sur ce CMS :( Quand tu parles de faire la MAJ via FTP, tu entends quoi exactement ? Télécharger l'archive complète de la version désirée et tout copier sur le FTP ? Si oui, c'est ce que j'ai fait avec l'archive 3.1.7pl1. C'est à l'étape 3/5, quand ils demandent la mise à jour de certains fichiers (écraser, fusionner ou laisser tomber) que j'ai fait la version automatique.

Bon effectivement, tu avais raison, la seconde vérification a été sautée et j'ai eu directement la MAJ de la base de données. Sauf que voilà :D

Les fichiers de mise à jour sont incompatibles avec la version qui est actuellement installée. La version actuellement installée est la 3.1.9 alors que les fichiers de mise à jour sont destinés à la mise à jour de phpBB 3.1.6 vers phpBB 3.1.7-pl1


Je vais voir à installer directement la version 3.1.9 au cas où cela passerait cette fois-ci ;)
tipi64
Posteur néophyte
Posteur néophyte
 
Messages: 8
Enregistré le: 07 Mar 2016 à 15:47

Suivante

Retourner vers Mises à jour/Conversions

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité