[Réglé] Passer mon forum d'un 3.0.11 à 3.1.8

Forum concernant les demandes de support pour tout problème de mise à jour d'un forum phpBB 3.1.x depuis une version antérieure ou d'une conversion de phpBB2 ou phpBB3 vers phpBB 3.1

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.

[Réglé] Passer mon forum d'un 3.0.11 à 3.1.8

Messagepar codoverge » 03 Mar 2016 à 20:32

Bonjour,

Voila je dois passer mon forum a cause de 1and1 en 3.1.8 mais je suis pas très doué :oops:

Voici mon forum actuel : http://www.oracleprono.com/Forum

Je veux suivre le tuto ici : documentation/mise-a-jour/31x-mise-a-niveau-de-phpbb-30x-vers-31x-a209-view.html

Mais mon probleme commence des le début car on demande d'installer un fameux STK :( mais qui n'est pas dispo pour la version 3.0.11

Je sens que je vais y passer des jours pour faire la mise a jour ...

Et j'ai pas très bien compris, il y a marqué :

Utilisez STK afin de nettoyer votre base de données.
N'hésitez pas à faire plusieurs nettoyages de votre base de données avant de procéder à la mise à niveau.


Cela veux dire quoi nettoyer ? ca veux dire effacer le forum ?
Modifié en dernier par codoverge le 04 Mar 2016 à 00:00, modifié 2 fois.
codoverge
Posteur néophyte
Posteur néophyte
 
Messages: 87
Enregistré le: 18 Nov 2012 à 19:10

Re: Passer mon forum d'un 3.0.11 à 3.1.8

Messagepar cabot » 03 Mar 2016 à 20:50

Hello,

Le STK est compatible avec ta version.

A savoir que ce n'est pas obligé de l'utiliser, tu peux très bien zapper cette étape qui est surtout utile si tu souhaites nettoyer la base pour repartir sur du propre (sans effacer le forum ^^).
Image
Avatar de l’utilisateur
cabot
Equipe site
Equipe site
 
Messages: 26796
Enregistré le: 13 Fév 2011 à 20:42
Localisation: Rarement sur la plaque

Re: Passer mon forum d'un 3.0.11 à 3.1.8

Messagepar codoverge » 03 Mar 2016 à 21:45

J'ai peur de tout perdre .... :oops:
codoverge
Posteur néophyte
Posteur néophyte
 
Messages: 87
Enregistré le: 18 Nov 2012 à 19:10

Re: Passer mon forum d'un 3.0.11 à 3.1.8

Messagepar Steph » 03 Mar 2016 à 21:48

Salut,

Si tu suis à la lettre le tutoriel et que tu fais une sauvegarde fichiers et base de données cela devrait bien se passer. :wink:
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 18199
Enregistré le: 29 Déc 2008 à 16:48
Localisation: Alsace / Bas-Rhin / France

Re: Passer mon forum d'un 3.0.11 à 3.1.8

Messagepar codoverge » 03 Mar 2016 à 23:02

J'arrive pas a aller sur le fichier installe

http://www.oracleprono.com/Forum/instal ... update.php
codoverge
Posteur néophyte
Posteur néophyte
 
Messages: 87
Enregistré le: 18 Nov 2012 à 19:10

Re: Passer mon forum d'un 3.0.11 à 3.1.8

Messagepar cabot » 03 Mar 2016 à 23:16

Hello,

Je vais peut-être dire une ânerie mais tu ne devais pas attendre que ton hébergeur fasse évoluer la version PHP avant de mettre à jour le forum ?
Image
Avatar de l’utilisateur
cabot
Equipe site
Equipe site
 
Messages: 26796
Enregistré le: 13 Fév 2011 à 20:42
Localisation: Rarement sur la plaque

Re: Passer mon forum d'un 3.0.11 à 3.1.8

Messagepar codoverge » 03 Mar 2016 à 23:24

Non je pense pas, il m'ont dit que je devais mettre à jour mon forum pour arrêter un support qui me permettais de lire du php 5.2

Tu penses que ça vient de mon hébergeur ?
Modifié en dernier par Steph le 03 Mar 2016 à 23:27, modifié 1 fois.
Raison: Suppression de la citation
codoverge
Posteur néophyte
Posteur néophyte
 
Messages: 87
Enregistré le: 18 Nov 2012 à 19:10

Re: Passer mon forum d'un 3.0.11 à 3.1.8

Messagepar Steph » 03 Mar 2016 à 23:30

Inutile de citer en entier le message auquel tu réponds directement.

Si c'est juste à cause de la version de php alors tu peux d'abord faire la mise à jour jusque 3.0.14 et mettre la dernière version de php sauf la 7, cela fonctionnera.

Ensuite tu pourras envisager la mise à niveau vers 3.1.

Pour exemple je tourne très bien avec 3.0.14 et php 5.6
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 18199
Enregistré le: 29 Déc 2008 à 16:48
Localisation: Alsace / Bas-Rhin / France

Re: Passer mon forum d'un 3.0.11 à 3.1.8

Messagepar cabot » 03 Mar 2016 à 23:30

Ben je n'y connais rien à PHP et tout le bouzin mais quand je fais une recherche avec l'erreur relevée, j'ai pas mal de résultats qui indiquent un problème de version PHP. Dans le doute, renvoie les fichiers sauvegardés et vois ça avec ton hébergeur demain.
Image
Avatar de l’utilisateur
cabot
Equipe site
Equipe site
 
Messages: 26796
Enregistré le: 13 Fév 2011 à 20:42
Localisation: Rarement sur la plaque

Re: Passer mon forum d'un 3.0.11 à 3.1.8

Messagepar Steph » 03 Mar 2016 à 23:34

Si tu as déjà envoyé tous les fichiers de la version 3.1 alors change la version de php dans ton espace 1and1 cela prends quelques minutes pour la prise en compte, normalement tu as la main pour le faire si cela n'a pas changé.

Edit : un peu de lecture : https://assistance.1and1.fr/hebergement ... 91913.html

Si tu n'as que phpBB, tu peux utiliser la version 5.6 sinon fait l'essai
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 18199
Enregistré le: 29 Déc 2008 à 16:48
Localisation: Alsace / Bas-Rhin / France

Re: Passer mon forum d'un 3.0.11 à 3.1.8

Messagepar codoverge » 03 Mar 2016 à 23:55

Merci :mrgreen:
codoverge
Posteur néophyte
Posteur néophyte
 
Messages: 87
Enregistré le: 18 Nov 2012 à 19:10


Retourner vers Mises à jour/Conversions

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 2 invités

cron