[Réglé] [Réglé]Mis à niveau 3.0.14 -> ....

Forum concernant les demandes de support pour tout problème de mise à jour d'un forum phpBB 3.1.x depuis une version antérieure ou d'une conversion de phpBB2 ou phpBB3 vers phpBB 3.1

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.

Re: Mis à niveau 3.0.14 -> ....

Messagepar Skouat » 12 Mar 2016 à 18:30

Bonjour,

A la lecture de vos commentaires, je pense que vous vous trompez de méthode pour mettre à niveau vers 3.1

La mise à niveau vers 3.1 ne nécessite aucunement de recréer un nouveau forum et donc une nouvelle base de données.
Le seul intéret de monter un nouveau forum et donc une BDD c'est de faire des tests avant migration vers 3.1 (tester les extensions, les styles et principalement la migration vers 3.1).

En gros, si vous recréez un forum, recréez le en version 3.0.14, puis mettez-le à niveau vers 3.1. Et, une fois que vous vous êtes fait la main, vous le supprimez et vous migrez votre forum en production.

Ne partez pas dans l'idée de monter un 3.1 vierge et de transférer les utilisateurs, messages et tout le reste de l'ancien vers le nouveau.
Mes MODS

Ultima-World Hébergé par phpBB-Services
Code parrainage : 1241646554
Skouat
Traducteur
Traducteur
 
Messages: 13606
Enregistré le: 02 Avr 2008 à 20:47

Re: Mis à niveau 3.0.14 -> ....

Messagepar dork » 17 Mar 2016 à 11:21

je vais me lancer. Merci pour votre aide :)
dork
Posteur néophyte
Posteur néophyte
 
Messages: 49
Enregistré le: 19 Jan 2008 à 17:10
Avertissements: 1

Re: Mis à niveau 3.0.14 -> ....

Messagepar dork » 08 Aoû 2016 à 16:33

Je viens d'installer un peu tard je sais) un nouveau forum avec le préfixe phpBB- comme vous me l'avez suggéré et voilà le message d'erreur
dork
Posteur néophyte
Posteur néophyte
 
Messages: 49
Enregistré le: 19 Jan 2008 à 17:10
Avertissements: 1

Re: Mis à niveau 3.0.14 -> ....

Messagepar dork » 08 Aoû 2016 à 16:35

oups ! le lien ne fonctionne pas, voilà le message

Le préfixe que vous avez saisi n’est pas valide. Il doit commencer par une lettre et ne doit contenir que des lettres, des nombres et des tirets bas.

sinon j'ai essayé de modifier différemment, cela s'est terminé par un une erreur générale
dork
Posteur néophyte
Posteur néophyte
 
Messages: 49
Enregistré le: 19 Jan 2008 à 17:10
Avertissements: 1

Re: Mis à niveau 3.0.14 -> ....

Messagepar Skouat » 08 Aoû 2016 à 16:51

Bonjour,

Vu que ça fait un moment que vous n'avez pas répondu sur ce sujet, un p'tit rappel de bonne pratique s'impose.

Merci de ne faire des UPs que toutes les 24 heures minimum ! Afin d'éviter le verrouillage du sujet.
Ajoutez votre complément d'information en utilisant le bouton MODIFIER.
Pour info : Sur phpBB-fr.com un UP est le fait de poster deux messages à la suite, sans réponse d'un autre membre entre deux, dans un délai de moins de 24 heures.

Ceci étant rappelé...
_________________________________

dork a écrit:Je viens d'installer [...] un nouveau forum avec le préfixe phpBB-

dork a écrit:le message
Le préfixe que vous avez saisi n’est pas valide. Il doit commencer par une lettre et ne doit contenir que des lettres, des nombres et des tirets bas.

Connaissez-vous la différence entre tiret bas et tiret ?

tiret => -
tiret bas => _
Donc utilisez phpbb_ et non phpbb-
dork a écrit:sinon j'ai essayé de modifier différemment, cela s'est terminé par un une erreur générale

Erreur qui est ?
Mes MODS

Ultima-World Hébergé par phpBB-Services
Code parrainage : 1241646554
Skouat
Traducteur
Traducteur
 
Messages: 13606
Enregistré le: 02 Avr 2008 à 20:47

Re: Mis à niveau 3.0.14 -> ....

Messagepar dork » 12 Aoû 2016 à 10:00

Skouat a écrit:Bonjour,

Steph a écrit:Si c'est la même base de donnée, il faut que tu change le préfix par défaut qui te sera proposé lors de l'installation.


A noter que le préfixe ne peut pas dépasser 6 caractères, et qu'il est tout de même préférable de mettre un caractère de séparation. donc je suggère phpbb- au lieu de phpbb_


je n'ai suivi que les instructions :) et cela n'a pas fonctionné. Comment faire
dork
Posteur néophyte
Posteur néophyte
 
Messages: 49
Enregistré le: 19 Jan 2008 à 17:10
Avertissements: 1

Re: Mis à niveau 3.0.14 -> ....

Messagepar Skouat » 12 Aoû 2016 à 11:21

dork a écrit:Comment faire

Aucune idée, vu que vous semblez avare sur les informations.

dork a écrit:cela s'est terminé par un une erreur générale

Skouat a écrit:Erreur qui est ?

:?: :?: :?: :?: :?: :?: :?:
Mes MODS

Ultima-World Hébergé par phpBB-Services
Code parrainage : 1241646554
Skouat
Traducteur
Traducteur
 
Messages: 13606
Enregistré le: 02 Avr 2008 à 20:47

Re: Mis à niveau 3.0.14 -> ....

Messagepar dork » 13 Aoû 2016 à 08:51

ok ,c'est réglé. Juste à changer le config.php. Merci de votre aide
dork
Posteur néophyte
Posteur néophyte
 
Messages: 49
Enregistré le: 19 Jan 2008 à 17:10
Avertissements: 1

Précédente

Retourner vers Mises à jour/Conversions

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité