[Réglé] probleme mise a jour 3.0.12 => 3.1

Forum concernant les demandes de support pour tout problème de mise à jour d'un forum phpBB 3.1.x depuis une version antérieure ou d'une conversion de phpBB2 ou phpBB3 vers phpBB 3.1

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.
Partager sur FacebookPartager sur TwitterPartager sur Google+

[Réglé] probleme mise a jour 3.0.12 => 3.1

Messagepar BlancBim » 04 Fév 2016 à 11:15

http://tls3d.fr/forum/

bonjour,étant très en retard sur mes mises a jour, je m'y suis mis hier avec toute une série, passant des versions:
3.07 pl1 à 3.08, puis 3.09, 3.010, 3.011, 3.012...

jusque la, tout allait bien mais j'ai continué pour passer à 3.1 et c'est la que les problèmes ont commencé, il y'a eu quelques problèmes à l'installation, d'abord une page blanche en lieu et place de la page d'installation (résolut en effaçant certains fichiers) , puis des copies a répétitions, l'install me demandait de copier des fichiers dans certains dossiers, re-scannait pour vérifier puis me demandait de copier a nouveau les mêmes fichiers. (résolut en effaçant les dit fichiers).

l'installation c'est finalement terminé avec succès, je peux maintenant accéder aux pages principales du forum mais dés que j'essaie d'entrer dans un topic, il m'affiche le message suivant:

Code: Tout sélectionner
Illegal use of $_REQUEST. You must use the request class or request_var() to access input data. Found in /home/tls3d/public_html/forum/viewtopic.php on line 49. This error message was generated by deactivated_super_global.


du coup j'ai essayé de trouver une soluce sur internet, y compris sur ce forum mais j'espere malgré tout ne pas avoir posté un doublon, n'étant pas très à l'aise avec les mots clés.

merci a vous si vous pouvez m'aider,
BlancBim



[edit]
suppression de l'edit précédent qui était erroné
Modifié en dernier par BlancBim le 04 Fév 2016 à 21:49, modifié 2 fois.
BlancBim
Posteur néophyte
Posteur néophyte
 
Messages: 34
Enregistré le: 15 Sep 2010 à 18:11

Re: probleme mise a jour 3.0.12 => 3.1

Messagepar Manard » 04 Fév 2016 à 12:06

Bonjour,

Pour la migration de 3.0.12 en 3.1.7 PL1 as-tu mis en application le tutoriel de Jester ? : documentation/mise-a-jour/31x-mise-a-niveau-de-phpbb-30x-vers-31x-a209-view.html

Bonne journée

Bernard
Manard
Roi des posts
Roi des posts
 
Messages: 897
Enregistré le: 31 Mar 2012 à 08:24

Re: probleme mise a jour 3.0.12 => 3.1

Messagepar BlancBim » 04 Fév 2016 à 12:22

Bonjour Manard et merci pour ta réponse,

en fait non, comme j'avais commencer mes mises a jour a partir de 3.07, j'ai appliquer le tuto suivant a répétition:
http://forums.phpbb-fr.com/documentation/mise-a-jour/mettre-a-jour-son-forum-phpbb-30x-a178-view.html

et dans la foulée, 3.07, 3.08, 3.09 etc, je suis passé directement a la version 3.1 sans voir que ce n’était plus la bonne méthode.

en lançant l'install, je me suis retrouvé sur une page blanche, j'ai donc fait une recherche pour trouver le problème et suis tombé sur l'équivalent du tuto que tu cite mais en anglais, j'ai donc supprimé les fichiers recommandé et j'ai pu continuer l'installation en suivant la procédure affichée par l'installateur
BlancBim
Posteur néophyte
Posteur néophyte
 
Messages: 34
Enregistré le: 15 Sep 2010 à 18:11

Re: probleme mise a jour 3.0.12 => 3.1

Messagepar cocooncrash » 04 Fév 2016 à 12:34

Bonjour,
Mise a jour resolue?

Si vous considérez votre requête comme résolue, merci d'ajouter l'attribut de sujet [Réglé].
decouvrez l'aide complete : ICI
découvrez les règles : La_bas

Pensez a ajouter le tag [réglé] en modifiant votre premier message s'il est résolu. Merci :wink:
Avatar de l’utilisateur
cocooncrash
Resp. des modérateurs
Resp. des modérateurs
 
Messages: 7543
Enregistré le: 07 Jan 2008 à 08:29
Localisation: dans un bocal en compagnie de nemo!!

Re: probleme mise a jour 3.0.12 => 3.1

Messagepar BlancBim » 04 Fév 2016 à 12:41

bonjour cocooncrash,
non le problème est loin d’être résolut
BlancBim
Posteur néophyte
Posteur néophyte
 
Messages: 34
Enregistré le: 15 Sep 2010 à 18:11

Re: probleme mise a jour 3.0.12 => 3.1

Messagepar cocooncrash » 04 Fév 2016 à 12:53

L'erreur Got error 28 from storage engine [1030] indique un espace d'hebergement complet. Il faudrait donc voir votre hebergbeur car votre espace FTp est arrivé a saturation.
decouvrez l'aide complete : ICI
découvrez les règles : La_bas

Pensez a ajouter le tag [réglé] en modifiant votre premier message s'il est résolu. Merci :wink:
Avatar de l’utilisateur
cocooncrash
Resp. des modérateurs
Resp. des modérateurs
 
Messages: 7543
Enregistré le: 07 Jan 2008 à 08:29
Localisation: dans un bocal en compagnie de nemo!!

Re: probleme mise a jour 3.0.12 => 3.1

Messagepar BlancBim » 04 Fév 2016 à 13:09

merci cocooncrash, je vais essayer de voir ce qu'il en est de ce coté la...

ps: j'ai envoyé un message a o2switch, j'espere qu'ils réagiront rapidement
BlancBim
Posteur néophyte
Posteur néophyte
 
Messages: 34
Enregistré le: 15 Sep 2010 à 18:11

Re: probleme mise a jour 3.0.12 => 3.1

Messagepar BlancBim » 04 Fév 2016 à 14:25

j'espere qu'on me pardonnera ce double post, j'ai bien lu les règles, notamment pour les 2 posts en 24 heures, mais j'ai commis une erreur dans mon post précédent, erreur qui pourrait semer la confusion aupres de ceux qui essayent de m'aider, toutes mes excuses pour ça .

j'ai donc commis une erreur, le "Got error 28 from storage engine [1030]" datait de 2014, il n'y a pas d'erreur plus récente dans le journal de phpbb.

l'erreur qui nous intéresse donc est celle qui s'affiche a l'ouverture des page du forum:
General Error
Illegal use of $_REQUEST. You must use the request class or request_var() to access input data. Found in /home/blancbim/public_html/forum/viewtopic.php on line 49. This error message was generated by deactivated_super_global.
BlancBim
Posteur néophyte
Posteur néophyte
 
Messages: 34
Enregistré le: 15 Sep 2010 à 18:11

Re: probleme mise a jour 3.0.12 => 3.1

Messagepar cocooncrash » 04 Fév 2016 à 15:07

Je pense que tu as upgrader sans procéder aux nettoyages des fichiers anciens avant l'upgrade, ni meme d'avoir nettoyé tes anciens mods avant l'upgrade, ce qui fait qu'il reste des traces de vieux mods qui interferent avec 3.1. Faut revoir la procédure d'upgrade dans ton cas!
decouvrez l'aide complete : ICI
découvrez les règles : La_bas

Pensez a ajouter le tag [réglé] en modifiant votre premier message s'il est résolu. Merci :wink:
Avatar de l’utilisateur
cocooncrash
Resp. des modérateurs
Resp. des modérateurs
 
Messages: 7543
Enregistré le: 07 Jan 2008 à 08:29
Localisation: dans un bocal en compagnie de nemo!!

Re: probleme mise a jour 3.0.12 => 3.1

Messagepar Steph » 04 Fév 2016 à 15:14

Salut,

Merci de ne faire des UPs que toutes les 24 heures minimum !

Qu'importe la raison, tu aurais pu éditer ton précédent message.
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 17624
Enregistré le: 29 Déc 2008 à 15:48
Localisation: Alsace / Bas-Rhin / France

Re: probleme mise a jour 3.0.12 => 3.1

Messagepar BlancBim » 04 Fév 2016 à 16:25

cocooncrash a écrit:Je pense que tu as upgrader sans procéder aux nettoyages des fichiers anciens avant l'upgrade, ni meme d'avoir nettoyé tes anciens mods avant l'upgrade, ce qui fait qu'il reste des traces de vieux mods qui interferent avec 3.1. Faut revoir la procédure d'upgrade dans ton cas!


je crois que tu tiens quelque-chose avec cette histoire de mods, il y'a longtemps, j'avais un probleme dans les webmaster tools de google, il me trouvait plein de doublons parmi les topics du forum.
j'avais trouvé a l'époque que c'était un problème d'adresses lié a phpbb et avais suivi un tuto en anglais pour regler le problème.
c'est peut-être ça qui pose problème aujourd'hui mais impossible de retrouver le tuto en question pour retrouver les changements alors effectués.

je vais quand mème continuer a chercher, si je retrouve ça, le problème sera peut-être résolu.




Steph a écrit:Salut,

<font color=red><b>Merci de ne faire des UPs que toutes les 24 heures minimum !</b></font>

Qu'importe la raison, tu aurais pu éditer ton précédent message.


oui encore pardon, sachant que cocooncrash m'avait répondu, j'ai eu peur qu'il ai lu ma 1ere réponse et ne voit pas la présence d'un "[EDIT]"
BlancBim
Posteur néophyte
Posteur néophyte
 
Messages: 34
Enregistré le: 15 Sep 2010 à 18:11

Re: probleme mise a jour 3.0.12 => 3.1

Messagepar cocooncrash » 04 Fév 2016 à 16:34

Lis ceci, dedans tu as toute la procédure, donc celle (stk) qui permet de nettoyer ton forum de ses anciens mods.

http://forums.phpbb-fr.com/documentation/mise-a-jour/31x-mise-a-niveau-de-phpbb-30x-vers-31x-a209-view.html
decouvrez l'aide complete : ICI
découvrez les règles : La_bas

Pensez a ajouter le tag [réglé] en modifiant votre premier message s'il est résolu. Merci :wink:
Avatar de l’utilisateur
cocooncrash
Resp. des modérateurs
Resp. des modérateurs
 
Messages: 7543
Enregistré le: 07 Jan 2008 à 08:29
Localisation: dans un bocal en compagnie de nemo!!

Re: probleme mise a jour 3.0.12 => 3.1

Messagepar BlancBim » 04 Fév 2016 à 17:40

le tuto correspond bien a celui que j'ai partiellement suivi en anglais, j'ai donc bien effacé les fichiers cités mais effectivement, je n'ai pas utilisé l'outil stk
malheureusement, celui-ci n'est pas compatible avec la version 3.1, je vais donc continuer a chercher les lignes de code que j'ai pu modifier a l’époque
je vous tien au courant dés que ca evolue
Modifié en dernier par Steph le 04 Fév 2016 à 17:47, modifié 1 fois.
Raison: Suppression de la citation inutile du précedent message en entier
BlancBim
Posteur néophyte
Posteur néophyte
 
Messages: 34
Enregistré le: 15 Sep 2010 à 18:11

Re: probleme mise a jour 3.0.12 => 3.1

Messagepar Zoddo » 04 Fév 2016 à 19:49

Bonjour,

Si vous avez suivi le tuto, vous n'avez pas à chercher les lignes de code que vous avez modifier car il faut supprimer et réenvoyer TOUS les fichiers. Donc vous repartez sur un code propre.
[Doc] Installer une extension - [Extension] Post Models - [Recrutement] Équipe des Extensions
Si vous considérez votre requête comme résolue, merci d'ajouter l'attribut de sujet [Réglé]
Zoddo
Resp. Extensions
Resp. Extensions
 
Messages: 5790
Enregistré le: 16 Mar 2011 à 17:44
Localisation: /root/

Re: probleme mise a jour 3.0.12 => 3.1

Messagepar BlancBim » 04 Fév 2016 à 21:47

bon bein j'ai refait toute l'installation, directement a la version 3.1.7-pl1 et ça a l'air de marcher, merci les gars pour votre aide, du bon boulot! :D
BlancBim
Posteur néophyte
Posteur néophyte
 
Messages: 34
Enregistré le: 15 Sep 2010 à 18:11


Retourner vers Mises à jour/Conversions

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 2 invités