Toujours pas compatibilité avec PHP 7 avec phpBB 3.1.7pl1 ?

Forum concernant les demandes de support pour tout problème de mise à jour d'un forum phpBB 3.1.x depuis une version antérieure ou d'une conversion de phpBB2 ou phpBB3 vers phpBB 3.1

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.
Partager sur FacebookPartager sur TwitterPartager sur Google+

Toujours pas compatibilité avec PHP 7 avec phpBB 3.1.7pl1 ?

Messagepar ignace72 » 15 Jan 2016 à 20:28

Salut à tous,
je viens de tester la mise à jour vers la version phpBB 3.1.7pl1 avec PHP 7.
Résultat :
Code: Tout sélectionner
SQL ERROR [ mysql4 ]

mysql_connect function does not exist, is mysql extension installed? []

Quelqu'un a-il phpBB qui fonctionne avec PHP 7 ?

Si oui, comment a il fait ?
Si non, quand une version compatible doit-elle sortir ?

C'est pour savoir si je dois changer de moteur de forum ou non.

Merci
ignace72
Posteur néophyte
Posteur néophyte
 
Messages: 40
Enregistré le: 07 Aoû 2014 à 21:30

Re: Toujours pas compatibilité avec PHP 7 avec phpBB 3.1.7pl1 ?

Messagepar Kewee » 15 Jan 2016 à 20:34

Beeen, comme t'avait dit cocoon, apparemment, php7 n'est pas fait pour phpBB...

Pour toutes les autres questions, dsl, mais il faut voir avec phpBB.com, ici, on distribue, on traduit et on aide mais le développement c'est là-bas : https://www.phpbb.com/
euh... je suis une fille, hein ? ok ? faites un effort ! arrêtez de dire "il" en parlant de moi, merci
Vous avez le droit d'aider si vous avez la réponse ou une piste, n'hésitez pas, on n'égorge pas les honnêtes gens ^^
Avatar de l’utilisateur
Kewee
Graphiste
Graphiste
 
Messages: 12219
Enregistré le: 01 Déc 2005 à 18:17
Localisation: mais mais mais... et vous voulez pas mon numéro aussi?

Re: Toujours pas compatibilité avec PHP 7 avec phpBB 3.1.7pl1 ?

Messagepar Steph » 15 Jan 2016 à 20:43

Salut,

Il me semble que la version 3.2 sera compatible, mais cela reste à confirmer.

Par contre, cette version n'est pas conseillé en production pour le moment.
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 17930
Enregistré le: 29 Déc 2008 à 16:48
Localisation: Alsace / Bas-Rhin / France

Re: Toujours pas compatibilité avec PHP 7 avec phpBB 3.1.7pl1 ?

Messagepar ignace72 » 15 Jan 2016 à 21:10

Salut Steph,
phpBB 3.2 est prévu pour 2017, il est évident que sortir une version majeure non compatible avec la version de PHP actuelle serait inutile.
Je ne vais surement pas attendre 2017 pour avoir à nouveau un forum qui fonctionne, je vais donc migrer vers un autre moteur de forum. Il est évident que j'inciterai quiconque à ne pas utiliser phpBB puisque obsolète depuis des années (2013).
Merci et bon vent.
ignace72
Posteur néophyte
Posteur néophyte
 
Messages: 40
Enregistré le: 07 Aoû 2014 à 21:30

Re: Toujours pas compatibilité avec PHP 7 avec phpBB 3.1.7pl1 ?

Messagepar Steph » 15 Jan 2016 à 22:53

Oulala, quel langage pour une histoire de version php :roll:

Bonne continuation, ne t'inquiète surtout pas, personne ne te retiendra. :wink:
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 17930
Enregistré le: 29 Déc 2008 à 16:48
Localisation: Alsace / Bas-Rhin / France

Re: Toujours pas compatibilité avec PHP 7 avec phpBB 3.1.7pl1 ?

Messagepar Zoddo » 15 Jan 2016 à 23:37

Salut,

La raison de la non-compatibilité en phpBB 3.1 est l'utilisation par phpBB de certains éléments qui rentrent en conflit avec PHP7. Pour corriger ça, il faut effectuer des modifications qui cassent la compatibilité ascendante dans le code, chose qui ne peut-être fait qu'entre versions majeures (sinon, les extensions ou autres scripts se basant sur phpBB risquerait de cesser de fonctionner).

Je voudrais savoir d'où vous tenez l'info comme quoi phpBB 3.2 est prévu pour 2017. Actuellement, sa sortie est prévue courant 2016 (il est actuellement en alpha2 et devrais passer en beta puis RC rapidement :)).

Sinon, qu'est-ce qui empêche de rester en PHP 5.6 pendant ce temps ?

Edit : A propos de l'erreur actuelle, c'est que vous utilisez MySQL au lieu de MySQLi (choix proposé lors de l'installation).
Ça peut se résoudre en remplaçant la valeur de $dbms par phpbb\\db\\driver\\mysqli dans le config.php.

Par contre, vous risquez d'avoir d'autres erreurs pour les raisons invoquées ci-dessus.
[Doc] Installer une extension - [Extension] Post Models - [Recrutement] Équipe des Extensions
Si vous considérez votre requête comme résolue, merci d'ajouter l'attribut de sujet [Réglé]
Zoddo
Equipe site
Equipe site
 
Messages: 6300
Enregistré le: 16 Mar 2011 à 18:44
Localisation: /root/

Re: Toujours pas compatibilité avec PHP 7 avec phpBB 3.1.7pl1 ?

Messagepar Kewee » 16 Jan 2016 à 00:13

Bon vent alors ! En espérant que vous trouviez votre bonheur !
euh... je suis une fille, hein ? ok ? faites un effort ! arrêtez de dire "il" en parlant de moi, merci
Vous avez le droit d'aider si vous avez la réponse ou une piste, n'hésitez pas, on n'égorge pas les honnêtes gens ^^
Avatar de l’utilisateur
Kewee
Graphiste
Graphiste
 
Messages: 12219
Enregistré le: 01 Déc 2005 à 18:17
Localisation: mais mais mais... et vous voulez pas mon numéro aussi?

Re: Toujours pas compatibilité avec PHP 7 avec phpBB 3.1.7pl1 ?

Messagepar ignace72 » 16 Jan 2016 à 01:02

Merci à tous, le bonheur a été trouvé par le premier moteur de forum que j'ai trouvé (FluxBB).
À titre d'info j'utilise PHP 7 car c'est la dernière version stable de PHP et c'est comme ça pour tout les programmes sur mon ordinateur. Rien ne justifie que je change mes habitudes pour les beau yeux d'un programme.
ignace72
Posteur néophyte
Posteur néophyte
 
Messages: 40
Enregistré le: 07 Aoû 2014 à 21:30

Re: Toujours pas compatibilité avec PHP 7 avec phpBB 3.1.7pl1 ?

Messagepar Kewee » 16 Jan 2016 à 12:50

ah nan mais on est entièrement d'accord, on propose une solution, on ne l'impose pas ! :mrgreen:

Bonne aventure avec fluxBB :)
euh... je suis une fille, hein ? ok ? faites un effort ! arrêtez de dire "il" en parlant de moi, merci
Vous avez le droit d'aider si vous avez la réponse ou une piste, n'hésitez pas, on n'égorge pas les honnêtes gens ^^
Avatar de l’utilisateur
Kewee
Graphiste
Graphiste
 
Messages: 12219
Enregistré le: 01 Déc 2005 à 18:17
Localisation: mais mais mais... et vous voulez pas mon numéro aussi?

Re: Toujours pas compatibilité avec PHP 7 avec phpBB 3.1.7pl1 ?

Messagepar Aurelienazerty » 18 Jan 2016 à 13:01

Concernant la date de sortie de la 3.2, je confirme ce que dit Zoddo, il suffit de regarder sur cette page d'ailleurs https://www.phpbb.com/about/release/ la version Alpha 2 est sortie d'ailleurs.

Concernant le support de PHP 7, en effet, ça sera avec phpBB 3.2, avec le support de Emoji, je vous invite à lire ceci pour être complet : https://wiki.phpbb.com/Release_Highlights/3.2.0-a1
http://www.team-azerty.com Association organisatrice de LAN "fun" au sud de Lyon
Aurelienazerty
Apprenti-posteur
Apprenti-posteur
 
Messages: 141
Enregistré le: 20 Avr 2004 à 19:31


Retourner vers Mises à jour/Conversions

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité