[Réglé] Erreur lors du passage en 3.1.5 (TWIG)

Forum concernant les demandes de support pour tout problème de mise à jour d'un forum phpBB 3.1.x depuis une version antérieure ou d'une conversion de phpBB2 ou phpBB3 vers phpBB 3.1

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.

Re: Erreur lors du passage en 3.1.5 (TWIG)

Messagepar Skouat » 16 Aoû 2015 à 13:34

Non rien à voir avec le phpbb3_, quoi que soit dit en passant ca parait bizarre qu'il n'y ait pas eu d'erreur car normalement il aurait du y avoir une erreur concernant l'utilisation maxi du nombre de caractères pour les index de table.

Non inutile d'avoir un acces BDD.
Fais un export de la structure de la BDD, et pastebin le tout.
Mes MODS

Ultima-World Hébergé par phpBB-Services
Code parrainage : 1241646554
Skouat
Traducteur
Traducteur
 
Messages: 13493
Enregistré le: 02 Avr 2008 à 19:47

Re: Erreur lors du passage en 3.1.5 (TWIG)

Messagepar amorcage » 16 Aoû 2015 à 13:52

@Skouat
Voici la structure : http://pastebin.com/ADUGmLhR
amorcage
Posteur néophyte
Posteur néophyte
 
Messages: 38
Enregistré le: 09 Oct 2014 à 10:32

Re: Erreur lors du passage en 3.1.5 (TWIG)

Messagepar Skouat » 16 Aoû 2015 à 15:08

Résultat d'une comparaison entre un forum 3.1.5 neuf et ton forum

Il manque des champs dans phpbb3_forums, phpbb3_posts, phpbb3_profile_fields, phpbb3_reports et phpbb3_topics

Il y a des champs en trop dans la table phpbb3_users

Il y a des différences d'attribution de taille de champs dans phpbb3_groups, phpbb3_profile_fields_lang

Dans les champs de profils personnalisés phpbb3_profile_fields_data ne sont pas présents (a moins qu'ils aient été supprimés)

Les tables suivantes sont à supprimer :
  • phpbb3_styles_imageset
  • phpbb3_styles_imageset_data
  • phpbb3_styles_template
  • phpbb3_styles_template_data
  • phpbb3_styles_theme

Comme indiqué précédemment, la table phpbb3_styles n'est pas valide

Je ne te communique pas les différences, car tu as utilisé MySQLDumper et moi phpMyAdmin.

Voici la structure de phpBB 3.1.5 => http://pastebin.com/1dTP5XaF
Créé une nouvelle BDD et importe la structure puis exporte là avec MySQL Dumper, puis compare.

après à voir si avec le STK (non officiel) pour 3.1 tu peux corriger ton problème de style.
Mes MODS

Ultima-World Hébergé par phpBB-Services
Code parrainage : 1241646554
Skouat
Traducteur
Traducteur
 
Messages: 13493
Enregistré le: 02 Avr 2008 à 19:47

Re: Erreur lors du passage en 3.1.5 (TWIG)

Messagepar amorcage » 16 Aoû 2015 à 15:21

@Skouat : Non, j'ai bien utiliser phpmyadmin pour l'export ^^
Je vais voir avec le stk éventuellement oui :)
amorcage
Posteur néophyte
Posteur néophyte
 
Messages: 38
Enregistré le: 09 Oct 2014 à 10:32

Re: Erreur lors du passage en 3.1.5 (TWIG)

Messagepar Skouat » 16 Aoû 2015 à 15:30

amorcage a écrit:j'ai bien utiliser phpmyadmin pour l'export


Au temps pour moi... mon oeil n'a pas lu "Admin" dans le texte suivant : phpMyAdmin SQL Dump :oops:
Mes MODS

Ultima-World Hébergé par phpBB-Services
Code parrainage : 1241646554
Skouat
Traducteur
Traducteur
 
Messages: 13493
Enregistré le: 02 Avr 2008 à 19:47

Re: Erreur lors du passage en 3.1.5 (TWIG)

Messagepar amorcage » 16 Aoû 2015 à 15:36

Bon, j'ai remis le forum en 3.0.12 (et il me dit qu'il n'est pas à jour ^^)

J'ai passé un coup de STK sur la BDD (qui ma supprimé pas mal de trucs (d'ailleurs, j'ai plus accès à certaines partie du forum :roll: )

Je vais tenter la ré-importation et l'update :)

------------------------------------
EDIT 16h43

Bon, après avoir passé un coup de STK et supprimer pas mal de trucs de la base de données
J'ai relancé l'importation et elle marche bien :)
Effectivement, je sais pas pourquoi. Je pense à l'update de la BDD qui à foiré :(

Par contre, j'ai des catégorie qui ont sautés après le STK :(
Je les voit bien dans le PCA mais pas sur la page d'accueil :(

Une idée ?
------------------------
EDIT 17h13
Il semblerait que le forum ai récupéré les permissions des "users inscrits" au lieu de reprendre les permissions des groupes :(
Et j'aime pas gérer les permissions :'(
amorcage
Posteur néophyte
Posteur néophyte
 
Messages: 38
Enregistré le: 09 Oct 2014 à 10:32

Re: Erreur lors du passage en 3.1.5 (TWIG)

Messagepar Skouat » 16 Aoû 2015 à 16:44

amorcage a écrit:Il semblerait que le forum ai récupéré les permissions des "users inscrits" au lieu de reprendre les permissions des groupes

Sans doute une conséquence du nettoyage de la BDD.

amorcage a écrit:Et j'aime pas gérer les permissions :'(

Ce n'est pas compliqué du moment que l'on ne s'amuse pas à assigner des permissions directement à un membre.
Il est très vivement recommandé de créer des groupes pour chaque catégorie de permissions à définir.
Certes ca va faire beaucoup de groupe, mais après en lisibilité c'est plus rapide pour agir et savoir qui a accès à quoi.

Mais bon... Ceci n'est pas le sujet.

Si vous considérez votre requête comme résolue, merci d'ajouter l'attribut de sujet [Réglé] :wink:
Mes MODS

Ultima-World Hébergé par phpBB-Services
Code parrainage : 1241646554
Skouat
Traducteur
Traducteur
 
Messages: 13493
Enregistré le: 02 Avr 2008 à 19:47

Re: Erreur lors du passage en 3.1.5 (TWIG)

Messagepar amorcage » 16 Aoû 2015 à 16:54

Oui, je vais ouvrir un autre sujet car je me perds dans les permissions de phpbb :( Il me faut de l'aide :$
Je suis plus habitué à InvisionPowerBoard :)

Merci encore pour ton aide @Skouat :)
amorcage
Posteur néophyte
Posteur néophyte
 
Messages: 38
Enregistré le: 09 Oct 2014 à 10:32

Re: Erreur lors du passage en 3.1.5 (TWIG)

Messagepar galixte » 18 Aoû 2015 à 03:26

Communau EzCom
Image
« Traductions d’extensions & styles pour phpBB 3.1.x & 3.2.x ».
ImageListes de toutes les extensions recensées pour phpBB 3.1.x & 3.2.x.
ImageListes de tous les styles recensés pour phpBB 3.1.x & 3.2.x.
Avatar de l’utilisateur
galixte
Floodeur universel
Floodeur universel
 
Messages: 10068
Enregistré le: 08 Mar 2004 à 01:40
Localisation: Sud de la France.

Re: Erreur lors du passage en 3.1.5 (TWIG)

Messagepar amorcage » 18 Aoû 2015 à 07:55

@Galixte : C'est pas mal :) Merci :)
amorcage
Posteur néophyte
Posteur néophyte
 
Messages: 38
Enregistré le: 09 Oct 2014 à 10:32

Précédente

Retourner vers Mises à jour/Conversions

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 2 invités