[Réglé] Page blanche Administration après mise à jour 3.0.14 vers 3.1.5

Forum concernant les demandes de support pour tout problème de mise à jour d'un forum phpBB 3.1.x depuis une version antérieure ou d'une conversion de phpBB2 ou phpBB3 vers phpBB 3.1

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.

[Réglé] Page blanche Administration après mise à jour 3.0.14 vers 3.1.5

Messagepar Lorand » 12 Aoû 2015 à 16:33

Bonjour,

J'ai effectué la mise à jour de mon Forum, depuis la version 3.0.14 vers la version 3.1.5 en suivant les étapes indiquées sur http://forums.phpbb-fr.com/documentation/mise-a-jour/31x-mise-a-niveau-de-phpbb-30x-vers-31x-a209-view.html.

Si l'index de mon Forum s'affiche bien après la mise à jour, il n'en n'est pas de même pour l'Administration car je me trouve face à une page blanche.

- Mon style est bien "prosilver", j'ai vérifié si tout était ok à ce niveau via mon Phpmyadmin.
- J'ai tenté d'utiliser Support Toolkit (STK) et lors que je le lance, voici ce que je vois :

Image



Adresse du Forum : http://forum.android-logiciels.fr

Merci par avance si vous pouvez m'aider :)
Avatar de l’utilisateur
Lorand
Posteur néophyte
Posteur néophyte
 
Messages: 65
Enregistré le: 28 Mai 2004 à 00:37

Re: Page blanche Administration après mise à jour 3.0.14 vers 3.1.5

Messagepar Zoddo » 12 Aoû 2015 à 16:56

Bonjour,

Le STK n'est pas compatible pour le moment avec phpBB 3.1.x.

Dans le fichier config.php, si vous enlevez les deux slashs au début de cette ligne, des erreurs s'affichent-elles lorsque vous tentez d'accéder à l'admin ?
Code: Tout sélectionner
@define('DEBUG'true); 

Pensez à remettre les deux slashs ensuite pour désactiver le debug.
[Doc] Installer une extension - [Extension] Post Models - [Recrutement] Équipe des Extensions
Si vous considérez votre requête comme résolue, merci d'ajouter l'attribut de sujet [Réglé]
Zoddo
Equipe site
Equipe site
 
Messages: 7076
Enregistré le: 16 Mar 2011 à 17:44
Localisation: Laval

Re: Page blanche Administration après mise à jour 3.0.14 vers 3.1.5

Messagepar Lorand » 12 Aoû 2015 à 17:14

Bonjour Zoddo,

Merci beaucoup pour votre réponse.
J'ai retiré les deux slashs du config.php, et le problème reste le même. J'ai toujours une page blanche, sans aucune erreur affichée lorsque j'essaye d'accéder à l'admin.
Avatar de l’utilisateur
Lorand
Posteur néophyte
Posteur néophyte
 
Messages: 65
Enregistré le: 28 Mai 2004 à 00:37

Re: Page blanche Administration après mise à jour 3.0.14 vers 3.1.5

Messagepar Zoddo » 12 Aoû 2015 à 17:34

Avez-vous eu une page de connexion avant d'avoir la page blanche ou pas ?
[Doc] Installer une extension - [Extension] Post Models - [Recrutement] Équipe des Extensions
Si vous considérez votre requête comme résolue, merci d'ajouter l'attribut de sujet [Réglé]
Zoddo
Equipe site
Equipe site
 
Messages: 7076
Enregistré le: 16 Mar 2011 à 17:44
Localisation: Laval

Re: Page blanche Administration après mise à jour 3.0.14 vers 3.1.5

Messagepar Lorand » 12 Aoû 2015 à 17:36

Merci pour votre réponse.

Si je suis déconnecté du Forum, que je m'identifie ensuite en tant que membre et que j'essaye d'aller dans l'admin = Oui j'ai la page d'identification et de connexion admin. Après avoir validé ces informations, j'arrive sur une page blanche.

Si je suis déjà connecté sur le Forum en tant que membre et que je tente d'aller dans l'admin = je tombe directement sur une page blanche.
Avatar de l’utilisateur
Lorand
Posteur néophyte
Posteur néophyte
 
Messages: 65
Enregistré le: 28 Mai 2004 à 00:37

Re: Page blanche Administration après mise à jour 3.0.14 vers 3.1.5

Messagepar Zoddo » 12 Aoû 2015 à 17:39

Dans ce cas, essayez de réenvoyer les dossiers /adm et /includes/acp puis vider le cache (il suffit pour cela de supprimer tous les fichiers contenues dans dans le dossier /cache excepter index.htm & .htaccess).
[Doc] Installer une extension - [Extension] Post Models - [Recrutement] Équipe des Extensions
Si vous considérez votre requête comme résolue, merci d'ajouter l'attribut de sujet [Réglé]
Zoddo
Equipe site
Equipe site
 
Messages: 7076
Enregistré le: 16 Mar 2011 à 17:44
Localisation: Laval

Re: Page blanche Administration après mise à jour 3.0.14 vers 3.1.5

Messagepar Lorand » 12 Aoû 2015 à 17:46

Merci pour votre réponse.

C'est fait, le problème est hélas toujours présent :|
Avatar de l’utilisateur
Lorand
Posteur néophyte
Posteur néophyte
 
Messages: 65
Enregistré le: 28 Mai 2004 à 00:37

Re: Page blanche Administration après mise à jour 3.0.14 vers 3.1.5

Messagepar Zoddo » 12 Aoû 2015 à 17:52

Téléchargez cette version du STK pour phpBB 3.1.x (non officiel, fait par un utilisateur de phpBB). Ensuite, exécutez l'outil permettant de recréer les modules de l'administration.
[Doc] Installer une extension - [Extension] Post Models - [Recrutement] Équipe des Extensions
Si vous considérez votre requête comme résolue, merci d'ajouter l'attribut de sujet [Réglé]
Zoddo
Equipe site
Equipe site
 
Messages: 7076
Enregistré le: 16 Mar 2011 à 17:44
Localisation: Laval

Re: Page blanche Administration après mise à jour 3.0.14 vers 3.1.5

Messagepar Lorand » 12 Aoû 2015 à 18:17

Merci pour votre réponse.

Rien n'y fait, j'ai toujours le même problème.
J'ai essayé de faire un peu de nettoyage avec cette version STK mais ça ne change rien.

Je pense que je vais revenir à mon ancienne version 3.0.14 :)
Avatar de l’utilisateur
Lorand
Posteur néophyte
Posteur néophyte
 
Messages: 65
Enregistré le: 28 Mai 2004 à 00:37

Re: Page blanche Administration après mise à jour 3.0.14 vers 3.1.5

Messagepar Zoddo » 12 Aoû 2015 à 18:35

Avant de faire ça, avez-vous accès à des journaux d'erreurs sur votre hébergement ? (généralement dans un dossier logs ou un fichier error_log sur le FTP ou bien par le biais du panel de l'hébergeur)
[Doc] Installer une extension - [Extension] Post Models - [Recrutement] Équipe des Extensions
Si vous considérez votre requête comme résolue, merci d'ajouter l'attribut de sujet [Réglé]
Zoddo
Equipe site
Equipe site
 
Messages: 7076
Enregistré le: 16 Mar 2011 à 17:44
Localisation: Laval

Re: Page blanche Administration après mise à jour 3.0.14 vers 3.1.5

Messagepar Lorand » 12 Aoû 2015 à 18:38

Je ne sais pas si ça peut vous aider, lorsque j'utilise STK et que je vais dans "Outils pour les administrateurs" / "Paramètres de configuration", et que je tente ensuite d'aller sur la page 3 (sur un total de 13 pages), j'ai ce message d'erreur :


Code: Tout sélectionner
Fatal error: Uncaught exception 'Exception' with message 'DateTime::__construct(): Failed to parse time string (@2013-12-18 20:00:01) at position 8 (-): Double timezone specification' in /var/www/mon_chemin/forum.android-logiciels.fr/phpbb/datetime.php:50 Stack trace: #0 /var/www/mon_chemin/forum.android-logiciels.fr/phpbb/datetime.php(50): DateTime->__construct('@2013-12-18 20:...', Object(DateTimeZone)) #1 /var/www/mon_chemin/forum.android-logiciels.fr/phpbb/user.php(720): phpbb\datetime->__construct(Object(phpbb\user), '@2013-12-18 20:...', Object(DateTimeZone)) #2 /var/www/mon_chemin/forum.android-logiciels.fr/stk/tools/admin/config_list.php(356): phpbb\user->format_date('2013-12-18 20:0...', '|d M Y|, H:i:s') #3 /var/www/mon_chemin/forum.android-logiciels.fr/stk/index.php(305): config_list->display_options() #4 {main} thrown in /var/www/mon_chemin/forum.android-logiciels.fr/phpbb/datetime.php on line 50


Error 1: Uncaught exception 'Exception' with message 'DateTime::__construct(): Failed to parse time string (@2013-12-18 20:00:01) at position 8 (-): Double timezone specification' in /var/www/mon_chemin/forum.android-logiciels.fr/phpbb/datetime.php:50 Stack trace: #0 /var/www/mon_chemin/forum.android-logiciels.fr/phpbb/datetime.php(50): DateTime->__construct('@2013-12-18 20:...', Object(DateTimeZone)) #1 /var/www/mon_chemin/forum.android-logiciels.fr/phpbb/user.php(720): phpbb\datetime->__construct(Object(phpbb\user), '@2013-12-18 20:...', Object(DateTimeZone)) #2 /var/www/mon_chemin/forum.android-logiciels.fr/stk/tools/admin/config_list.php(356): phpbb\user->format_date('2013-12-18 20:0...', '|d M Y|, H:i:s') #3 /var/www/mon_chemin/forum.android-logiciels.fr/stk/index.php(305): config_list->display_options() #4 {main} thrown at file /var/www/mon_chemin/forum.android-logiciels.fr/phpbb/datetime.php line 50
Avatar de l’utilisateur
Lorand
Posteur néophyte
Posteur néophyte
 
Messages: 65
Enregistré le: 28 Mai 2004 à 00:37

Re: Page blanche Administration après mise à jour 3.0.14 vers 3.1.5

Messagepar Skouat » 12 Aoû 2015 à 18:45

Bonjour,

Sauf erreur de ma part, le fichier datetime.php ne fait pas partie de phpBB.
Rapatriez le localement sur votre PC et supprimez le du serveur.
Skouat
Resp. Traducteurs
Resp. Traducteurs
 
Messages: 14769
Enregistré le: 02 Avr 2008 à 19:47

Re: Page blanche Administration après mise à jour 3.0.14 vers 3.1.5

Messagepar Lorand » 12 Aoû 2015 à 18:47

Zoddo a écrit:Avant de faire ça, avez-vous accès à des journaux d'erreurs sur votre hébergement ? (généralement dans un dossier logs ou un fichier error_log sur le FTP ou bien par le biais du panel de l'hébergeur)


Oui je suis en train de le consulter, il y a de nombreuses erreurs du style :

Wed Aug 12 16:48:55 2015] [warn] [client xxxxx] mod_fcgid: stderr: PHP Warning: include(./common.php): failed to open stream: No such file or directory in /var/www/mon_chemin/forum.android-logiciels.fr/app.php on line 23, referer: http://forum.android-logiciels.fr/adm/i ... 828d4&i=27



Ça m'ennuie de le mettre en ligne car il y a des adresses IP, la mienne principalement.
Avatar de l’utilisateur
Lorand
Posteur néophyte
Posteur néophyte
 
Messages: 65
Enregistré le: 28 Mai 2004 à 00:37

Re: Page blanche Administration après mise à jour 3.0.14 vers 3.1.5

Messagepar Zoddo » 12 Aoû 2015 à 18:48

@Skouat : Si il fait parti de phpBB 3.1.x ... https://github.com/phpbb/phpbb/blob/3.1 ... tetime.php

@Lorand : Que retourne cette requête ?
Code: Tout sélectionner
SELECT *  FROM phpbb_config
WHERE config_name = 'board_startdate'


Edit : 16:48:55 ne correspondrait pas à l'heure ou vous avez fait la mise à jour ? Il faudrait regarder dans les toutes dernières lignes.
[Doc] Installer une extension - [Extension] Post Models - [Recrutement] Équipe des Extensions
Si vous considérez votre requête comme résolue, merci d'ajouter l'attribut de sujet [Réglé]
Zoddo
Equipe site
Equipe site
 
Messages: 7076
Enregistré le: 16 Mar 2011 à 17:44
Localisation: Laval

Re: Page blanche Administration après mise à jour 3.0.14 vers 3.1.5

Messagepar Lorand » 12 Aoû 2015 à 18:51

Skouat a écrit:Bonjour,

Sauf erreur de ma part, le fichier datetime.php ne fait pas partie de phpBB.
Rapatriez le localement sur votre PC et supprimez le du serveur.


C'est fait, et cette fois je n'ai plus rien du tout :)

Si je tente avec le STK, j'ai ceci :

Code: Tout sélectionner
Fatal error: Class '\phpbb\datetime' not found in /var/www/mon_chemin/forum.android-logiciels.fr/phpbb/user.php on line 720
Error 1: Class '\phpbb\datetime' not found at file /var/www/mon_chemin/forum.android-logiciels.fr/phpbb/user.php line 720
Avatar de l’utilisateur
Lorand
Posteur néophyte
Posteur néophyte
 
Messages: 65
Enregistré le: 28 Mai 2004 à 00:37

Suivante

Retourner vers Mises à jour/Conversions

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 2 invités