FORUM complétement planté après Mise à jour 3.0.12 > 3.1.3

Forum concernant les demandes de support pour tout problème de mise à jour d'un forum phpBB 3.1.x depuis une version antérieure ou d'une conversion de phpBB2 ou phpBB3 vers phpBB 3.1

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.
Partager sur FacebookPartager sur TwitterPartager sur Google+

FORUM complétement planté après Mise à jour 3.0.12 > 3.1.3

Messagepar CFox » 13 Juin 2015 à 17:03

Bonjour à tous,

Alors je viens vers vous car je suis complétement paumé suite à une mise à jour qui de prime abord semble s'être pas très bien passé... :(

Tout fonctionnait bien avant la mise à jour.
Cela dit, tout le monde me recommandait cette mise à jour, j'ai donc fais.
J'ai suivi à la lettre le petit tuto permettant de passer de la 3.0.12 à la 3.1.3.

J'ai tout respecté SAUF remplacer le dossier style (car j'avais un style hyper travaillé et j'avais peur de le paumer)
Une fois fait, tout semblait s'être bien passé sauf qu'évidemment, plus moyen de mettre mon ancien style etc.

J'ai donc procédé une 2ème fois à une restaure de cette mise à jour à demi réussie, et là... catastrophe.
Le forum semble bien être mis à jour, mais plus aucun lien vers la BDD !

On peut lire en bas : Total posts 39489 • Total topics 1937 • Total members 1111 • Our newest member wotoadgi

Mais tous les topics, les posts sont notés comme "0". Et plus rien n'est présent !
Je n'arrive plus à me connecter à mon panneau d'admin car dès que je me log, bien qu'il me reconnaisse connecté (dans les membres apparaissant comme connectés en bas de forum), j'ai toujours la possibilité de me loger...
Donc en gros je suis connecté, sans être connecté.

Bref, je me demande s'il y a pas eu un gros bug sur le index.php ou le htaccess.

J'ai du coup fait appeler à mon hébergeur 1&1 pour m'aider à une restauration antérieure sauf qu'étant sur un serveur dédié ils m'ont fait un backup jusqu'à une date égale à la date de mise à jour. Donc je ne sais même pas ce que comprend ce backup s'il a été fait AVANT ou APRÈS la MAJ ratée...

Mais rien à faire me concernant.
Je les ai rappelé, et malgré leurs efforts : ils m'ont dit qu'ils ne pouvaient rien faire (ou ne connaissaient pas je pense...)

Du coup vous êtes mon dernier espoir... (car oui je n'ai pas de sauvegarde, pas besoin de me dire qu'il fallait je le sais :/)

Voici le lien du forum : http://forum.dragonball-ultimate.com/
Si vous arrivez à me sauver ça, car j'avais un forum hyper bien référencé, vous êtes des rois...

MERCI à tous d'avance !
CFox
Posteur néophyte
Posteur néophyte
 
Messages: 27
Enregistré le: 07 Fév 2013 à 20:35

Re: FORUM complétement planté après Mise à jour 3.0.12 > 3.1.3

Messagepar FoFa » 14 Juin 2015 à 00:53

Bonsoir,

Bienvenu !

Normalement 1&1 a des sauvegardes d'une semaine en arrière nan ? Sauvegardes disponibles également normalement via votre espace client ???

Il faut déjà regarder la poids de la sauvegarde mise en place par 1&1 et le poids de votre mise à jour à moitié réussie.
Après l'assassinat de mon ordinateur, je reviens progressivement vers vous...
FoFa
Resp. des supporters
Resp. des supporters
 
Messages: 10565
Enregistré le: 15 Nov 2008 à 19:04
Localisation: Auxonne

Re: FORUM complétement planté après Mise à jour 3.0.12 > 3.1.3

Messagepar Manard » 14 Juin 2015 à 10:37

Bonjour CFox,


Quand tu parles de restauration, c'est la base de données et/ou ton installation de phpBB 3 sur le serveur ? S'ils ont restauré la base de données de ton forum en 3.0.x comme ça semble être le cas, il est normal que tu ne puisses la voir avec une installation en 3.1.4 sur le serveur, car là l'affichage correspond à la version 3.1

Je t'engage à faire une sauvegarde de cette base depuis phpMyAdmin ce sera déjà une bonne chose. Avais-tu des Mods d'installés en 3.0.x, si tel est le cas il faudra re-installer une version 3.0 correspondante à celle qui était en place pour la nettoyer avec l'outil STK, c'est expliqué dans le tutoriel de Jester : documentation/mise-a-jour/31x-mise-a-niveau-de-phpbb-30x-vers-31x-a209-view.html

Bon dimanche et bonne remise en état

Bernard
Manard
Roi des posts
Roi des posts
 
Messages: 921
Enregistré le: 31 Mar 2012 à 09:24

Re: FORUM complétement planté après Mise à jour 3.0.12 > 3.1.3

Messagepar CFox » 15 Juin 2015 à 14:32

@Fofa : Ils ont tenté de demander aux admins plus haut (d'après leurs dires) une save la plus lointaine. Ils sont remontés à la date à laquelle la mise à jour a été faite, mais l'heure, je n'en sais rien... Si cela tombe soit elle est bien avant soit après. :/

@Manard : C'est la BDD je pense. Vu que mes fichiers sont en .sql. Sauf qu'ils n'ont "rien" mis en place. C'est à dire qu'ils ont crée un dossier "backup" à ma racine FTP, au sein duquel je retrouve ces sql. C'est pourquoi, dans l'idée je comprends du coup l'histoire d'une BDD 3.0.X avec un affichage 3.1.3 non compatible. Mais vu que rien n'a été fait, est ce le problème ? :/

Sinon je viens de sauvegarder la base dpuis phpMyAdmin. J'avais des mods oui, mais je peux les supprimer je les remettrai plus tard selon compatibilité.
Je peux écraser la version actuelle par une version antérieure ?
Comment procéder vu que j'avais suivi le tuto que tu m'as donné :

Mettre à niveau phpBB :

Téléchargez et décompressez l'archive du pack complet phpBB 3.1.x
Supprimez du pack :
Le fichier config.php
le répertoire images/
le répertoire files/
le répertoire store/
Depuis votre serveur, supprimez le contenu du répertoire racine de votre forum excepté :
le fichier config.php
le répertoire images/
le répertoire files/
le répertoire store/

Je suis paumé là :/
Une fois fait, je ferai en sorte de nettoyer le tout avec STK comme tu me l'as conseillé.

Bonne semaine et merci de votre aide !
CFox
Posteur néophyte
Posteur néophyte
 
Messages: 27
Enregistré le: 07 Fév 2013 à 20:35

Re: FORUM complétement planté après Mise à jour 3.0.12 > 3.1.3

Messagepar Skouat » 18 Juin 2015 à 00:22

Bonjour,

L'utilisation de l'outil STK est à effectuer AVANT de migrer en phpBB 3.1
Mes MODS

Ultima-World Hébergé par phpBB-Services
Code parrainage : 1241646554
Skouat
Traducteur
Traducteur
 
Messages: 13629
Enregistré le: 02 Avr 2008 à 20:47

Re: FORUM complétement planté après Mise à jour 3.0.12 > 3.1.3

Messagepar CFox » 19 Juin 2015 à 23:01

J'ai scruté la base et la table topic est vide. Qu'en pensez vous ?

Avec manard nous avons passé beaucoup de temps à reprendre une install sur wampserver en local.
On est donc reparti sur une 3.0.12 > réinjection du dump bdd > nettoyage STK > résultat : on obtient cela =

Image

Image

C’est un poil mieux car le nombre de posts et topics n'est plus à 0 mais s'est mis à jour.
Le problème est que nous n'avons pas du tout accès aux topics depuis le début !
On obtient une ou des pages vides correspondants aux nombres initiaux de topics (voir screenshot)
Pourtant on voit bien le nombre de pages correspondant aux nombre de topics également.

Un vrai casse tête.

Ce point reste un mystère, je compte sur vous.

Merci beaucoup d'avance
CFox
Posteur néophyte
Posteur néophyte
 
Messages: 27
Enregistré le: 07 Fév 2013 à 20:35

Re: FORUM complétement planté après Mise à jour 3.0.12 > 3.1.3

Messagepar FoFa » 19 Juin 2015 à 23:04

Je peux avoir la sauvegarde de votre forum via MP svp ?
Après l'assassinat de mon ordinateur, je reviens progressivement vers vous...
FoFa
Resp. des supporters
Resp. des supporters
 
Messages: 10565
Enregistré le: 15 Nov 2008 à 19:04
Localisation: Auxonne

Re: FORUM complétement planté après Mise à jour 3.0.12 > 3.1.3

Messagepar CFox » 19 Juin 2015 à 23:06

Je te fais ça tu peux venir sur skype si tu veux aussi
Nous sommes en conférence avec Manard vu qu'on est dessus :)
CFox
Posteur néophyte
Posteur néophyte
 
Messages: 27
Enregistré le: 07 Fév 2013 à 20:35

Re: FORUM complétement planté après Mise à jour 3.0.12 > 3.1.3

Messagepar CFox » 19 Juin 2015 à 23:11

Envoyé
CFox
Posteur néophyte
Posteur néophyte
 
Messages: 27
Enregistré le: 07 Fév 2013 à 20:35

Re: FORUM complétement planté après Mise à jour 3.0.12 > 3.1.3

Messagepar FoFa » 19 Juin 2015 à 23:13

Merci de ne faire des UPs que toutes les 24 heures minimum !

Je vais regarder.

Je n'ai pas Skype :wink:
Après l'assassinat de mon ordinateur, je reviens progressivement vers vous...
FoFa
Resp. des supporters
Resp. des supporters
 
Messages: 10565
Enregistré le: 15 Nov 2008 à 19:04
Localisation: Auxonne

Re: FORUM complétement planté après Mise à jour 3.0.12 > 3.1.3

Messagepar galixte » 19 Juin 2015 à 23:17

Je peux me joindre à vous ? :mrgreen:
Communau EzCom
Image
« Traductions d’extensions & styles pour phpBB 3.1.x & 3.2.x ».
ImageListes de toutes les extensions recensées pour phpBB 3.1.x & 3.2.x.
ImageListes de tous les styles recensés pour phpBB 3.1.x & 3.2.x.
Avatar de l’utilisateur
galixte
Floodeur universel
Floodeur universel
 
Messages: 10097
Enregistré le: 08 Mar 2004 à 02:40
Localisation: Sud de la France.

Re: FORUM complétement planté après Mise à jour 3.0.12 > 3.1.3

Messagepar FoFa » 19 Juin 2015 à 23:20

Tu es déjà parmi nous, là :wink:
Après l'assassinat de mon ordinateur, je reviens progressivement vers vous...
FoFa
Resp. des supporters
Resp. des supporters
 
Messages: 10565
Enregistré le: 15 Nov 2008 à 19:04
Localisation: Auxonne

Re: FORUM complétement planté après Mise à jour 3.0.12 > 3.1.3

Messagepar CFox » 19 Juin 2015 à 23:22

Tu veux dire par Skype ? Si oui MP :)
CFox
Posteur néophyte
Posteur néophyte
 
Messages: 27
Enregistré le: 07 Fév 2013 à 20:35

Re: FORUM complétement planté après Mise à jour 3.0.12 > 3.1.3

Messagepar FoFa » 19 Juin 2015 à 23:25

CFox, tu m'as donné quelle version ? Celle après ta tentative de migration ? Car là je vois des tables 3.1.x

As-tu une sauvegarde 3.0.x de AVANT ta tentative de migration ?
Après l'assassinat de mon ordinateur, je reviens progressivement vers vous...
FoFa
Resp. des supporters
Resp. des supporters
 
Messages: 10565
Enregistré le: 15 Nov 2008 à 19:04
Localisation: Auxonne

Re: FORUM complétement planté après Mise à jour 3.0.12 > 3.1.3

Messagepar CFox » 19 Juin 2015 à 23:28

Je t'ai filé le .dump le plus ancien que 1&1, mon hébergeur, a pu me filer. J'avais vérifié avec manard on y voyait en ligne 344 d'un fichier (je ne sais plus lequel) 'version 3.0.12'
Je comprends plus rien là :/
CFox
Posteur néophyte
Posteur néophyte
 
Messages: 27
Enregistré le: 07 Fév 2013 à 20:35

Suivante

Retourner vers Mises à jour/Conversions

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité