[Réglé] Perte d'avatars dans la migration

Forum concernant les demandes de support pour tout problème de mise à jour d'un forum phpBB 3.1.x depuis une version antérieure ou d'une conversion de phpBB2 ou phpBB3 vers phpBB 3.1

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.

[Réglé] Perte d'avatars dans la migration

Messagepar Dr_Sbaitso » 13 Mai 2015 à 15:45

Hello,
J'ai un problème depuis la migration vers 3.1.x depuis 3.0.17 (je crois)
Les avatars de mes utilisateurs ont disparus.
J'ai bien tout importé dans /images/avatars/upload
J'ai bien tout vidé le cache
J'ai bien tout les noms .jpg dans la bdd

Mais le nom local du type 06352fds993217be14593219568a45cbeb_54.jpg n'est plus accessible depuis le 54_153344540.jpg stocké en base.

Y'a t-il un truc de plus à faire ?
Comme je suis en local, je pensais peut être à un problème de génération de vignettes (genre GD ou imagemagick qui n'est pas paramétré pareil ?)
Merci de votre aide.
A+
Modifié en dernier par Dr_Sbaitso le 13 Mai 2015 à 15:50, modifié 1 fois.
Dr_Sbaitso
Posteur néophyte
Posteur néophyte
 
Messages: 23
Enregistré le: 20 Avr 2015 à 16:15

Re: Merci de modifier le titre du sujet afin qu'il soit plus explicite.

Messagepar Steph » 13 Mai 2015 à 15:49

[Titre d'origine : Ouuh ouhh Avatar ?]

Salut ,

Selon le point 1.3.4 de nos conditions générales d’utilisation nous te remercions de bien vouloir éditer le titre de ton premier message et d'y inscrire un titre explicite.

@+ :wink:
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 18198
Enregistré le: 29 Déc 2008 à 16:48
Localisation: Alsace / Bas-Rhin / France

Re: Perte d'avatars dans la migration

Messagepar Dr_Sbaitso » 22 Mai 2015 à 11:44

Bonjour,

Donc je me réponds à moi-même.
Mon problème est résolu, il faut non seulement passer à 777 le dossier upload de "avatars" comme spécifié dans la doc et dans le pca mais aussi vérifier le propriétaire !!!
Dans mon cas de dev local, le propriétaire avait logiquement basculé vers "moi:moi" je suis donc passé à www-data pour le dossier.

Sous linux, faire un "sudo chown -R www-data:www-data upload/ "

Et ça roule ;)
Dr_Sbaitso
Posteur néophyte
Posteur néophyte
 
Messages: 23
Enregistré le: 20 Avr 2015 à 16:15

Re: Perte d'avatars dans la migration

Messagepar cabot » 22 Mai 2015 à 11:46

Merci pour le retour d'infos. :)
Image
Avatar de l’utilisateur
cabot
Equipe site
Equipe site
 
Messages: 26796
Enregistré le: 13 Fév 2011 à 20:42
Localisation: Rarement sur la plaque


Retourner vers Mises à jour/Conversions

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité

cron