[Réglé] Pré-requis migration vers 3.1.3

Forum concernant les demandes de support pour tout problème de mise à jour d'un forum phpBB 3.1.x depuis une version antérieure ou d'une conversion de phpBB2 ou phpBB3 vers phpBB 3.1

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.
Partager sur FacebookPartager sur TwitterPartager sur Google+

[Réglé] Pré-requis migration vers 3.1.3

Messagepar noftal » 08 Fév 2015 à 15:26

Bonjour
Dans le tuto de mise à jour, je lis :

La fonction getimagesize() doit être activée.
L'extension PHP JSON doit être activée.


Comment fait-on pour s'en assurer ?
Modifié en dernier par noftal le 09 Fév 2015 à 23:55, modifié 1 fois.
noftal
Apprenti-posteur
Apprenti-posteur
 
Messages: 123
Enregistré le: 23 Jan 2014 à 15:32

Re: Pré-requis migration vers 3.1.3

Messagepar Skouat » 08 Fév 2015 à 15:35

Bonjour,

Sur votre serveur en production, vous créez un répertoire temporaire nommé, par exemple, phpBB31_test et vous y copier les sources du pack complet de 3.1

Vous simuler une nouvelle installation et vous verrez si tous les prerequis sont valides (n'allez pas jusqu'au bout de l'installation, arrêtez vous à la verification des prérequis).

Une fois le contrôle effectué, supprimez le répertoire phpBB31_test
Mes MODS

Ultima-World Hébergé par phpBB-Services
Code parrainage : 1241646554
Skouat
Traducteur
Traducteur
 
Messages: 13493
Enregistré le: 02 Avr 2008 à 19:47

Re: Pré-requis migration vers 3.1.3

Messagepar noftal » 08 Fév 2015 à 15:53

J'ai uploadé la version 3.1.3 dans un répertoire phpBB31_test et j'ai lancé http://monsite.com/phpBB31_test/install ... update.php

EDIT : je n'ai pas changé d'un iota les fichiers du pack, notamment le config.php
J'obtiens le message suivant qui apparaît dans une page web blanche :

Please read: INSTALL.html before attempting to update.


Que faut-il faire ?
noftal
Apprenti-posteur
Apprenti-posteur
 
Messages: 123
Enregistré le: 23 Jan 2014 à 15:32

Re: Pré-requis migration vers 3.1.3

Messagepar Skouat » 08 Fév 2015 à 16:21

Bonjour,

Pour obtenir un support plus efficace, merci de préciser l'URL de votre forum.
Mes MODS

Ultima-World Hébergé par phpBB-Services
Code parrainage : 1241646554
Skouat
Traducteur
Traducteur
 
Messages: 13493
Enregistré le: 02 Avr 2008 à 19:47

Re: Pré-requis migration vers 3.1.3

Messagepar noftal » 08 Fév 2015 à 16:46

La racine est bacchantis.webou.net
J'ai tenté de remplacer mon ancien forum 3.0.12 par un 3.1.3 en suivant le tuto de mise à jour, dans bacchantis.webou.net/forum
J'ai un message d'erreur lors du lancement de database_upddate.php.

Fatal error: Invalid opcode 153/1/8. in /home/noftal/public_html/forum/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/ParameterBag/ParameterBag.php on line 239


Suspectant un pb de pré-requis, j'ai posté ce topic.

J'ai donc uploadé les fichiers du pack 3.1.3 (EDIT : pack complet) dans : bacchantis.webou.net/forum2
Mais en lançant bacchantis.webou.net/forum2/install, j'ai le message :

Fatal error: Invalid opcode 153/1/8. in /home/noftal/public_html/forum2/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/ParameterBag/ParameterBag.php on line 239


Si je fais bacchantis.webou.net/forum2/install/database_update.php, j'ai le message :

Please read: INSTALL.html before attempting to update.
Modifié en dernier par noftal le 08 Fév 2015 à 17:34, modifié 1 fois.
noftal
Apprenti-posteur
Apprenti-posteur
 
Messages: 123
Enregistré le: 23 Jan 2014 à 15:32

Re: Pré-requis migration vers 3.1.3

Messagepar FoFa » 08 Fév 2015 à 17:05

Salut

À la fin faut install/install.php et non pas install/database_update.php
Après l'assassinat de mon ordinateur, je reviens progressivement vers vous...
FoFa
Resp. des supporters
Resp. des supporters
 
Messages: 10378
Enregistré le: 15 Nov 2008 à 18:04
Localisation: Auxonne

Re: Pré-requis migration vers 3.1.3

Messagepar noftal » 08 Fév 2015 à 17:16

install/install.php n'existe pas.
noftal
Apprenti-posteur
Apprenti-posteur
 
Messages: 123
Enregistré le: 23 Jan 2014 à 15:32

Re: Pré-requis migration vers 3.1.3

Messagepar sub60 » 08 Fév 2015 à 17:23

Salut,

Relis le sujet de SKouat support-mises-a-jour-conversions-phpbb31/sujet203636.html#p1591444

l'idée est bien de tester les prérequis lors d'une nouvelle installation, donc il faut télécharger un pack complet, et non un pack de mise a jour :roll:
<< Comment poster au bon endroit sur phpbb-fr >>
Attention..!! les styles pour phpBB 3.0, ne sont pas compatible avec phpBB 3.1
Sur phpBB 3.1, pour rafraîchir le style il suffit de vider le cache du forum.
Si vous considérez votre requête comme résolue, merci d'ajouter l'attribut de sujet [Réglé]
Avatar de l’utilisateur
sub60
Floodeur universel
Floodeur universel
 
Messages: 9518
Enregistré le: 19 Juin 2006 à 14:14
Localisation: oise

Re: Pré-requis migration vers 3.1.3

Messagepar FoFa » 08 Fév 2015 à 17:26

Avec un pack complet l'installation se lance toute seule lorsque tu te rends sur le forum non installé
Après l'assassinat de mon ordinateur, je reviens progressivement vers vous...
FoFa
Resp. des supporters
Resp. des supporters
 
Messages: 10378
Enregistré le: 15 Nov 2008 à 18:04
Localisation: Auxonne

Re: Pré-requis migration vers 3.1.3

Messagepar noftal » 08 Fév 2015 à 17:30

C'est bien le pack complet que j'ai téléchargé depuis ce même lien et installé dans /forum2.
Je n'arrive pas à lancer l'installation. Y arrivez-vous ?
noftal
Apprenti-posteur
Apprenti-posteur
 
Messages: 123
Enregistré le: 23 Jan 2014 à 15:32

Re: Pré-requis migration vers 3.1.3

Messagepar FoFa » 08 Fév 2015 à 17:33

Envoie moi des accès FTP par messagerie privée vais aller voir
Après l'assassinat de mon ordinateur, je reviens progressivement vers vous...
FoFa
Resp. des supporters
Resp. des supporters
 
Messages: 10378
Enregistré le: 15 Nov 2008 à 18:04
Localisation: Auxonne

Re: Pré-requis migration vers 3.1.3

Messagepar FoFa » 08 Fév 2015 à 18:31

Re,

Cela semble être dû à votre hébergeur gratuit... Sujet dans leur forum de discussion => http://www.webou.net/communaute/index.p ... 809.0.html

Pour ma part, je n'ai pas réussi à charger tous les fichiers d'un phpBB pour simuler une installation...

Donc essayez de dire sur le sujet dont je vous donne le lien plus haut pour dire que vous aussi vous rencontrez le même souci que les autres.

Tenez-nous au courant.
Après l'assassinat de mon ordinateur, je reviens progressivement vers vous...
FoFa
Resp. des supporters
Resp. des supporters
 
Messages: 10378
Enregistré le: 15 Nov 2008 à 18:04
Localisation: Auxonne

Re: Pré-requis migration vers 3.1.3

Messagepar Skouat » 08 Fév 2015 à 21:18

Bonjour,

Si je vais sur http://bacchantis.webou.net/forum2/install/index.php
J'ai le message d'erreur suivant :

Fatal error: Invalid opcode 153/1/8. in /home/noftal/public_html/forum2/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/ParameterBag/ParameterBag.php on line 239


Il semblerait y avoir un problème avec les serveur hébergés par webou
http://www.webou.net/communaute/index.php?topic=5809.0

Donc à priori vous ne pourrez pas installer phpBB 3.1.x sur cet hébergement.
Il ne vous reste plus qu'à aller sur le sujet que j'ai mentionné juste au dessus et de faire un up du sujet en expliquant que vous rencontrez le même problème lorsque vous voulez installer phpBB 3.1

Cordialement.

--- Edit ---

Mon message fait doublon avec la réponse de ForumsFaciles, car en fait il avait posté sa réponse dans un autre sujet.
Mes MODS

Ultima-World Hébergé par phpBB-Services
Code parrainage : 1241646554
Skouat
Traducteur
Traducteur
 
Messages: 13493
Enregistré le: 02 Avr 2008 à 19:47

Re: Pré-requis migration vers 3.1.3

Messagepar noftal » 08 Fév 2015 à 21:42

Merci pour votre aide.
J'ai posté un message dans le fil indiqué.
Toutefois, je me demandais s'il n'y a pas un pb de base de données à créer avant de lancer le install/
Quand je lis le tuto d'installation :
1.1. Pré-requis

Avant de commencer à proprement parler l'installation de phpBB 3, il vous faut créer une base de données.


Il y a un an, quand j'ai créé mon premier forum phpbb 3.0.12, il me semble que j'avais fait une manip pour créer une base de données MySQL. Je ne me souviens plus des gestes exacts mais j'avais dû suivre un tuto que je ne retrouve plus.
Toujours est-il que mon fichier config.php (celui de mon forum avant migration) reprend bien le nom de ma base de données noftal_forum.

Donc si, pour tester que j'ai bien les pré-requis, je crée un nouveau forum 3.1.3, dans forum2/, ne faut-il pas que je crée une nouvelle base de données avant ?
Si oui, pouvez-vous m'indiquer où je peux trouver le tuto qui explique pas à pas comment faire car je ne m'en souviens plus ?
noftal
Apprenti-posteur
Apprenti-posteur
 
Messages: 123
Enregistré le: 23 Jan 2014 à 15:32

Re: Pré-requis migration vers 3.1.3

Messagepar FoFa » 08 Fév 2015 à 21:45

Si vous ne créez pas de base de données cela ne fait rien car votre but n'est pas d'installer le forum mais d'accéder à la page qui vérifiera si votre hébergeur a ou non les prérequis
Après l'assassinat de mon ordinateur, je reviens progressivement vers vous...
FoFa
Resp. des supporters
Resp. des supporters
 
Messages: 10378
Enregistré le: 15 Nov 2008 à 18:04
Localisation: Auxonne

Suivante

Retourner vers Mises à jour/Conversions

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité