[Réglé] Pré-requis migration vers 3.1.3

Forum concernant les demandes de support pour tout problème de mise à jour d'un forum phpBB 3.1.x depuis une version antérieure ou d'une conversion de phpBB2 ou phpBB3 vers phpBB 3.1

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.

Re: Pré-requis migration vers 3.1.3

Messagepar Skouat » 09 Fév 2015 à 23:17

Bonjour,

noftal a écrit:A l'étape 2, j'ai bien eu la confirmation de l'import correct de ma BdD alors que je n'avais pas encore transféré les fichiers du forum.

en quoi est-ce une contradiction ?
Le fait que le fichier .sql ait bien été importé ne signifie en rien que la base de donnée est complète.
Il suffit que votre export ce soit mal passé et hop ! l'import dira que c'est ok.

Donc, pour vérifier que votre base de données est vraiment valide, il vous a fallu transférer vos fichiers et c'est une fois connecté que vous avez pu vous rendre compte que vous aviez bien l'intégralité de vos données de la BDD. :wink:
noftal a écrit:PHP Version 5.3.27

bon ben votre version de PHP ne semble pas référencée dans les versions posant problème :(

noftal a écrit:Pour en revenir aux hébergeurs, je veux bien croire que le risque d'avoir une fonctionnalité manquante cachée est supérieure chez un hébergeur gratuit, mais je ne vois pas ce qui empêcherait un hébergeur payant d'être parfait de ce côté-là. Donc je resterais méfiant quel que soit l'hébergeur à l'avenir, qu'il soit payant ou non.

De tous les sujets qui ont été ouvert, que ce soit pour 3.1 ou 3.0, je n'ai jamais vu un problème de compatibilité lié à un hébergement payant. Par contre pour les hébergement gratuit... on peut vous lister un bon nombre de sujet.

Certes, même chez un payant le problème pourrait être rencontré, mais du fait que vous payez, vous aurez plus de chance que le problème soit résolu, alors que chez un gratuit...
Mes MODS

Ultima-World Hébergé par phpBB-Services
Code parrainage : 1241646554
Skouat
Traducteur
Traducteur
 
Messages: 13712
Enregistré le: 02 Avr 2008 à 20:47

Re: Pré-requis migration vers 3.1.3

Messagepar noftal » 09 Fév 2015 à 23:37

Ben, je ne désespère pas que Webou règle la question...
noftal
Apprenti-posteur
Apprenti-posteur
 
Messages: 123
Enregistré le: 23 Jan 2014 à 16:32

Re: Pré-requis migration vers 3.1.3

Messagepar Skouat » 09 Fév 2015 à 23:51

Bonjour,

Etant donné que vous avez indiqué que le service d'hébergement gratuit allait être stoppé en 2016, il ne faut pas trop espérer.

Quoi qu'il en soit, et pour revenir au sujet de base.

Dans la théorie, si un hébergeur propose une version supérieur à PHP 5.3.3, alors l'extension JSON est incluse dans PHP.
Ceci peut être vérifié à l'aide de phpinfo().
Vous pouvez obtenir cette information directement depuis votre forum en 3.0 en allant dans ACP >> Général >> Infos PHP

Concernant la fonction getimagesize() elle était déjà obligatoire avec phpBB 3.0, donc si phpBB 3.0 a pu être installé alors c'est que cette fonction est disponible.

Si vous considérez votre requête comme résolue, merci d'ajouter l'attribut de sujet [Réglé] ;)

Cordialement.
Mes MODS

Ultima-World Hébergé par phpBB-Services
Code parrainage : 1241646554
Skouat
Traducteur
Traducteur
 
Messages: 13712
Enregistré le: 02 Avr 2008 à 20:47

Re: Pré-requis migration vers 3.1.3

Messagepar noftal » 10 Fév 2015 à 00:54

Json :
enabled, version 1.2.1

Donc finalement, les pré-requis sont OK, sauf l'incompatibilité évoquée... Donc les pré-requis ne sont pas OK :lol:
noftal
Apprenti-posteur
Apprenti-posteur
 
Messages: 123
Enregistré le: 23 Jan 2014 à 16:32

Re: Pré-requis migration vers 3.1.3

Messagepar Skouat » 10 Fév 2015 à 00:58

Voilà c'est bien résumé :mrgreen:
Mes MODS

Ultima-World Hébergé par phpBB-Services
Code parrainage : 1241646554
Skouat
Traducteur
Traducteur
 
Messages: 13712
Enregistré le: 02 Avr 2008 à 20:47

Re: Pré-requis migration vers 3.1.3

Messagepar noftal » 10 Fév 2015 à 16:42

Skouat a écrit:Par exemple :
chez Free, les fonctions cURL et fsockopen ne sont pas disponibles
s


A propos, comme je suis en train de prospecter d'autres hébergeurs et que free a plutôt bonne presse, les limitations dont tu fais état sont-elles un obstacle au bon fonctionnement de phpbb 3.1.3 ?
noftal
Apprenti-posteur
Apprenti-posteur
 
Messages: 123
Enregistré le: 23 Jan 2014 à 16:32

Re: Pré-requis migration vers 3.1.3

Messagepar Skouat » 10 Fév 2015 à 19:12

Oublie Free... leur version de PHP est 5.1.x :mrgreen:
Mes MODS

Ultima-World Hébergé par phpBB-Services
Code parrainage : 1241646554
Skouat
Traducteur
Traducteur
 
Messages: 13712
Enregistré le: 02 Avr 2008 à 20:47

Précédente

Retourner vers Mises à jour/Conversions

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité