[Réglé] Pré-requis migration vers 3.1.3

Forum concernant les demandes de support pour tout problème de mise à jour d'un forum phpBB 3.1.x depuis une version antérieure ou d'une conversion de phpBB2 ou phpBB3 vers phpBB 3.1

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.

Re: Pré-requis migration vers 3.1.3

Messagepar Skouat » 08 Fév 2015 à 22:45

Bonjour,

Comme indiqué dans mon 1er message, il ne sagit la que de tester les prerequis.
Donc non il n'y a pas de base de données à créer.

De toute manière votre problèmatique va au dela de phpBB, vu que votre hébergeur ne semble pas apprécier les framework de Symfony.

--- Pre-post-edit ----
grilled >_<'
Skouat
Traducteur
Traducteur
 
Messages: 13790
Enregistré le: 02 Avr 2008 à 20:47

Re: Pré-requis migration vers 3.1.3

Messagepar FoFa » 08 Fév 2015 à 22:51

Dès que je récupère mon PC je te mets un sous-domaine avec lequel tu pourras simuler une installation afin que tu puisses voir les prérequis
De retour parmi vous :wink:
FoFa
Resp. des supporters
Resp. des supporters
 
Messages: 10592
Enregistré le: 15 Nov 2008 à 19:04
Localisation: Auxonne

Re: Pré-requis migration vers 3.1.3

Messagepar noftal » 08 Fév 2015 à 23:55

Et maintenant que ma version locale installée marche bien, y a-t-il une possibilité de copier simplement les fichiers vers mon serveur ? Quels sont les fichiers à modifier une fois sur le serveur ?
noftal
Apprenti-posteur
Apprenti-posteur
 
Messages: 123
Enregistré le: 23 Jan 2014 à 16:32

Re: Pré-requis migration vers 3.1.3

Messagepar FoFa » 09 Fév 2015 à 00:11

Tu migres tes fichiers vers ton hébergeur
Tu migres ta base de données locale vers ta base de données chez ton hébergeur
Tu modifies le fichier config.php pour y insérer les infos de connexion à ta base de données de ton hébergeur
De retour parmi vous :wink:
FoFa
Resp. des supporters
Resp. des supporters
 
Messages: 10592
Enregistré le: 15 Nov 2008 à 19:04
Localisation: Auxonne

Re: Pré-requis migration vers 3.1.3

Messagepar noftal » 09 Fév 2015 à 00:19

ForumsFaciles a écrit:Tu migres tes fichiers vers ton hébergeur

OK, ça je sais faire.

Tu migres ta base de données locale vers ta base de données chez ton hébergeur

C'est là que j'aurais un peu plus besoin d'aide. J'ai eu la bonne idée de donner le même nom à ma base de données locale que ma base de donnée hébergeur lorsque j'ai créé mon forum sous wamp.
Mais après...?

Tu modifies le fichier config.php pour y insérer les infos de connexion à ta base de données de ton hébergeur

Ben là je suppose qu'il suffit de faire ceci :
- je transfère mes fichiers locaux 3.1.3 vers l'hébergeur
- je copie le fichier config.php que j'avais rapatrié de mon hébergeur (celui du forum 3.0.12) vers mon DD. Et je le colle en remplacement du fichier config.php transféré au point précédent
Est-ce bien cela ?
noftal
Apprenti-posteur
Apprenti-posteur
 
Messages: 123
Enregistré le: 23 Jan 2014 à 16:32

Re: Pré-requis migration vers 3.1.3

Messagepar FoFa » 09 Fév 2015 à 00:21

Oui pour le config.php

Concernant la base de données:
tu vas sur ton phpmyadmin local => exporter => enregistres le fichier obtenu sur ton pc
tu vas sur ton phpmyadmin hébergeur => importer => sélectionne ton fichier de sauvegarde créé précédemment
De retour parmi vous :wink:
FoFa
Resp. des supporters
Resp. des supporters
 
Messages: 10592
Enregistré le: 15 Nov 2008 à 19:04
Localisation: Auxonne

Re: Pré-requis migration vers 3.1.3

Messagepar noftal » 09 Fév 2015 à 01:03

Bon, pour l'importation de la base de données, j'ai eu un message d'erreur :

Erreur

Requête SQL:

-- -- Contenu de la table `phpbb_forums` -- INSERT IGNORE INTO `phpbb_forums` (`forum_id`, `parent_id`, `left_id`, `right_id`, `forum_parents`, `forum_name`, `forum_desc`, `forum_desc_bitfield`, `forum_desc_options`, `forum_desc_uid`, `forum_link`, `forum_password`, `forum_style`, `forum_image`, `forum_rules`, `forum_rules_link`, `forum_rules_bitfield`, `forum_rules_options`, `forum_rules_uid`, `forum_topics_per_page`, `forum_type`, `forum_status`, `forum_last_post_id`, `forum_last_poster_id`, `forum_last_post_subject`, `forum_last_post_time`, `forum_last_poster_name`, `forum_last_poster_colour`, `forum_flags`, `forum_options`, `display_subforum_list`, `display_on_index`, `enable_indexing`, `enable_icons`, `enable_prune`, `prune_next`, `prune_days`, `prune_viewed`, `prune_freq`, `forum_posts_approved`, `forum_posts_unapproved`, `forum_posts_softdeleted`, `forum_topics_approved`, `forum_topics_unapproved`, `forum_topics_softdeleted`, `enable_shadow_prune`, `prune_shadow_days`, `prune[...]

MySQL a répondu: Documentation
#1054 - Unknown column 'forum_posts_approved' in 'field list'


Alors soit j'ai mal exporté, soit c'est autre chose...

Par acquit de conscience, j'ai quand même été au bout de la démarche et ai tenté de lancer le forum mais j'ai eu un message d'erreur :


General Error
SQL ERROR [ mysqli ]

Access denied for user 'root'@'localhost' (using password: NO) [1045]

An sql error occurred while fetching this page. Please contact an administrator if this problem persists.


EDIT : heureusement, j'avais préalablement exporté ma BdD 3.0.12. Le réimport fonctionne bien.
noftal
Apprenti-posteur
Apprenti-posteur
 
Messages: 123
Enregistré le: 23 Jan 2014 à 16:32

Re: Pré-requis migration vers 3.1.3

Messagepar Skouat » 09 Fév 2015 à 14:57

Stop !!!!!!!

Y a que moi que ca inquiète de voir que l'hébergement web ne semble pas compatible avec phpbb 3.1 ?

restez en 3.0 pour le moment le temps de faire quelques test avec la plateforme de votre hébergeur.
Skouat
Traducteur
Traducteur
 
Messages: 13790
Enregistré le: 02 Avr 2008 à 20:47

Re: Pré-requis migration vers 3.1.3

Messagepar FoFa » 09 Fév 2015 à 16:02

D'où la nécessité d'être clairs dans les demandes de support. On peut pas tout deviner ^_^
De retour parmi vous :wink:
FoFa
Resp. des supporters
Resp. des supporters
 
Messages: 10592
Enregistré le: 15 Nov 2008 à 19:04
Localisation: Auxonne

Re: Pré-requis migration vers 3.1.3

Messagepar noftal » 09 Fév 2015 à 17:10

Euh, j'ai pas très bien compris vos 2 dernières réponses.
Même si mon hébergeur semble être incompatible avec phpbb 3.1.3, je ne vois pas pourquoi l'import-export de bdd MySQL serait impacté. Il m'a semblé intéressant de vérifier cet aspect là.
noftal
Apprenti-posteur
Apprenti-posteur
 
Messages: 123
Enregistré le: 23 Jan 2014 à 16:32

Re: Pré-requis migration vers 3.1.3

Messagepar FoFa » 09 Fév 2015 à 19:48

Car cela ne sert à rien d'importer une base de données que vous ne pourrez pas du tout utiliser vu que vous ne pourrez jamais (en tout cas pas tant que les prérequis ne seront pas disponibles sur l'hébergeur) utiliser 3.1.x chez votre hébergeur.

Changez d'hébergeur cela vous fera grand bien ^_^
De retour parmi vous :wink:
FoFa
Resp. des supporters
Resp. des supporters
 
Messages: 10592
Enregistré le: 15 Nov 2008 à 19:04
Localisation: Auxonne

Re: Pré-requis migration vers 3.1.3

Messagepar noftal » 09 Fév 2015 à 20:28

Ben ça me permettait de tester l'export/import de Bdd, même si j'ai bien compris que je n'irais pas plus loin.

ForumsFaciles a écrit:Changez d'hébergeur cela vous fera grand bien ^_^


Je suis en train de regarder.
De toute façon, avec webou, l'hébergement gratuit prend fin en février 2016. Donc tôt ou tard, il aurait fallu que je me pose la question.
Ce que je trouve flippant, c'est que lorsqu'on choisit un hébergeur, on ne peut pas voir dans ses caractéristiques promises s'il va être compatible pour ce genre de truc. On regarde la version PHP, MySQL, et sur le papier, les pré-requis exigés par phphbb sont bien présents chez webou.
noftal
Apprenti-posteur
Apprenti-posteur
 
Messages: 123
Enregistré le: 23 Jan 2014 à 16:32

Re: Pré-requis migration vers 3.1.3

Messagepar Skouat » 09 Fév 2015 à 21:25

Bonjour,

noftal a écrit:Ben ça me permettait de tester l'export/import de Bdd, même si j'ai bien compris que je n'irais pas plus loin.

L'interet de faire un import/export d'une BDD c'est de pouvoir voir si elle fonctionne.
Et pour voir si tout est ok il faut associer à la BDD les fichiers qui vont permettre de la consulter.

Donc si vous importer chez webou votre BDD en version 3.1.3 de phpBB, ainsi que les fichiers, vu que webou semble incompatible avec phpBB, vous ne pourrez jamais savoir si l'import s'est bien passé.

noftal a écrit:On regarde la version PHP, MySQL, et sur le papier, les pré-requis exigés par phphbb sont bien présents chez webou.

C'est le propre des hébergeurs gratuits.
Si c'est gratuit, c'est qu'il y a des fonctions qui ne sont pas activées et souvent on s'en rend compte une fois que l'on en a besoin.
Par exemple :
chez Free, les fonctions cURL et fsockopen ne sont pas disponibles
Chez d'autres hébergeurs c'est le nombre de connexions simultanées qui sont limitées
Chez webou c'est autre chose...

Pour en revenir à votre problème.
pouvez-vous nous dire quel est le version de PHP fournie par webou ?
ACP >> Général >> Information PHP
Car il semblerait que la version 2.6 de symfony2 soit buguée avec certaines version de PHP.
:arrow: https://github.com/symfony/symfony/tree ... quirements
Skouat
Traducteur
Traducteur
 
Messages: 13790
Enregistré le: 02 Avr 2008 à 20:47

Re: Pré-requis migration vers 3.1.3

Messagepar noftal » 09 Fév 2015 à 23:04

Skouat a écrit:Et pour voir si tout est ok il faut associer à la BDD les fichiers qui vont permettre de la consulter.


Au risque de vous contredire, je viens de faire un test sur un autre hébergeur gratuit. Dans l'ordre voici comment j'ai procédé :
- création d'une base de données MySQL chez l'hébergeur
- importation du fichier .sql issu de l'exportation de ma BdD locale, vers l'hébergeur
- PUIS transfert des fichiers de mon forum local vers l'hébergeur

A l'étape 2, j'ai bien eu la confirmation de l'import correct de ma BdD alors que je n'avais pas encore transféré les fichiers du forum.


pouvez-vous nous dire quel est le version de PHP fournie par webou ?


PHP Version 5.3.27

Pour en revenir aux hébergeurs, je veux bien croire que le risque d'avoir une fonctionnalité manquante cachée est supérieure chez un hébergeur gratuit, mais je ne vois pas ce qui empêcherait un hébergeur payant d'être parfait de ce côté-là. Donc je resterais méfiant quel que soit l'hébergeur à l'avenir, qu'il soit payant ou non.
noftal
Apprenti-posteur
Apprenti-posteur
 
Messages: 123
Enregistré le: 23 Jan 2014 à 16:32

Re: Pré-requis migration vers 3.1.3

Messagepar FoFa » 09 Fév 2015 à 23:12

Tu ne contredis rien du tout :wink:

Le fait de réussir un import d'une base de données chez un hébergeur ne veut pas dire que ton forum va tourner chez cet hébergeur. Vu que tout se passe au niveau des fichiers et des fonctions appelées à divers endroits.

Là tu savais que cet hébergeur ne correspondait pas à ton forum 3.1.x... Du coup, autant gagner du temps et partir voir ailleurs...
De retour parmi vous :wink:
FoFa
Resp. des supporters
Resp. des supporters
 
Messages: 10592
Enregistré le: 15 Nov 2008 à 19:04
Localisation: Auxonne

PrécédenteSuivante

Retourner vers Mises à jour/Conversions

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité