[Réglé] maj 3.0.12 à 3.0.13 puis 3.0.14

Forum concernant les demandes de support pour tout problème de mise à jour d'un forum phpBB 3.0.x. depuis une version antérieure de phpBB3 ou d'une conversion de phpBB2 vers phpBB3.

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.
Partager sur FacebookPartager sur TwitterPartager sur Google+

[Réglé] maj 3.0.12 à 3.0.13 puis 3.0.14

Messagepar chantal » 17 Déc 2016 à 14:26

Bonjour,

J'ai procédé à la maj de mon forum de la version 3-0-12 vers la version 3-0-13
J'ai lancé le "install" mis à la racine du répertoire de mon forum
suite à quoi j'ai remplacé chacun des fichiers du répertoire récupéré update_3.0.12_to_3.0.13-PL1 dans mon serveur
pas de problème tout marche à merveille

Le seul problème c'est le fichier .htaccess; si je le remplace j'obtiens un message d'erreur "erreur 500" sur mon forum et donc forum inaccessible

J'ai donc laissé l'ancien .htaccess

Sauf que quand j'ai relancé mon "install" pour finaliser ma maj ça me dit qu'il me reste ce fichier .htaccess à modifier
Je ne peux donc pas terminer ma maj

voici mon .htaccess avant la maj

Code: Tout sélectionner
Options -Indexes
AddCharset iso-8859-1 .css .php .html

php 1

<Files "config.php">
Order Allow,Deny
Deny from All
</Files>
<Files "common.php">
Order Allow,Deny
Deny from All
</Files>


et voici celui proposé pour la maj vers 3-0-13
Code: Tout sélectionner
Options -Indexes
AddCharset iso-8859-1 .css .php .html

php 1

# With Apache 2.4 the "Order, Deny" syntax has been deprecated and moved from
# module mod_authz_host to a new module called mod_access_compat (which may be
# disabled) and a new "Require" syntax has been introduced to mod_authz_host.
# We could just conditionally provide both versions, but unfortunately Apache
# does not explicitly tell us its version if the module mod_version is not
# available. In this case, we check for the availability of module
# mod_authz_core (which should be on 2.4 or higher only) as a best guess.
<IfModule mod_version.c>
	<IfVersion < 2.4>
<Files "config.php">
Order Allow,Deny
Deny from All
</Files>
<Files "common.php">
Order Allow,Deny
Deny from All
</Files>
	</IfVersion>
	<IfVersion >= 2.4>
		<Files "config.php">
			Require all denied
		</Files>
		<Files "common.php">
			Require all denied
		</Files>
	</IfVersion>
</IfModule>
<IfModule !mod_version.c>
	<IfModule !mod_authz_core.c>
		<Files "config.php">
			Order Allow,Deny
			Deny from All
		</Files>
		<Files "common.php">
			Order Allow,Deny
			Deny from All
		</Files>
	</IfModule>
	<IfModule mod_authz_core.c>
		<Files "config.php">
			Require all denied
		</Files>
		<Files "common.php">
			Require all denied
		</Files>
	</IfModule>
</IfModule>


Je pensais:

1) remplacer le .htaccess sans tenir compte que mon forum ne marche pas avec
2) cela me permettrait de finaliser ma maj
3) une fois cette maj faite jusqu'au bout, remettre mon ancien .htaccess

Mais est-ce que je ne risque pas de tout faire planter?

J'ai voulu passer à la maj vers 3-0-14 mais j'ai un message que cette maj ne peut pas se faire car j'ai tjs des fichiers en 3-0-12 (il ne peut s'agir que du fichier .htaccess vu que c'est le seul que je ne peux pas modifier..)

Comment faire?

Merci de votre aide

Chantal
Modifié en dernier par chantal le 05 Jan 2017 à 17:23, modifié 3 fois.
chantal
Maître-posteur
Maître-posteur
 
Messages: 490
Enregistré le: 31 Aoû 2011 à 20:39

Re: maj 3.0.12 à 3.0.13 puis 3.0.14

Messagepar chantal » 18 Déc 2016 à 16:59

Bonsoir,

J'ai essayé ceci sur une BDD bidon
chantal a écrit:Je pensais:

1) remplacer le .htaccess sans tenir compte que mon forum ne marche pas avec
2) cela me permettrait de finaliser ma maj
3) une fois cette maj faite jusqu'au bout, remettre mon ancien .htaccess



si je laisse le .htaccess qui fonctionne, je ne peux pas finaliser ma maj
si je mets le .htaccess proposé dans la maj vers 3-0-13 j'ai ce message "erreur 500" quand je lance le "install" qui m'empêche de l'éxécuter

Je ne sais plus comment faire
Merci de votre aide

Chantal
chantal
Maître-posteur
Maître-posteur
 
Messages: 490
Enregistré le: 31 Aoû 2011 à 20:39

Re: maj 3.0.12 à 3.0.13 puis 3.0.14

Messagepar anywhere91 » 19 Déc 2016 à 17:08

Bonjour / Soir

Déjà, tout ce qui est précédé par # peut être supprimer 8)

Tu dois êtres chez FREE (php 1 est assez caractéristique). Essaye ce fichier et dis nous si c'est OK ou pas et attention a ce que tu utilises comme éditeur html/php (surtout pas le notepad de windows mais plus notepad2 ou notepad++)

Code: Tout sélectionner
Options -Indexes
AddCharset iso-8859-1 .css .php .html

php 1

<Files "config.php">
Order Allow,Deny
Deny from All
</Files>
<Files "common.php">
Order Allow,Deny
Deny from All
</Files>


Cordialement
Image
Avatar de l’utilisateur
anywhere91
Grand-maître des floodeurs
Grand-maître des floodeurs
 
Messages: 2844
Enregistré le: 04 Déc 2007 à 18:01
Localisation: Hein ?!? heu !?!

Re: maj 3.0.12 à 3.0.13 puis 3.0.14

Messagepar chantal » 20 Déc 2016 à 10:59

Merci beaucoup pour votre réponse,

Le fichier que vous me proposez est celui que j'avais avant la maj vers 3-0-13
J'ai refait l'essai mais sans succès
Quand je lance le "install" il me reste toujours ce fichier .htaccess qui pose problème

J'ai essayé les 3 possibilités (sur ma BDD bidon je ne craignais rien)

Je suis effectivement sous free

Chantal

PS: je m'absente qques jours pour les fêtes de Noël, merci de ne pas clôturer mon sujet en cas d'absence de réponse de ma part, j'espère que le père noël m'apportera la solution :)
Modifié en dernier par chantal le 05 Jan 2017 à 08:58, modifié 2 fois.
chantal
Maître-posteur
Maître-posteur
 
Messages: 490
Enregistré le: 31 Aoû 2011 à 20:39

Re: maj 3.0.12 à 3.0.13 puis 3.0.14

Messagepar anywhere91 » 22 Déc 2016 à 00:14

Bonjour / Soir

Un erreur 500 est souvent une erreur interne au serveur. dans ton cas une charge peut être trop importante au moment de la MaJ bloque ton process.

En faisant un copier coller d'un fichier .htacces d'une version 3.0.14 (en ayant renommer l'ancien avant intervention) peut aider a résoudre le problème en collant le code suivant a la base

Code: Tout sélectionner
Options -Indexes
AddCharset iso-8859-1 .css .php .html

php 1


Sion voir avec une version ultérieur de php => http://additifstabac.free.fr/index.php/ ... /#modifier

Cordialement
Image
Avatar de l’utilisateur
anywhere91
Grand-maître des floodeurs
Grand-maître des floodeurs
 
Messages: 2844
Enregistré le: 04 Déc 2007 à 18:01
Localisation: Hein ?!? heu !?!

Re: maj 3.0.12 à 3.0.13 puis 3.0.14

Messagepar chantal » 29 Déc 2016 à 10:34

Bonjour et merci pour votre réponse,

J'ai modifié mon .htaccess comme vous me le proposez
Code: Tout sélectionner
Options -Indexes
AddCharset iso-8859-1 .css .php .html

php 1
#
# Uncomment the statement below if you want to make use of
# HTTP authentication and it does not already work.
# This could be required if you are for example using PHP via Apache CGI.
#
#<IfModule mod_rewrite.c>
#RewriteEngine on
#RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]
#</IfModule>

# With Apache 2.4 the "Order, Deny" syntax has been deprecated and moved from
# module mod_authz_host to a new module called mod_access_compat (which may be
# disabled) and a new "Require" syntax has been introduced to mod_authz_host.
# We could just conditionally provide both versions, but unfortunately Apache
# does not explicitly tell us its version if the module mod_version is not
# available. In this case, we check for the availability of module
# mod_authz_core (which should be on 2.4 or higher only) as a best guess.
<IfModule mod_version.c>
	<IfVersion < 2.4>
		<Files "config.php">
			Order Allow,Deny
			Deny from All
		</Files>
		<Files "common.php">
			Order Allow,Deny
			Deny from All
		</Files>
	</IfVersion>
	<IfVersion >= 2.4>
		<Files "config.php">
			Require all denied
		</Files>
		<Files "common.php">
			Require all denied
		</Files>
	</IfVersion>
</IfModule>
<IfModule !mod_version.c>
	<IfModule !mod_authz_core.c>
		<Files "config.php">
			Order Allow,Deny
			Deny from All
		</Files>
		<Files "common.php">
			Order Allow,Deny
			Deny from All
		</Files>
	</IfModule>
	<IfModule mod_authz_core.c>
		<Files "config.php">
			Require all denied
		</Files>
		<Files "common.php">
			Require all denied
		</Files>
	</IfModule>
</IfModule>


Mais malheureusement toujours le même problème

anywhere91 a écrit:
Sion voir avec une version ultérieur de php => http://additifstabac.free.fr/index.php/ ... /#modifier



Je me dirige donc vers cette proposition
Mon problème n'étant pas encore résolu, dois-je quand même clôturer mon sujet en "réglé" (bien qu'il ne l'est pas) ou bien j'attends de voir si j'arrive à le résoudre avec ce nouveau support? Car j'ai vu qu'il y avait un forum indépendant de celui-ci

A moins que quelqu'un puisse me guider?

Merci de me préciser

Chantal
chantal
Maître-posteur
Maître-posteur
 
Messages: 490
Enregistré le: 31 Aoû 2011 à 20:39

Re: maj 3.0.12 à 3.0.13 puis 3.0.14

Messagepar cocooncrash » 29 Déc 2016 à 15:53

Bonjour,
Vous pouvez le laisser ouvert, le temps que tout rentre dans l'ordre.
decouvrez l'aide complete : ICI
découvrez les règles : La_bas

Pensez a ajouter le tag [réglé] en modifiant votre premier message s'il est résolu. Merci :wink:
Avatar de l’utilisateur
cocooncrash
Resp. des modérateurs
Resp. des modérateurs
 
Messages: 7533
Enregistré le: 07 Jan 2008 à 08:29
Localisation: dans un bocal en compagnie de nemo!!

Re: maj 3.0.12 à 3.0.13 puis 3.0.14

Messagepar chantal » 03 Jan 2017 à 09:58

ok merci

sinon quelqu'un peut-il me guider dans l'installation de wordpress?

J'ai téléchargé wordpress 4.7 et l'ai mis à la racine du répertoire de mon forum (c'est bien ça?) mais je ne comprends pas ce que je dois faire après..

Désolée mais je suis un peu perdue là

Chantal
chantal
Maître-posteur
Maître-posteur
 
Messages: 490
Enregistré le: 31 Aoû 2011 à 20:39

Re: maj 3.0.12 à 3.0.13 puis 3.0.14

Messagepar cocooncrash » 03 Jan 2017 à 10:39

Chantal, tu es sur le forum de support de phpbb, wordpress a son propre support!!
decouvrez l'aide complete : ICI
découvrez les règles : La_bas

Pensez a ajouter le tag [réglé] en modifiant votre premier message s'il est résolu. Merci :wink:
Avatar de l’utilisateur
cocooncrash
Resp. des modérateurs
Resp. des modérateurs
 
Messages: 7533
Enregistré le: 07 Jan 2008 à 08:29
Localisation: dans un bocal en compagnie de nemo!!

Re: maj 3.0.12 à 3.0.13 puis 3.0.14

Messagepar chantal » 03 Jan 2017 à 10:53

oui je sais mais n'ayant pas de réponse du support wordpress je me suis permise de poser la question..

Je vais patienter encore :)
chantal
Maître-posteur
Maître-posteur
 
Messages: 490
Enregistré le: 31 Aoû 2011 à 20:39

Re: maj 3.0.12 à 3.0.13 puis 3.0.14

Messagepar cocooncrash » 03 Jan 2017 à 11:39

ca ne sera pas ici sur ce forum.
decouvrez l'aide complete : ICI
découvrez les règles : La_bas

Pensez a ajouter le tag [réglé] en modifiant votre premier message s'il est résolu. Merci :wink:
Avatar de l’utilisateur
cocooncrash
Resp. des modérateurs
Resp. des modérateurs
 
Messages: 7533
Enregistré le: 07 Jan 2008 à 08:29
Localisation: dans un bocal en compagnie de nemo!!

Re: maj 3.0.12 à 3.0.13 puis 3.0.14

Messagepar chantal » 03 Jan 2017 à 19:43

cocooncrash a écrit:ca ne sera pas ici sur ce forum.

Je voulais dire "je vais encore patienter pour avoir une réponse du support concerné", réponse que j'attends toujours
anywhere91 a écrit:Sion voir avec une version ultérieur de php => http://additifstabac.free.fr/index.php/ ... /#modifier

La finalité de cette démarche est-elle d'abandonner ma structure actuelle phpbb et de repartir complètement sur autre chose ou bien "d'améliorer" le support free qui me permettrait de garder ma structure actuelle?

Ayant du mal à cerner tout ceci, j'ai installé wordpress mais ...???? et sur le support concerné (encore un autre) on ne sait pas me dire comment je peux faire le lien entre mon forum actuel et wordpress... et j'ai l'impression qu'une autre structure m'est proposée

Je pense avoir fait cette installation pour rien et que ce n'était pas ce qui m'était proposé, sauf que je ne comprends pas comment activer 5.6.8

Je comprends parfaitement que ce forum n'est pas approprié à ma question mais si quelqu'un pouvait juste m'aider à piger la finalité

Pour l'instant wordpress est dans un répertoire parallèle à celui de mon forum phpbb, faut-il que j'inclue l'un dans l'autre?

Merci
chantal
Maître-posteur
Maître-posteur
 
Messages: 490
Enregistré le: 31 Aoû 2011 à 20:39

Re: maj 3.0.12 à 3.0.13 puis 3.0.14

Messagepar Steph » 03 Jan 2017 à 21:41

Salut,

La finalité est d'avoir une autre version de php.

Pour WordPress, ce n'est pas chez nous qu'il faut poser la question.

D'ailleurs personne ici ne t'a demandé d'installer WordPress.
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 17560
Enregistré le: 29 Déc 2008 à 15:48
Localisation: Alsace / Bas-Rhin / France

Re: maj 3.0.12 à 3.0.13 puis 3.0.14

Messagepar chantal » 04 Jan 2017 à 15:38

Bonjour,

J'ai enfin réussi à passer en 5.6.8

Mais je n'arrive pas pour autant à passer de la version 3.0.12 à la version 3.0.13 pour mon forum

C'est toujours le fichier .htaccess qui pose problème (j'ai le message "erreur 500")

Code: Tout sélectionner
Options -Indexes
AddCharset iso-8859-1 .css .php .html

php 1

# With Apache 2.4 the "Order, Deny" syntax has been deprecated and moved from
# module mod_authz_host to a new module called mod_access_compat (which may be
# disabled) and a new "Require" syntax has been introduced to mod_authz_host.
# We could just conditionally provide both versions, but unfortunately Apache
# does not explicitly tell us its version if the module mod_version is not
# available. In this case, we check for the availability of module
# mod_authz_core (which should be on 2.4 or higher only) as a best guess.
<IfModule mod_version.c>
	<IfVersion < 2.4>
<Files "config.php">
Order Allow,Deny
Deny from All
</Files>
<Files "common.php">
Order Allow,Deny
Deny from All
</Files>
	</IfVersion>
	<IfVersion >= 2.4>
		<Files "config.php">
			Require all denied
		</Files>
		<Files "common.php">
			Require all denied
		</Files>
	</IfVersion>
</IfModule>
<IfModule !mod_version.c>
	<IfModule !mod_authz_core.c>
		<Files "config.php">
			Order Allow,Deny
			Deny from All
		</Files>
		<Files "common.php">
			Order Allow,Deny
			Deny from All
		</Files>
	</IfModule>
	<IfModule mod_authz_core.c>
		<Files "config.php">
			Require all denied
		</Files>
		<Files "common.php">
			Require all denied
		</Files>
	</IfModule>
</IfModule>
Modifié en dernier par chantal le 05 Jan 2017 à 15:34, modifié 1 fois.
chantal
Maître-posteur
Maître-posteur
 
Messages: 490
Enregistré le: 31 Aoû 2011 à 20:39

Re: maj 3.0.12 à 3.0.13 puis 3.0.14

Messagepar Steph » 04 Jan 2017 à 22:30

Hello,

Une chose que je te propose de tester.

Tu gardes ton fichier .htaccess qui fonctionne et tu ouvres le fichier install/update/index.php

Cherche (ligne 12)

Code: Tout sélectionner
		'.htaccess',


Tu supprimes cette ligne, tu renvoies le fichier sur le serveur et tu retentes une mise à jour.
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 17560
Enregistré le: 29 Déc 2008 à 15:48
Localisation: Alsace / Bas-Rhin / France

Suivante

Retourner vers Mises à jour/Conversions

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 5 invités

cron