[Réglé] "Erreur générale" après conversion phpbb2>3

Forum concernant les demandes de support pour tout problème de mise à jour d'un forum phpBB 3.0.x. depuis une version antérieure de phpBB3 ou d'une conversion de phpBB2 vers phpBB3.

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.
Partager sur FacebookPartager sur TwitterPartager sur Google+

[Réglé] "Erreur générale" après conversion phpbb2>3

Messagepar Bernardo » 13 Jan 2009 à 17:22

Bonjour,

J'ai un Forum d'environ 50 000 membres et 100 000 messages sous PunBB (je ne souhaite pas garder les messages, simplement les utilisateurs (même pas les groupes, ranks, catégories...), j'ai réalisé avec succès la conversion vers phpBB2 (bien que les passwords des membres n'aient pas été gardés...mais ça j'ai entendu dire que c'était normal et puis ça ne me gêne pas, je ferais simplement une "ré-initialisation générale" où le lien d'activation d'un new password sera envoyé à tous les membres...bref).

Le Forum sous phpBB2 marche à merveille, j'ai vidé le contenu de phpbb_posts / topics / forums / catégories depuis la sql.

Mon but est de passer sous phpBB3, j'ai donc installé phpBB3 en local et effectuer une installation vierge sur la même base de données que celle du phpBB2 mais avec le préfixe phpbb3_.
La migration via le dossier /install/ s'est déroulé à merveille, je n'ai eu absolument aucune erreur !

Seulement lorsque je vais sur n'importe quelle page, j'ai cette erreur:
Erreur générale
SQL ERROR [ mysqli ]

Erreur de syntaxe pr�s de 'AND t.template_id = s.template_id AND c.theme_id = s.theme_i' � la ligne 4 [1064]

Une erreur SQL est arrivée en chargeant cette page. Contactez l’administrateur du forum si ce problème persiste.

( http://dump-it.fr/upload/images/da600e2 ... 90bb03.png )

J'ai re-téléchargé une archive de phpBB3.0.4 depuis ici et j'ai remis les fichiers (en laissant simplement le config.php): meme problème.
En changeant le nom du skin (en recherchant "prosylver" dans la sql et en remplaçant tous les résultats par "subsilver2"): meme problème.
J'ai fais téléchargé l'archive de mise à jours 3.0.3 > 3.0.4, et lorsque je vais à http://127.0.0.1/phpbb3/install/index.p ... anguage=fr , j'ai:
Erreur générale
SQL ERROR [ mysqli ]

Erreur de syntaxe pr�s de 'AND t.template_id = s.template_id AND c.theme_id = s.theme_i' � la ligne 4 [1064]

SQL

SELECT s.style_id, t.template_storedb, t.template_path, t.template_id, t.bbcode_bitfield, t.template_inherits_id, t.template_inherit_path, c.theme_path, c.theme_name, c.theme_storedb, c.theme_id, i.imageset_path, i.imageset_id, i.imageset_name FROM phpbb3_styles s, phpbb3_styles_template t, phpbb3_styles_theme c, phpbb3_styles_imageset i WHERE s.style_id = AND t.template_id = s.template_id AND c.theme_id = s.theme_id AND i.imageset_id = s.imageset_id

BACKTRACE

FILE: includes/db/mysqli.php
LINE: 163
CALL: dbal->sql_error()

FILE: includes/session.php
LINE: 1558
CALL: dbal_mysqli->sql_query()

FILE: install/install_update.php
LINE: 120
CALL: user->setup()

FILE: install/index.php
LINE: 405
CALL: install_update->main()

FILE: install/index.php
LINE: 282
CALL: module->load()

( http://dump-it.fr/upload/images/eecd341 ... 70b26a.png )
Je suppose que cette erreur lors de la mise à jours (normalement impossible vu que je suis déjà en 3.0.4, mais c'était pour tester...) a un rapport avec l'erreur que j'ai sur mon forum..

PS: J'ai également essayé de modifier la valeur de "$dbms" dans le config.php, elle est à mysqli et lorsque je la passe à mysql j'ai toujours les mêmes erreurs sauf qu'au lieu d'avoir "SQL ERROR [ mysqli ]", j'ai "SQL ERROR [ mysql4 ]".

Merci d'avance de votre aide !
Dernière édition par Bernardo le 13 Jan 2009 à 20:41, édité 1 fois.
Avatar de l’utilisateur
Bernardo
Posteur néophyte
Posteur néophyte
 
Messages: 2
Inscription: 13 Jan 2009 à 16:59
Localisation: Clermont-Ferrand

Re: "Erreur générale" après conversion phpbb2>3

Messagepar Bernardo » 13 Jan 2009 à 20:40

Je me permets de re-poster pour annoncer que j'ai résolu mon problème.
Sur mon installation phpBB3 vierge, j'ai importé l'user "Anonymous" (enfin la requête sql lui correspondant.....) et j'ai exécuté cette requête sql dans ma table phpbb3_users de la Base de données de mon Forum.
Voilà la requête sql en question pour ceux qui ont le même problème:
Code: Tout sélectionner
INSERT INTO `phpbb3_users` (`user_id`, `user_type`, `group_id`, `user_permissions`, `user_perm_from`, `user_ip`, `user_regdate`, `username`, `username_clean`, `user_password`, `user_passchg`, `user_pass_convert`, `user_email`, `user_email_hash`, `user_birthday`, `user_lastvisit`, `user_lastmark`, `user_lastpost_time`, `user_lastpage`, `user_last_confirm_key`, `user_last_search`, `user_warnings`, `user_last_warning`, `user_login_attempts`, `user_inactive_reason`, `user_inactive_time`, `user_posts`, `user_lang`, `user_timezone`, `user_dst`, `user_dateformat`, `user_style`, `user_rank`, `user_colour`, `user_new_privmsg`, `user_unread_privmsg`, `user_last_privmsg`, `user_message_rules`, `user_full_folder`, `user_emailtime`, `user_topic_show_days`, `user_topic_sortby_type`, `user_topic_sortby_dir`, `user_post_show_days`, `user_post_sortby_type`, `user_post_sortby_dir`, `user_notify`, `user_notify_pm`, `user_notify_type`, `user_allow_pm`, `user_allow_viewonline`, `user_allow_viewemail`, `user_allow_massemail`, `user_options`, `user_avatar`, `user_avatar_type`, `user_avatar_width`, `user_avatar_height`, `user_sig`, `user_sig_bbcode_uid`, `user_sig_bbcode_bitfield`, `user_from`, `user_icq`, `user_aim`, `user_yim`, `user_msnm`, `user_jabber`, `user_website`, `user_occ`, `user_interests`, `user_actkey`, `user_newpasswd`, `user_form_salt`) VALUES 
(1, 2, 1, '', 0, '', 1231868292, 0x416e6f6e796d6f7573, 0x616e6f6e796d6f7573, '', 0, 0, '', 0, '', 0, 0, 0, '', '', 0, 0, 0, 0, 0, 0, 0, 0x656e, 0.00, 0, 0x64204d205920483a69, 1, 0, '', 0, 0, 0, 0, -3, 0, 0, 0x74, 0x64, 0, 0x74, 0x61, 0, 1, 0, 1, 1, 1, 0, 895, '', 0, 0, 0, '', '', '', '', '', '', '', '', '', '', '', '', '', '', 0x64343163393238626532626436336337),

(je n'ai pas compris pourquoi tous les champs sont cryptés, mais en tous cas ça marche et c'est l'essentiel !).

Je coche résolu ! :)
Avatar de l’utilisateur
Bernardo
Posteur néophyte
Posteur néophyte
 
Messages: 2
Inscription: 13 Jan 2009 à 16:59
Localisation: Clermont-Ferrand


Retourner vers Mises à jour/Conversions

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 2 invités