erreur après appel de l' url install

Forum concernant les demandes de support pour tout problème de mise à jour d'un forum phpBB 3.0.x. depuis une version antérieure de phpBB3 ou d'une conversion de phpBB2 vers phpBB3.

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.
Partager sur FacebookPartager sur TwitterPartager sur Google+

erreur après appel de l' url install

Messagepar zebu » 18 Avr 2008 à 22:26

Bonjour,

J'ai voulu effectuer la mise à jour du mon forum sur la version 3.01.

J' ai donc basculé par ftp le repertoire install et le lancer par l' url correspondante.

Le soucis est que quand je clique sur l' onglet superieur 'mise à jour', j' ai cette erreur

Code: Tout sélectionner
Fatal error: Call to a member function on a non-object in /home/z/'nom de mon forum'/www/forum/includes/functions.php on line 1741



Merci pour votre aide


edit: apparemment cela viendrait de mod rewrite SEO, ils suggèrent de placer un function php vierge, de lancer la mise à jour et de remettre le modifié.

Sinon ils parlent ensuite de modifs manuelles nécéssaires sur ce fichier, mais là je ne vois pas trop.

merci si quelqu'un pourrait me donner des infos car je ne suis plus si franc pour effectuer cette mise à jour maintenant
Avatar de l’utilisateur
zebu
Apprenti-posteur
Apprenti-posteur
 
Messages: 158
Enregistré le: 17 Déc 2004 à 18:32

Re: erreur après appel de l' url install

Messagepar lolovoisin » 19 Avr 2008 à 10:48

Il existe pour cela les "patch file"de modifications.
C'est un peu "imbuvable" à lire mais voici le lien:
http://www.phpbb.com/downloads/olympus. ... e8adea5228

Vous trouverez dans ce fichier "phpBB-3.0.1-patch.zip" les modifications du fichier functions.php
c'est de la ligne 5911 à 7509
Ceux qui échouent trouvent des excuses, ceux qui réussissent trouvent les moyens
Quand un homme a faim, mieux vaut lui apprendre à pêcher que de lui donner un poisson.
PAS DE SUPPORT PAR MP !!

tutophpbb3 + astuce + tutos debian
Avatar de l’utilisateur
lolovoisin
Rugbix ³
Rugbix ³
 
Messages: 39779
Enregistré le: 04 Mai 2006 à 13:16
Localisation: Dans la BDD ...

Re: erreur après appel de l' url install

Messagepar zebu » 19 Avr 2008 à 15:54

Merci Lolovoisin pour ton aide.

Si je comprend bien, il faut que je fasse la modification, mais ensuite je suis aussi obligé de refaire les modifs touchant function php pour les mods (car je suppose que ces modifs vont en ecraser d' autres).

Ne serait donc pas aussi bien de placer un function php provenant de phpBB3.01 et refaire les modifs dessus: je ne vois pas trop bien la nuance.

Merci
Avatar de l’utilisateur
zebu
Apprenti-posteur
Apprenti-posteur
 
Messages: 158
Enregistré le: 17 Déc 2004 à 18:32

Re: erreur après appel de l' url install

Messagepar lolovoisin » 19 Avr 2008 à 17:57

ah si bien sur.
Je t'ai donné le lien pour les modif manuelles mais tu peux utiliser un fichier functions d'une archive 3.0.1
Ceux qui échouent trouvent des excuses, ceux qui réussissent trouvent les moyens
Quand un homme a faim, mieux vaut lui apprendre à pêcher que de lui donner un poisson.
PAS DE SUPPORT PAR MP !!

tutophpbb3 + astuce + tutos debian
Avatar de l’utilisateur
lolovoisin
Rugbix ³
Rugbix ³
 
Messages: 39779
Enregistré le: 04 Mai 2006 à 13:16
Localisation: Dans la BDD ...

Re: erreur après appel de l' url install

Messagepar zebu » 19 Avr 2008 à 19:38

Je vais voir ceci, Seo suggere de mettre un function.php original, faire la modif auto de phpBB et refaire les modif du SEO sur le function php.

Je vous tiens au courant

Merci beaucoup à toi :wink:
Avatar de l’utilisateur
zebu
Apprenti-posteur
Apprenti-posteur
 
Messages: 158
Enregistré le: 17 Déc 2004 à 18:32

Re: erreur après appel de l' url install

Messagepar lolovoisin » 19 Avr 2008 à 19:42

c'est le plus simple surtout si il y a moins de modifs du MODs seo que la MAJ 3.0.1 :wink:
Ceux qui échouent trouvent des excuses, ceux qui réussissent trouvent les moyens
Quand un homme a faim, mieux vaut lui apprendre à pêcher que de lui donner un poisson.
PAS DE SUPPORT PAR MP !!

tutophpbb3 + astuce + tutos debian
Avatar de l’utilisateur
lolovoisin
Rugbix ³
Rugbix ³
 
Messages: 39779
Enregistré le: 04 Mai 2006 à 13:16
Localisation: Dans la BDD ...

Re: erreur après appel de l' url install

Messagepar zebu » 19 Avr 2008 à 22:29

Je vois cela, en tout cas un grand merci pour votre aide, je vous informe de mes futurs problêmes à venir :lol: :wink:
Avatar de l’utilisateur
zebu
Apprenti-posteur
Apprenti-posteur
 
Messages: 158
Enregistré le: 17 Déc 2004 à 18:32

Re: erreur après appel de l' url install

Messagepar Dakin Quelia » 19 Avr 2008 à 22:34

Bonsoir,

Si tu estimes ton problème résolu, n'oublie pas de rajouter [Réglé] dans le titre de ton sujet. :wink:

A bientôt,
Aucun support par mail, MP ou msn.
Mes MODs: ici | Mon blogue: Mon blogue | DeviantArt: cliquez ici
Avatar de l’utilisateur
Dakin Quelia
Floodeur universel
Floodeur universel
 
Messages: 21326
Enregistré le: 31 Oct 2006 à 19:33
Localisation: Belgique

Re: erreur après appel de l' url install

Messagepar zebu » 19 Avr 2008 à 23:11

Faisant la modif ces prochains jours, je ne manquerai pas de le faire :wink:

Maintenant si vous préferez que j'ouvre eventuellement un nouveau post (quoique je ne souhaite pas avoir à le faire), faites moi signe et je cloturerai ce sujet
Avatar de l’utilisateur
zebu
Apprenti-posteur
Apprenti-posteur
 
Messages: 158
Enregistré le: 17 Déc 2004 à 18:32

Re: erreur après appel de l' url install

Messagepar zebu » 27 Avr 2008 à 09:36

Bonjour,

Je reviens donc avec mon soucis :mrgreen:

J' ai tenté d' effectuer la modif en placant un function.php avant de lancer l' install.

L' install s'est bien déroulé, j' ai replace mon function.php modifié SEO et j' ai cette erreur suivante

Code: Tout sélectionner
Fatal error: Call to undefined function: get_formatted_filesize() in /home/z/zebinfo/www/forum/includes/acp/acp_main.php on line 313


J'ai donc replacé mes fichiers initialement sauvegardés en attendant mais apparement les liens des sous forum n' apparaissent plus sur les forum parent malgrès le bon réglage acp (j'ai comparé avec un forum ami).

Bref, j' aggrandis la cata :lol:

si quelqu'un pourrait peut être m' orienté sur un fichier concernant ceci


Merci de votre aide :wink:
Avatar de l’utilisateur
zebu
Apprenti-posteur
Apprenti-posteur
 
Messages: 158
Enregistré le: 17 Déc 2004 à 18:32

Re: erreur après appel de l' url install

Messagepar lolovoisin » 27 Avr 2008 à 13:59

Le fichier que vous avez remis (functions.php), vous avez fais les MAJ 3.0.0 en 3.0.1 ou pas ?
Ceux qui échouent trouvent des excuses, ceux qui réussissent trouvent les moyens
Quand un homme a faim, mieux vaut lui apprendre à pêcher que de lui donner un poisson.
PAS DE SUPPORT PAR MP !!

tutophpbb3 + astuce + tutos debian
Avatar de l’utilisateur
lolovoisin
Rugbix ³
Rugbix ³
 
Messages: 39779
Enregistré le: 04 Mai 2006 à 13:16
Localisation: Dans la BDD ...

Re: erreur après appel de l' url install

Messagepar zebu » 27 Avr 2008 à 15:38

lolovoisin a écrit:Le fichier que vous avez remis (functions.php), vous avez fais les MAJ 3.0.0 en 3.0.1 ou pas ?


Je vois ou vous voulez en venir, en effet j' ai remis le fichier SEO modifié mais initialement en 3.0.0.

l' original du 3.01 non SEO me renvoyait une erreur similaire sur une ligne plus éloignée

Si je comprend bien, vous me suggérez de mettre le function php original 3.01 et faire dessus les modifs du phpbb SEO.


Apparement il semblerait que ce soit la même chose dans le viewtopic, les url n' ont pas la même forme (ne reprenne pas le titre des posts).

Si vous me confirmez, je tenterai les modifs de cette facon :wink:

En tout cas subjectivement, je trouve celà hyper très lourd, je pense que je baisserai les bras avant le trentième version :lol:

Merci :wink:
Avatar de l’utilisateur
zebu
Apprenti-posteur
Apprenti-posteur
 
Messages: 158
Enregistré le: 17 Déc 2004 à 18:32

Re: erreur après appel de l' url install

Messagepar lolovoisin » 27 Avr 2008 à 15:44

oui c'est ce que je vous suggère.
Prendre un fichier 3.0.1 et faire les modifs du mods sur ce fichier.
Sinon ils ne sont pas "raccord", c'est à dire un forum en 3.0.1 et un fichier functions en 3.0.0

PS: Normalement la fonction de fusion doit fonctionner sans problème même avec des MODs.
mais cela devrait s'améliorer dans le temps ;)
Ceux qui échouent trouvent des excuses, ceux qui réussissent trouvent les moyens
Quand un homme a faim, mieux vaut lui apprendre à pêcher que de lui donner un poisson.
PAS DE SUPPORT PAR MP !!

tutophpbb3 + astuce + tutos debian
Avatar de l’utilisateur
lolovoisin
Rugbix ³
Rugbix ³
 
Messages: 39779
Enregistré le: 04 Mai 2006 à 13:16
Localisation: Dans la BDD ...

Re: erreur après appel de l' url install

Messagepar 123*** » 27 Avr 2008 à 21:02

Bonjour,

zebu , j'ai le même problème que le tiens. [je n'expose pas mon problème ici, j'essaie juste d'aider zebu]
Après passage a phpbb 3.0.1, les titres de mes messages sont devenues "viewtopics"

j'ai regarde le fichier viewtopic.php: il a été mal modé par l'install de phpbb 3.0.1, c'est a dire les codes de SEO ont été mal placés, pas aux bons endroits en tout cas.

ce serait sympa de nous informer de la suite.
123***
Posteur néophyte
Posteur néophyte
 
Messages: 28
Enregistré le: 26 Fév 2008 à 08:01

Re: erreur après appel de l' url install

Messagepar zebu » 27 Avr 2008 à 22:49

A vrai dire, j' ai remarqué que je n' avais pas faite la mise a jour du SEO de 4.0.0 en 4.0.2.

j' ai terminé la 4.0.2 avec succès.

Je retente la mise à jour demain de phpBB avec ces nouveaux fichiers.
Avatar de l’utilisateur
zebu
Apprenti-posteur
Apprenti-posteur
 
Messages: 158
Enregistré le: 17 Déc 2004 à 18:32


Retourner vers Mises à jour/Conversions

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 2 invités