[Réglé] Erreur générale lors de l'install

Forum concernant les demandes de support pour tout problème d'installation d'un forum phpBB 3.3.x uniquement

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.

[Réglé] Erreur générale lors de l'install

Messagepar Lomic » 26 Mar 2020 à 19:49

Bonjour à tous,

Petit souci jamais rencontré jusqu'alors, j'ai une erreur générale SQL lors de l'installation :
General Error: SQL ERROR [ mysqli ]You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near '' at line 3
[1064] SQLSELECT * FROM phpbb_styles s WHERE s.style_id = in file /var/www/alternc/k/xxxxxxxxx/www/forum/phpbb/db/driver/driver.php on line 1023
BACKTRACEFILE: (not given by php)
LINE: (not given by php)
CALL: installer_msg_handler()FILE: [ROOT]/phpbb/db/driver/driver.phpLINE: 1023
CALL: trigger_error()FILE: [ROOT]/phpbb/db/driver/mysqli.php
LINE: 195
CALL: phpbb\db\driver\driver->sql_error()FILE: [ROOT]/phpbb/db/driver/factory.php
LINE: 345
CALL: phpbb\db\driver\mysqli->sql_query()FILE: [ROOT]/phpbb/user.php
LINE: 267
CALL: phpbb\db\driver\factory->sql_query()FILE: [ROOT]/phpbb/install/module/install_finish/task/install_extensions.php
LINE: 103
CALL: phpbb\user->setup()FILE: [ROOT]/phpbb/install/module_base.php
LINE: 149
CALL: phpbb\install\module\install_finish\task\install_extensions->run()FILE: [ROOT]/phpbb/install/installer.php
LINE: 219
CALL: phpbb\install\module_base->run()FILE: [ROOT]/phpbb/install/controller/install.php
LINE: 133
CALL: phpbb\install\installer->run()FILE: [ROOT]/vendor/symfony/http-foundation/StreamedResponse.php
LINE: 114
CALL: phpbb\install\controller\install->phpbb\install\controller\{closure}()FILE: [ROOT]/vendor/symfony/http-foundation/Response.php
LINE: 374
CALL: Symfony\Component\HttpFoundation\StreamedResponse->sendContent()FILE: [ROOT]/install/app.php
LINE: 62
CALL: Symfony\Component\HttpFoundation\Response->send()

Je suis bloqué à 77% à l'étape "Installing packaged extensions…"
Toutes mes tables semblent bien créées dans la base et sont peuplée.

Je ne vois pas cette requête à la ligne indiquée dans le fichier indiqué.

Je n'ai trouvé ça sur le net, mais je ne pense pas que ma base de donnée soit clusterisée.
https://www.phpbb.com/community/viewtopic.php?t=2425211

Également ça qui propose de retirer le mode strict de MySQL. Je n'ai pas accès à ce paramètre, j'ai posé la question à l'hébergeur (Infini.fr).
https://www.phpbb.com/community/viewtopic.php?t=2467341

Si jamais vous avez déjà eu le souci et trouvé la solution, ça m'intéresse.

C'est bien une base MySQL.
Modifié en dernier par Lomic le 04 Avr 2020 à 10:31, modifié 1 fois.
Lomic
Posteur néophyte
Posteur néophyte
 
Messages: 36
Enregistré le: 20 Fév 2012 à 12:57

Re: Erreur générale lors de l'install

Messagepar Lomic » 26 Mar 2020 à 21:09

[Edit]L'hébergeur me confirme que si la base est bien clusterisée... ça sent le sapin pour PhpBB...
Lomic
Posteur néophyte
Posteur néophyte
 
Messages: 36
Enregistré le: 20 Fév 2012 à 12:57

Re: Erreur générale lors de l'install

Messagepar Sylveretour » 26 Mar 2020 à 22:41

Bonjour,

Quelle version de phpBB tente tu d'installer?
Quel est ton hébergeur, url ?

Dans un message que tu cite :
Installed successfully by disabling strict MySQL mode by default:
[mysqld]
sql-mode = 'NO_ENGINE_SUBSTITUTION'

Il est dit que le mode strict a été désactivé.
C'est à ton hébergeur qu'il revient de vérifier et si besoin de rectifier cela !

Sinon, tu peut passer par une installation en local avec par exemple wampserver puis ensuite transférer le tout (rectifié) sur ton serveur.
Avatar de l’utilisateur
Sylveretour
Floodeur mature
Floodeur mature
 
Messages: 1603
Enregistré le: 21 Nov 2017 à 19:24
Localisation: West Coast

Re: Erreur générale lors de l'install

Messagepar Lomic » 27 Mar 2020 à 10:47

Sylveretour a écrit:Quelle version de phpBB tente tu d'installer?
la plus récente
Quel est ton hébergeur
Infini.fr comme indiqué dans le message
url ?
http://forum.konkarlab.bzh/ mais tu n'auras qu'une toute petite partie du message d'erreur en passant par là.

Sinon, tu peut passer par une installation en local avec par exemple wampserver puis ensuite transférer le tout (rectifié) sur ton serveur.
excellente idée, j'ai un forum à jour sous le coude, je vais exporter sa DB, piquer ses fichiers et hop ! En plus il y a déjà pas mal de boulot de personnalisation que j'aurais de toute façon voulu reprendre, j'aurais du faire comme ça dès le début :mrgreen:

Je vais tester, merci !
Lomic
Posteur néophyte
Posteur néophyte
 
Messages: 36
Enregistré le: 20 Fév 2012 à 12:57

Re: Erreur générale lors de l'install

Messagepar Lomic » 04 Avr 2020 à 10:34

Le coup de prendre un forum (à jour) ailleurs a pas mal fonctionné et j'ai pu contourner le problème de clusterisation qui semblait coincer pour l'installation normale de PhpBB3.

J'ai eu par contre quelques couacs sur la structure des tables, notamment pas mal de tables qui arrivaient sans clé primaire et sans auto-incrément sur ces clés, bien que la structure des tables du forum copié est bonne.

J'ai donc corrigé petit à petit ces problèmes de structure, en me basant sur ça : https://wiki.phpbb.com/Tables

Tout fonctionne bien à l'exception d'un truc qui m'échappe, mais je vais poster un sujet dédié au problème et je passe celui-ci en résolu.
Lomic
Posteur néophyte
Posteur néophyte
 
Messages: 36
Enregistré le: 20 Fév 2012 à 12:57


Retourner vers Installation

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité