Transfert de local vers hebergeur : page blanche

Forum concernant les demandes de support pour tout problème d'installation d'un forum phpBB 3.2.x uniquement

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.

Transfert de local vers hebergeur : page blanche

Messagepar hegaldi » 11 Juil 2019 à 18:35

Salut

J'ai fait le forum pour notre association en local sous Wampserver et maintenant que nous avons prit un hébergeur (o2switch) je le transfert donc dessus. J'ai suivis votre tuto Transférer son forum vers un autre hébergeur. Mais je tombe sur une page blanche. J'ai verifié deux fois les infos et elles sont bonnes, j'ai même renvoyé les fichiers.

Voici le lien : forum.pena0780.odns.fr (comme nous venons de prendre l’hébergement mais que nous n'avons pas encore transféré le nom de domaine de notre site, o2switch nous en a donné un provisoire).
hegaldi
Posteur néophyte
Posteur néophyte
 
Messages: 7
Enregistré le: 11 Juil 2019 à 17:52

Re: Transfert de local vers hebergeur : page blanche

Messagepar pierredu » 12 Juil 2019 à 08:53

Page blanche = erreur 500 (ce qui est d'ailleurs affiché dans Google Chrome).
Quand tu as envoyé les fichiers, tu as bien demandé un transfert binaire, pas Ascii ?
Avatar de l’utilisateur
pierredu
Resp. Extensions
Resp. Extensions
 
Messages: 1175
Enregistré le: 29 Mai 2011 à 06:49
Localisation: Paris

Re: Transfert de local vers hebergeur : page blanche

Messagepar hegaldi » 12 Juil 2019 à 11:17

Pour le mode de transfert mon FileZilla est réglé sur Automatique. Donc il a dû le faire en ASCII. Je refait l'envoi des fichier mais cette fois en Binaire. Est-ce que c'est spécifique a phpBB l'envoi en binaire ou c'est pour tous les CMS ?
hegaldi
Posteur néophyte
Posteur néophyte
 
Messages: 7
Enregistré le: 11 Juil 2019 à 17:52

Re: Transfert de local vers hebergeur : page blanche

Messagepar Sylveretour » 12 Juil 2019 à 11:25

Bonjour,

Pour l'envoi des fichiers en ftp, laisse toujours FileZilla réglé sur Automatique bien sûr.
Une page blanche est le plus souvent signe d'un problème de fichiers.
Donc, pour être plus sûr, supprime tout et recommence en vérifiant qu'aucune erreur de transfert ne soit produite.
Avatar de l’utilisateur
Sylveretour
Roi des posts
Roi des posts
 
Messages: 881
Enregistré le: 21 Nov 2017 à 19:24
Localisation: West Coast

Re: Transfert de local vers hebergeur : page blanche

Messagepar hegaldi » 12 Juil 2019 à 15:13

Sylveretour a écrit:Bonjour,

Pour l'envoi des fichiers en ftp, laisse toujours FileZilla réglé sur Automatique bien sûr.
Une page blanche est le plus souvent signe d'un problème de fichiers.
Donc, pour être plus sûr, supprime tout et recommence en vérifiant qu'aucune erreur de transfert ne soit produite.

Quant j'ai vue ton message l'envoi en mode Binaire était déjà en cours. J'ai donc laissé. Mais le probleme était toujours présent. J'ai supprimé a nouveau les fichiers, remis en mode Automatique et refait l'envoi (deux fois et a chaque fois en supprimant les fichiers). Mais toujours cette page blanche. Par contre il n'y a aucun message d'erreur de transfert dans FileZilla.
hegaldi
Posteur néophyte
Posteur néophyte
 
Messages: 7
Enregistré le: 11 Juil 2019 à 17:52

Re: Transfert de local vers hebergeur : page blanche

Messagepar pierredu » 12 Juil 2019 à 16:17

Essaie de mettre la ligne
@ini_set('display_errors', 'on');
au début de l'un des fichiers (index.php ou viewforum.php), pour avoir des messages d'information.
Il ne faudra pas oublier de l'enlever après.
Avatar de l’utilisateur
pierredu
Resp. Extensions
Resp. Extensions
 
Messages: 1175
Enregistré le: 29 Mai 2011 à 06:49
Localisation: Paris

Re: Transfert de local vers hebergeur : page blanche

Messagepar hegaldi » 12 Juil 2019 à 16:55

Voici les messages :
Warning: require(/home/pena0780/hegaldi-forum/vendor/composer/../symfony/polyfill-ctype/bootstrap.php): failed to open stream: No such file or directory in /home/pena0780/hegaldi-forum/vendor/composer/autoload_real.php on line 66

Warning: require(/home/pena0780/hegaldi-forum/vendor/composer/../symfony/polyfill-ctype/bootstrap.php): failed to open stream: No such file or directory in /home/pena0780/hegaldi-forum/vendor/composer/autoload_real.php on line 66

Fatal error: require(): Failed opening required '/home/pena0780/hegaldi-forum/vendor/composer/../symfony/polyfill-ctype/bootstrap.php' (include_path='.:/opt/cpanel/ea-php72/root/usr/share/pear') in /home/pena0780/hegaldi-forum/vendor/composer/autoload_real.php on line 66
hegaldi
Posteur néophyte
Posteur néophyte
 
Messages: 7
Enregistré le: 11 Juil 2019 à 17:52

Re: Transfert de local vers hebergeur : page blanche

Messagepar Sylveretour » 12 Juil 2019 à 18:01

je pense que tu a envoyé tout le contenu du dossier cache/
Dans ce dossier, supprime tout sauf index.htm et .htaccess
Avatar de l’utilisateur
Sylveretour
Roi des posts
Roi des posts
 
Messages: 881
Enregistré le: 21 Nov 2017 à 19:24
Localisation: West Coast

Re: Transfert de local vers hebergeur : page blanche

Messagepar hegaldi » 12 Juil 2019 à 18:53

Effectivement je l'avais renvoyé car j'avais oublié de le vider dans le dossier de sauvegarde sur mon ordi. Mais j'ai toujours les mêmes messages.
hegaldi
Posteur néophyte
Posteur néophyte
 
Messages: 7
Enregistré le: 11 Juil 2019 à 17:52

Re: Transfert de local vers hebergeur : page blanche

Messagepar Sylveretour » 12 Juil 2019 à 19:19

Le chemin des fichiers recherchés est incorrect:
vendor/composer/../symfony/polyfill-ctype/bootstrap.php

Devrait être:
vendor/symfony/polyfill-ctype/bootstrap.php

Cela peut provenir du nom de domaine provisoire

Supprime totalement le dossier vendor et renvoie le.
Si c'est toujours pareil, contacte ton hébergeur, le ndd définitif devrait être déjà en place...

Puis, quelle est la version de php en place?
pour voir cela, met cette ligne:
Code: Tout sélectionner
<?php phpinfo(); ?>

dans un fichier infos.php et envoie le sur ton serveur
Avatar de l’utilisateur
Sylveretour
Roi des posts
Roi des posts
 
Messages: 881
Enregistré le: 21 Nov 2017 à 19:24
Localisation: West Coast

Re: Transfert de local vers hebergeur : page blanche

Messagepar hegaldi » 13 Juil 2019 à 10:54

Nous avons prit l’hébergement sans le transfert de du nom de domaine, que nous ferrons plus tard (pour des raisons de simplicité concernant le site).

Pour PHP c'est la 7.3.7. Pour voir la version j'ai mis ton code dans index.php mais rien, toujours cette page blanche. J'ai mis le code dans un fichier spécifique que j'ai nommé versionphp.php (que j'ai bien entendu supprimé après). Là j'ai réussis a voir la version.

Edit : j'avais pas lu la dernière phrase de ton message précédent (créer un fichier PHP pour le code). J'ai fait mon boulet lol
Modifié en dernier par hegaldi le 13 Juil 2019 à 11:38, modifié 1 fois.
hegaldi
Posteur néophyte
Posteur néophyte
 
Messages: 7
Enregistré le: 11 Juil 2019 à 17:52

Re: Transfert de local vers hebergeur : page blanche

Messagepar Steph » 13 Juil 2019 à 10:58

Salut,

PhpBB 3.2.x n'est pas compatible avec PHP7.3
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 18955
Enregistré le: 29 Déc 2008 à 16:48
Localisation: Alsace / Bas-Rhin / France

Re: Transfert de local vers hebergeur : page blanche

Messagepar hegaldi » 13 Juil 2019 à 11:35

Alors je passe PHP en 7.2 et je demande a mon hébergeur si le nom de domaine temporaire peux être le souci.
hegaldi
Posteur néophyte
Posteur néophyte
 
Messages: 7
Enregistré le: 11 Juil 2019 à 17:52

Re: Transfert de local vers hebergeur : page blanche

Messagepar Sylveretour » 13 Juil 2019 à 21:27

Le soucis est la version de php.
C'est pour cela que je t'ai donné le code permettant de la voir, l'erreur est dûe à cela.
Quand une version 7.2 sera en cours, tu pourra installer phpbb mais des paramètres seront à modifier ensuite.0
Avatar de l’utilisateur
Sylveretour
Roi des posts
Roi des posts
 
Messages: 881
Enregistré le: 21 Nov 2017 à 19:24
Localisation: West Coast


Retourner vers Installation

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité