[Réglé] 5 forums phpbb3.2.2 dans 2 bases de données : ca coince

Forum concernant les demandes de support pour tout problème d'installation d'un forum phpBB 3.2.x uniquement

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.

[Réglé] 5 forums phpbb3.2.2 dans 2 bases de données : ca coince

Messagepar jpmjpm » 24 Juil 2018 à 22:28

Problème à priori simple mais je dois manquer une marche quelque part (je ne peux pas donner d'url car le site est en construction) :

- un nom de domaine : site.com avec son hébergement
- un forum phpbb version 3.2.2 mais plein de modifs et d'extensions (et donc avec un peu de datas de départ) installé dans un répertoire site.com/vip0/
- un préfixe de table : 'vip0_'

- Et la j'ai besoin d'installer 3 clones de ce forum de départ :
- dans 3 autres répertoires (donc vip1_ vip2_ vip3_)
- dans la même base de données avec des préfixes différents ...
Ca marche sans souci (apparent ! voir ci-dessous) jusqu'à ce que je prolonge la chose ...

Pour le clone vip4_, je l installe toujours sur le même site dans le répertoire vip4 mais dans une seconde base de données (du même hébergement) avec vip4_ comme préfixe de table ...

Et là ca part en vrille :
- j'ai beau avoir modifié le config.php comme il faut (bon nom de base de données et préfixe vip4_)
- j'ai beau avoir modifié tous les vip0 en vip4 dans la table vip4_config

J'ai droit a ceci au lancement sur index.php :
General Error

SQL ERROR [ mysqli ]

Table 'nomdemabdd.vip0_config' doesn't exist [1146]

An sql error occurred while fetching this page. Please contact an administrator if this problem persists.


Mais que viens faire ce vip0_ là alors que partout j'ai mis vip4_ ... !

Et du coup je comprends que mon sentiment de bon fonctionnement lorsque ca reste dans la même bdd (vip0 1 2 3) est trompeur ... le forum vip2 doit lui aussi aller chercher vip0_config sans que ca plante puisque dans la meme bdd il y a 4 forum donc vip0 bien sur). ! Bref un beau pataquès surement ... (bon là c'est en phase dev et pas en prod bien sur).

Une journée que je m'arrache les derniers cheveux ... (j'ai même été jusqu'à sauver la bdd contenant vip4_, l'ouvrir avec un éditeur et faire un "remplacer 'vip0' par vip4 avant de réimporter). Rien n'y fait !

Au final j'ai re testé en repartant d'un phpbb zippé tout neuf et en re simulant la chose (pensant que ce sont peut être mes modifs ou les extensions qui perturbent la chose : exactement le même symptôme :\

J'ai loupé quoi ? Help ... là je sèche complet.

Edit : j'ai oublié de préciser :
hebergement mutu ovh perso+sqlstart 5 bdd de 100 mo
php 5.6
MySQL 5.6 aussi
Modifié en dernier par jpmjpm le 25 Juil 2018 à 02:22, modifié 1 fois.
jpmjpm
Posteur néophyte
Posteur néophyte
 
Messages: 11
Enregistré le: 04 Juil 2018 à 11:55

Re: 5 forums phpbb3.2.2 dans 2 bases de données : ca coince

Messagepar Zoddo » 25 Juil 2018 à 01:26

Bonjour,

Un petit vidage du cache (supprimer le dossier "production" dans le dossier "cache") pourrait aider.
[Doc] Installer une extension - [Extension] Post Models - [Recrutement] Équipe des Extensions
Si vous considérez votre requête comme résolue, merci d'ajouter l'attribut de sujet [Réglé]
Zoddo
Equipe site
Equipe site
 
Messages: 7043
Enregistré le: 16 Mar 2011 à 18:44
Localisation: Laval / Le Mans

Re: 5 forums phpbb3.2.2 dans 2 bases de données : ca coince

Messagepar jpmjpm » 25 Juil 2018 à 02:22

Bonne pioche ! Bingo ! Alléluia ! Merci Zoddo, tu me sauves ...
jpmjpm
Posteur néophyte
Posteur néophyte
 
Messages: 11
Enregistré le: 04 Juil 2018 à 11:55


Retourner vers Installation

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité