[Réglé] Mettre en place forum de test.

Forum concernant les demandes de support pour tout problème d'installation d'un forum phpBB 3.2.x uniquement

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.

[Réglé] Mettre en place forum de test.

Messagepar Fannyoiseau » 25 Jan 2018 à 14:04

Bonjour à tous,

Pouvez vous me guider SVP afin que je puisse installer un forum de test, car je ne sais pas du tout comment procéder.
Merci beaucoup pour cette nouvelle aide.

Mon forum : https://oiseau-libre.com/index.php

Cordialement.
Fanny
Modifié en dernier par Fannyoiseau le 29 Jan 2018 à 21:22, modifié 1 fois.
Fanny
Avatar de l’utilisateur
Fannyoiseau
Posteur néophyte
Posteur néophyte
 
Messages: 38
Enregistré le: 20 Oct 2017 à 17:32
Localisation: Ajaccio (Corse)

Re: Mettre en place forum de test.

Messagepar Sylveretour » 25 Jan 2018 à 15:28

Bonjour,

L'idéal est de le faire chez toi, sur ton ordi, plus simple à gérer et à mettre en œuvre.
Voir par exemple ce sujet => support-installation-phpbb32/sujet211097.html?hilit=wampserver#p1651887
Pour télécharger le tout voir ici => http://wampserver.aviatechno.net/
Tout ce qui doit être installé est présent dans cette page.

Première chose à savoir, si tu tourne en 64Bits, il faut tout installer en X86 et 64Bits
D'abord, installer les différentes versions de Visual C++ (en bas de la page)
Pour voir ceux déjà installés, panneau de configuration => programmes et fonctionnalités
IL faut les 2008/2010/2012/2013/2017

Ensuite, télécharger:
Wampserver 3.1.0 32 bit x86 - Apache 2.4.27 - PHP 5.6.31/7.0.23/7.1.9 - MySQL 5.7.19 - MariaDB 10.2.8 MD5
Wampserver 3.1.0 64 bit x64 - Apache 2.4.27 - PHP 5.6.31/7.0.23/7.1.9 - MySQL 5.7.19 - MariaDB 10.2.8 MD5


Les installer et les faire tourner l'un après l'autre

Une fois ceci fait, tu télécharge Wampserver update 3.1.1 MD5
Puis tu fait tourner cette mise à jour 3.1.0 vers 3.1.1 sur wamp puis sur wamp64

Si tu tourne en 64Bits, tu te sert de cette version (beaucoup plus rapide et puissante)
Tu active php 7.1.9

C'est fait, tu a un serveur virtuel, le forum (dossier nommé "forum") est à mettre dans le dossier "www"
Il te suffit alors de pointer vers http://localhost/forum/
Avatar de l’utilisateur
Sylveretour
Maître-posteur
Maître-posteur
 
Messages: 443
Enregistré le: 21 Nov 2017 à 19:24
Localisation: West Coast

Re: Mettre en place forum de test.

Messagepar Manard » 25 Jan 2018 à 19:49

Bonsoir,

Effectivement le serveur local est une des solutions, mais si Fanny a un hébergement qui lui permet d'installer une deuxième base de données, à mon avis c'est plus facile pour elle et elle sera déjà en configuration réelle coté des versions php installées sur le serveur d'hébergement.

D'ailleurs pour Wampserver un développeur qui connaît bien, indique qu'il n'y a aucun avantage à installer la version 64 bits qui serait expérimentale : https://www.jcz.fr/wampserver/

Bonne soirée

Bernard
Modifié en dernier par Manard le 25 Jan 2018 à 23:04, modifié 1 fois.
Manard
Roi des posts
Roi des posts
 
Messages: 929
Enregistré le: 31 Mar 2012 à 09:24

Re: Mettre en place forum de test.

Messagepar Sylveretour » 25 Jan 2018 à 20:17

Non, il est préférable d'avoir un forum de test en local qui sera la reproduction exacte de celui en ligne.
Ensuite, il suffit de faire pointer son logiciel client FTP entre les deux.
Les fichiers modifiés en local peuvent alors remplacer très facilement ceux du serveur quand il le faut...

à installer la version 64 bits qui serait expérimentale

Ha ben dommage alors! ça fait des années qu'elle existe et que je l'utilise. En ayant une version X86 installée sur un autre ordi, je peut dire qu'il y a de grosses différences.
Avatar de l’utilisateur
Sylveretour
Maître-posteur
Maître-posteur
 
Messages: 443
Enregistré le: 21 Nov 2017 à 19:24
Localisation: West Coast

Re: Mettre en place forum de test.

Messagepar Fannyoiseau » 26 Jan 2018 à 09:42

Bonjour,
Merci beaucoup Sylveretour et Bernard pour l'attention portée à ma demande.

Mon hébergeur est OVH et il est plus que certain que je vais faire au pus simple, car malgré tes explications très
précises et intéressantes Sylveretour, j'avoue que je nage et que c'est trop compliqué pour moi de procéder comme cela.
je suis désolée de venir demander de l'aide et ensuite ne pas savoir me débrouiller :oops:

Je vais donc essayer de voir si je peux dans un premier temps, suivre les conseils de Bernard .
Je vous remercie beaucoup sincèrement, et vous souhaite une bonne journée.
Fanny
Avatar de l’utilisateur
Fannyoiseau
Posteur néophyte
Posteur néophyte
 
Messages: 38
Enregistré le: 20 Oct 2017 à 17:32
Localisation: Ajaccio (Corse)


Retourner vers Installation

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité