[Réglé] Problème connexion depuis Wampserver

Forum concernant les demandes de support pour tout problème d'installation d'un forum phpBB 3.2.x uniquement

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.
Partager sur FacebookPartager sur TwitterPartager sur Google+

[Réglé] Problème connexion depuis Wampserver

Messagepar Nullette » 26 Juin 2017 à 16:13

Bonjour,
j'ai installé une copie de mon forum en local en utilisant Wampserver.
C'est presque bon, sauf que, quand je me connecte...j'arrive sur mon forum en ligne.
Le fichier config :
Code: Tout sélectionner
<?php
// phpBB 3.2.x auto-generated configuration file
// Do not change anything in this file!
$dbms = 'phpbb\\db\\driver\\mysqli';
$dbhost = 'localhost';
$dbport = '';
$dbname = 'Nullette_mabase';
$dbuser = 'root';
$dbpasswd = '';
$table_prefix = 'phpbb3_';
$phpbb_adm_relative_path = 'adm/';
$acm_type = 'phpbb\\cache\\driver\\file';

@define('PHPBB_INSTALLED', true);
// @define('DEBUG', true);
// @define('DEBUG_EXTRA', true);
?>


J'utilise en local le même pseudo et mot de passe que celui du forum en ligne.
Concernant les cookies, je ne sais pas s'il faut les changer et quoi mettre.

Avez-vous une idée de comment je pourrais arranger ce problème ?
Modifié en dernier par Nullette le 27 Juin 2017 à 08:03, modifié 1 fois.
Site et forum hébergés chez PhpBB-Services
Nullette
Empereur des posts
Empereur des posts
 
Messages: 1027
Enregistré le: 22 Avr 2009 à 22:28
Localisation: Paris

Re: Problème connexion depuis Wampserver

Messagepar cocooncrash » 26 Juin 2017 à 16:22

Il faut les changer oui, et aussi changer les valeurs dans ta base de donnée, cookie, server name. vois le tutoriel.
decouvrez l'aide complete : ICI
découvrez les règles : La_bas

Pensez a ajouter le tag [réglé] en modifiant votre premier message s'il est résolu. Merci :wink:
Avatar de l’utilisateur
cocooncrash
Resp. des modérateurs
Resp. des modérateurs
 
Messages: 7543
Enregistré le: 07 Jan 2008 à 08:29
Localisation: dans un bocal en compagnie de nemo!!

Re: Problème connexion depuis Wampserver

Messagepar Nullette » 26 Juin 2017 à 16:25

Merci :)
Je suis entrain de lire le tuto....
Comme tu sais, j'apprends, j'oublie...
A+
Site et forum hébergés chez PhpBB-Services
Nullette
Empereur des posts
Empereur des posts
 
Messages: 1027
Enregistré le: 22 Avr 2009 à 22:28
Localisation: Paris

Re: Problème connexion depuis Wampserver

Messagepar galixte » 26 Juin 2017 à 16:38

Salut,

normalement si tu n’as pas activé l’option « Forcer les paramètres URL du serveur », tu ne dois modifier que la valeur du paramètre cookie_domain (domaine du cookie) par localhost dans la table phpbb_configphpbb est le préfixe de tes tables.

Aussi, pense à purger le cache de ton forum. ;)
Communau EzCom
Image
« Traductions d’extensions & styles pour phpBB 3.1.x & 3.2.x ».
ImageListes de toutes les extensions recensées pour phpBB 3.1.x & 3.2.x.
ImageListes de tous les styles recensés pour phpBB 3.1.x & 3.2.x.
Avatar de l’utilisateur
galixte
Floodeur universel
Floodeur universel
 
Messages: 10068
Enregistré le: 08 Mar 2004 à 01:40
Localisation: Sud de la France.

Re: Problème connexion depuis Wampserver

Messagepar cocooncrash » 26 Juin 2017 à 17:11

et server name galixte!
decouvrez l'aide complete : ICI
découvrez les règles : La_bas

Pensez a ajouter le tag [réglé] en modifiant votre premier message s'il est résolu. Merci :wink:
Avatar de l’utilisateur
cocooncrash
Resp. des modérateurs
Resp. des modérateurs
 
Messages: 7543
Enregistré le: 07 Jan 2008 à 08:29
Localisation: dans un bocal en compagnie de nemo!!

Re: Problème connexion depuis Wampserver

Messagepar galixte » 26 Juin 2017 à 17:28

  • Si l’option « Forcer les paramètres URL du serveur » est activée, ce qui est le cas par défaut, il n’y en a pas besoin.
  • Si l’option est activée, oui il faut saisir la valeur : localhost pour le champ server_name (Nom de domaine) dans la table phpbb_configphpbb est le préfixe de tes tables.
Communau EzCom
Image
« Traductions d’extensions & styles pour phpBB 3.1.x & 3.2.x ».
ImageListes de toutes les extensions recensées pour phpBB 3.1.x & 3.2.x.
ImageListes de tous les styles recensés pour phpBB 3.1.x & 3.2.x.
Avatar de l’utilisateur
galixte
Floodeur universel
Floodeur universel
 
Messages: 10068
Enregistré le: 08 Mar 2004 à 01:40
Localisation: Sud de la France.

Re: Problème connexion depuis Wampserver

Messagepar Nullette » 26 Juin 2017 à 17:42

galixte a écrit:[list][*]Si l’option « Forcer les paramètres URL du serveur » est activée, ce qui est le cas par défaut, il n’y en a pas besoin.

Je ne sais pas si c'est activé, car je n'arrive pas à me connecter.

J'ai vidé le cache, pour server_name j'ai mis : localhost, cookie_domain : localhost.

Maintenant, en cliquant sur connexion, j'arrive à "Erreur de chargement de la page"

Code: Tout sélectionner
https://localhost/index.php?sid=xxxx


Edit :
Bizarre, je peux lire les forums ouverts aux non inscrits et il est indiqué que je suis connectée !

Edit bis :
Le forum en local s'affiche :
Code: Tout sélectionner
http://forum/


Quand je me connecte et j'obtiens l'erreur de chargement, s'affiche :
https://forum/index.php


Est-ce que le problème viendrait de la sécurisation SSL ?
Si c'est le cas, savez-vous comment la retirer du forum en local ?
Site et forum hébergés chez PhpBB-Services
Nullette
Empereur des posts
Empereur des posts
 
Messages: 1027
Enregistré le: 22 Avr 2009 à 22:28
Localisation: Paris

Re: Problème connexion depuis Wampserver

Messagepar galixte » 26 Juin 2017 à 18:56

Même table, pour les champs suivants :
  • server_protocol saisir la valeur http://
  • server_port saisir la valeur 80 ou autre si WAMPSERVER fonctionne par exemple sur le port 8080.
  • cookie_secure saisir al valeur 0

Purger les caches du navigateur et du forum (manuellement depuis son répertoire sauf les fichiers ./cache/.htaccess et ./cache/index.htm), supprimer les cookies du navigateur pour le nom de domaine localhost.
Communau EzCom
Image
« Traductions d’extensions & styles pour phpBB 3.1.x & 3.2.x ».
ImageListes de toutes les extensions recensées pour phpBB 3.1.x & 3.2.x.
ImageListes de tous les styles recensés pour phpBB 3.1.x & 3.2.x.
Avatar de l’utilisateur
galixte
Floodeur universel
Floodeur universel
 
Messages: 10068
Enregistré le: 08 Mar 2004 à 01:40
Localisation: Sud de la France.

Re: Problème connexion depuis Wampserver

Messagepar Nullette » 26 Juin 2017 à 19:20

Merciii.
Je crois que ça fonctionne.
Protocole du serveur http://
Port du serveur 80 (il était à 443).
Nom de domaine : forum

Pour ce dernier, je ne sais pas s'il fallait mettre "localhost".
En tout cas j'ai pu accéder au panneau d'administration du forum. :D
J'ai pu désactiver Google analytics, Tapatalk et autres.

J'attends demain pour indiquer Réglé

EDIT

Zut ! J'ai l'erreur générale pour lire les messages (je ne l'avais pas avant) :

Code: Tout sélectionner
SQL ERROR [ mysqli ]

Expression #3 of SELECT list is not in GROUP BY clause and contains nonaggregated column 'nullette_mabase.w.counter_user' which is not functionally dependent on columns in GROUP BY clause; this is incompatible with sql_mode=only_full_group_by [1055]

SQL

SELECT w.user_id, w.topic_id, w.counter_user, w.date, u.username, u.user_colour, u.user_id, u.user_avatar, u.user_avatar_type, u.user_avatar_height, u.user_avatar_width, u.user_type, SUM(w.counter_user) AS total FROM phpbb3_whovisitedthistopic w, phpbb3_users u WHERE w.topic_id = 8010 AND w.user_id = u.user_id GROUP BY w.user_id ORDER BY w.date DESC LIMIT 20

BACKTRACE


Re-Edit
Désolée de revenir.
Il me semble que c'était dû à l'extension "Who visited this post". Je l'ai désactivée et n'ai plus l'erreur.
Site et forum hébergés chez PhpBB-Services
Nullette
Empereur des posts
Empereur des posts
 
Messages: 1027
Enregistré le: 22 Avr 2009 à 22:28
Localisation: Paris

Re: Problème connexion depuis Wampserver

Messagepar Nullette » 27 Juin 2017 à 08:03

Bonjour et merci à vous.
Tout fonctionne. :D
Site et forum hébergés chez PhpBB-Services
Nullette
Empereur des posts
Empereur des posts
 
Messages: 1027
Enregistré le: 22 Avr 2009 à 22:28
Localisation: Paris

Re: Problème connexion depuis Wampserver

Messagepar galixte » 27 Juin 2017 à 19:06

Salut,

tu parles de cette extension ? https://www.phpbb.com/customise/db/exte ... his_topic/ Quelle version de PHP utilises-tu  ?
Communau EzCom
Image
« Traductions d’extensions & styles pour phpBB 3.1.x & 3.2.x ».
ImageListes de toutes les extensions recensées pour phpBB 3.1.x & 3.2.x.
ImageListes de tous les styles recensés pour phpBB 3.1.x & 3.2.x.
Avatar de l’utilisateur
galixte
Floodeur universel
Floodeur universel
 
Messages: 10068
Enregistré le: 08 Mar 2004 à 01:40
Localisation: Sud de la France.

Re: Problème connexion depuis Wampserver

Messagepar Nullette » 27 Juin 2017 à 20:04

Oui : dmzx/whovisitedthistopic
Je n'ai pas le temps d'aller dans son forum et je n'ai pas gardé copie du texte de l'erreur.
(En ligne elle fonctionne parfaitement).

Concernant PHP, si tu parles de la version en local, avec Wampserver, j'ai 5.6.2.5 coché.
Site et forum hébergés chez PhpBB-Services
Nullette
Empereur des posts
Empereur des posts
 
Messages: 1027
Enregistré le: 22 Avr 2009 à 22:28
Localisation: Paris

Re: Problème connexion depuis Wampserver

Messagepar galixte » 28 Juin 2017 à 07:16

Ah oui c’est en local, ok donc peu important. ;)
Communau EzCom
Image
« Traductions d’extensions & styles pour phpBB 3.1.x & 3.2.x ».
ImageListes de toutes les extensions recensées pour phpBB 3.1.x & 3.2.x.
ImageListes de tous les styles recensés pour phpBB 3.1.x & 3.2.x.
Avatar de l’utilisateur
galixte
Floodeur universel
Floodeur universel
 
Messages: 10068
Enregistré le: 08 Mar 2004 à 01:40
Localisation: Sud de la France.


Retourner vers Installation

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 2 invités