[Réglé] Changement de version PHP impossible (de 5.6 a 7.1)

Forum concernant les demandes de support pour tout problème d'installation d'un forum phpBB 3.2.x uniquement

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.
Partager sur FacebookPartager sur TwitterPartager sur Google+

[Réglé] Changement de version PHP impossible (de 5.6 a 7.1)

Messagepar stpere » 07 Juin 2017 à 15:24

Bonjour a tous

Apres avoir mis a jour le forum, puis migré d'hébergeur, je me frotte maintenant a un nouveau problème. Le forum passé en 3.2 ne supporte pas le changement de version PHP (7 ou 7.1)

Si je change la version PHP, voici le message d'erreur :

Code: Tout sélectionner
General Error
SQL ERROR [ mysql4 ]

mysql_connect function does not exist, is mysql extension installed? []

An sql error occurred while fetching this page. Please contact an administrator if this problem persists.


Si je remets la version 5.6, tout revient à la normale.

Où peut se situer l'erreur a corriger ? Y a t'il un fichier de config a modifier quelque part ?

Merci et bonne journée !
Pierre
Modifié en dernier par stpere le 07 Juin 2017 à 16:14, modifié 1 fois.
----------------------------------------------------
http://www.pierre-barthelemy.fr

https://www.passionhockey.com
https://forum.passionhockey.com
----------------------------------------------------
stpere
Posteur néophyte
Posteur néophyte
 
Messages: 42
Enregistré le: 11 Jan 2007 à 11:16

Re: Changement de version PHP impossible (de 5.6 a 7.1)

Messagepar ABDev » 07 Juin 2017 à 16:03

Bonjour,
Dans le fichier config.php, remplacez :

Code: Tout sélectionner
$dbms 'mysql4'

par :

Code: Tout sélectionner
$dbms 'mysqli'

Basculez ensuite sur PHP7 pour voir ce que ça donne.
Pour se payer le luxe d'être feignant, il faut sans cesse faire travailler ses méninges ! (Korben)

On clique sur le bouton Répondre plutôt que le bouton Citer ...
Un problème avec une extension ? Pas de lien vers celle-ci ? Sujet ignoré !
Avatar de l’utilisateur
ABDev
Programmationateur
Programmationateur
 
Messages: 15689
Enregistré le: 12 Mai 2005 à 22:54

Re: Changement de version PHP impossible (de 5.6 a 7.1)

Messagepar stpere » 07 Juin 2017 à 16:14

Bonjour

Ca fonctionne :)
A ceci pret que je n'avais pas mysql4 mais uniquement mysql
C'est pourquoi je n'y avais pas touché...

Merci beaucoup !
----------------------------------------------------
http://www.pierre-barthelemy.fr

https://www.passionhockey.com
https://forum.passionhockey.com
----------------------------------------------------
stpere
Posteur néophyte
Posteur néophyte
 
Messages: 42
Enregistré le: 11 Jan 2007 à 11:16


Retourner vers Installation

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité