"Incorrect integer value"

Forum concernant les demandes de support pour tout problème d'installation d'un forum phpBB 3.1.x uniquement

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.
Partager sur FacebookPartager sur TwitterPartager sur Google+

"Incorrect integer value"

Messagepar Puffer59 » 01 Fév 2017 à 18:00

A la suite de mon premier sujet (voir ici : support-utilisation-phpbb32/sujet209485.html), je me confronte à un nouveau problème..

Suite à ma mise à jour vers 3.1.x, l'installation s'est apparement bien déroulé, sauf que j'obtient ce message d'erreur :

Ce qui rend notre forum encore une fois indisponible..

SQL ERROR [ mysqli ]

Incorrect integer value: 'avatar.driver.upload' for column 'user_avatar_type' at row 53 [1366]

SQL

UPDATE phpbb_users SET user_avatar_type = 'avatar.driver.upload' WHERE user_avatar_type = '1'

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/phpbb/db/driver/driver.php
LINE: 855
CALL: trigger_error()

FILE: [ROOT]/phpbb/db/driver/mysqli.php
LINE: 193
CALL: phpbb\db\driver\driver->sql_error()

FILE: [ROOT]/phpbb/db/driver/factory.php
LINE: 329
CALL: phpbb\db\driver\mysqli->sql_query()

FILE: [ROOT]/phpbb/db/migration/data/v310/avatar_types.php
LINE: 50
CALL: phpbb\db\driver\factory->sql_query()

FILE: (not given by php)
LINE: (not given by php)
CALL: phpbb\db\migration\data\v310\avatar_types->update_user_avatar_type()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 591
CALL: call_user_func_array()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 538
CALL: phpbb\db\migrator->run_step()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 361
CALL: phpbb\db\migrator->process_data_step()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 276
CALL: phpbb\db\migrator->try_apply()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 276
CALL: phpbb\db\migrator->try_apply()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 276
CALL: phpbb\db\migrator->try_apply()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 216
CALL: phpbb\db\migrator->try_apply()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 199
CALL: phpbb\db\migrator->update_do()

FILE: [ROOT]/install/database_update.php
LINE: 205
CALL: phpbb\db\migrator->update()


Encore merci à ceux qui prennent le temps de me répondre :oops:
Puffer59
Posteur néophyte
Posteur néophyte
 
Messages: 8
Enregistré le: 30 Jan 2017 à 19:13

Re: "Incorrect integer value"

Messagepar Steph » 01 Fév 2017 à 18:04

Regarde si ce sujet apporte un début de solution : support-mises-a-jour-conversions-phpbb31/sujet206530.html

Sinon en anglais : https://www.phpbb.com/community/viewtop ... &t=2249251

Aparement le souci est déjà connu : https://tracker.phpbb.com/browse/PHPBB3 ... l-tabpanel

https://github.com/phpbb/phpbb/pull/343 ... 603deb001f

Par contre, il faudrait être sur de la version de phpBB que tu utilises ... 3.1 ou 3.2 ?
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 17267
Enregistré le: 29 Déc 2008 à 15:48
Localisation: Alsace / Bas-Rhin / France

Re: "Incorrect integer value"

Messagepar Puffer59 » 01 Fév 2017 à 18:45

J'ai fais la mise a jour de 3.0 à 3.1 :)
Puffer59
Posteur néophyte
Posteur néophyte
 
Messages: 8
Enregistré le: 30 Jan 2017 à 19:13

Re: "Incorrect integer value"

Messagepar Steph » 01 Fév 2017 à 18:59

OK, je demande, car dans l'autre sujet tu parles de la version 3.2

Tu as pu trouver une piste dans les liens que je t'ai donnés ?

PS J'ai supprimé la citation de ton message, car tu me cites en entier et cela charge inutilement la page.
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 17267
Enregistré le: 29 Déc 2008 à 15:48
Localisation: Alsace / Bas-Rhin / France

Re: "Incorrect integer value"

Messagepar galixte » 01 Fév 2017 à 22:49

Salut,

oui il était en 3.0.10.

Selon les informations glanées par Steph, ce problème concerne on dirait que tu as mis à jour ton forum en version 3.1.0 ou inférieur (RC4, RC5, etc.) comme si lors de ta mise à niveau le script se serait arrêté en cours.

Aussi, tu as quelle version dans ton panneau d’administration ? S’agit-il de la 3.1.10 (la dernière de cette branche) ou d’une version moins récente ?

EDIT: il semble que cela soit bien dû à une mise à jour non complète, voir ce message : support-mises-a-jour-conversions-phpbb31/sujet206530.html. D’ailleurs cela peut concerner une état dépassant la version 3.1.0.

Avais-tu des MODs (pour MODifications, fonctionnalités supplémentaires à celles offertes par défaut par phpBB 3.0.x) installés sur ton forum en version 3.0.10 ?
Si c’est le cas ou parce que si tu ne sais pas, le mieux serait de restaurer ton ancien forum en version 3.0.10 puis de suivre cette démarche : documentation/mise-a-jour/31x-mise-a-niveau-de-phpbb-30x-vers-31x-a209-view.html en veillant à utiliser l’outil STK afin de nettoyer ta base de données.
Communau EzCom
Image
« Traductions d’extensions & styles pour phpBB 3.1.x & 3.2.x ».
ImageListes de toutes les extensions recensées pour phpBB 3.1.x & 3.2.x.
ImageListes de tous les styles recensés pour phpBB 3.1.x & 3.2.x.
Avatar de l’utilisateur
galixte
Floodeur universel
Floodeur universel
 
Messages: 9883
Enregistré le: 08 Mar 2004 à 01:40
Localisation: Sud de la France.

Re: "Incorrect integer value"

Messagepar Puffer59 » 06 Fév 2017 à 16:27

En haut, ça m'écrit : Version précédente :: 3.1.0-a2

Je ne crois pas que j'avais de MODs, juste des smileys, et un theme "poker" avec une banniere modifié. Vraiment du tres tres tres basique.

Pour acceder a l'ACP, je peux le faire via url ? car d'habitude je cliquais tout en bas sur la page principale mais là, ca n'y apparait pas. :mrgreen:

J'avias essayer STK avant, mais ca avais planté. Je tente tous ce que vous m'avez dis dans la journée, et ensuite je reviens vers vous. (EDIT : J'avais essayer mais mon forum etait en 3.0.10, sur la page du ToolKit, il me propose que 3.0.12 / 13 / 14. C'est un probleme ou pas ? )

Encore merci pour votre temps et votre aide
Puffer59
Posteur néophyte
Posteur néophyte
 
Messages: 8
Enregistré le: 30 Jan 2017 à 19:13


Retourner vers Installation

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité