Bases de données supportées et Version de PHP incorrects

Forum concernant les demandes de support pour tout problème d'installation d'un forum phpBB 3.1.x uniquement

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.
Partager sur FacebookPartager sur TwitterPartager sur Google+

Bases de données supportées et Version de PHP incorrects

Messagepar Psychomasse » 22 Nov 2016 à 15:52

Bonjour,
J'ai déjà installé phpbb et je n'avais pas eu de soucis. Mais là j'ai changé de serveur et une fois arrivé à la page de "Compatibilité de l’installation", il y a d'affreux messages rouges qui m'empêchent de continuer :

- pour "Version de PHP et paramètres" :
Version de PHP : >= 5.3.3, < 7.0.0-dev : Non

- pour "Bases de données supportées" :
MySQL avec l’extension MySQLi : Disponible
MySQL : Indisponible
MSSQL Server 2000+ : Indisponible
MSSQL Server 2000+ via ODBC : Indisponible
MSSQL Server 2005+ [ Natif ] : Indisponible
Oracle : Indisponible
PostgreSQL : Indisponible
SQLite 2 : Indisponible

SQLite 3 : Disponible

Je ne vois pas à quoi ça peut renvoyer, comme problème. Et pas moyen de trouver des mots clés sur internet pour le résoudre :(
Je ne comprends même pas pourquoi il cherche la base données maintenant, alors qu'il n'y pas les accès.

Des idées svp ?
Merci
Avatar de l’utilisateur
Psychomasse
Posteur néophyte
Posteur néophyte
 
Messages: 16
Enregistré le: 04 Sep 2016 à 23:28
Localisation: derrière toi !

Re: Bases de données supportées et Version de PHP incorrects

Messagepar galixte » 22 Nov 2016 à 16:11

Au moyen de PHP il peut savoir si MySQL ou ses équivalents sont présents. Là, ton problème c’est la version de PHP sur ton hébergement, demande à ton hébergeur de basculer en version 5.6.
Communau EzCom
Image
« Traductions d’extensions & styles pour phpBB 3.1.x & 3.2.x ».
ImageListes de toutes les extensions recensées pour phpBB 3.1.x & 3.2.x.
ImageListes de tous les styles recensés pour phpBB 3.1.x & 3.2.x.
Avatar de l’utilisateur
galixte
Floodeur universel
Floodeur universel
 
Messages: 9537
Enregistré le: 08 Mar 2004 à 02:40
Localisation: Sud de la France.

Re: Bases de données supportées et Version de PHP incorrects

Messagepar Psychomasse » 23 Nov 2016 à 18:10

Merci de ta réponse.
J'ai pris un peu de temps, afin de faire différents essais, notamment pour changer la version de la base de données et d'en créer une nouvelle.
Ce qui est chose faite. Mais ça ne change rien.
Image
Pourtant sur mon autre serveur, avec le même hébergeur et les mêmes paramètres, ça fonctionne.
Et j'ai déjà réussi à installer wordpress. Je ne vois pas pourquoi phpbb bloque :/
Avatar de l’utilisateur
Psychomasse
Posteur néophyte
Posteur néophyte
 
Messages: 16
Enregistré le: 04 Sep 2016 à 23:28
Localisation: derrière toi !

Re: Bases de données supportées et Version de PHP incorrects

Messagepar galixte » 23 Nov 2016 à 22:50

Le script ne parvient sans doute pas à détecter ta version, essaye en renvoyant tous les fichiers sur ton espace FTP.

Aussi, n'y aurait-il pas un problème d'emplacement de ton forum vis à vis de WordPress ? Comme par exemple le répertoire de ton forum qui se trouverait dans celui de WordPress. WordPress a un antivirus qui dans certains cas pose problème à phpBB.
Modifié en dernier par galixte le 25 Nov 2016 à 02:55, modifié 2 fois.
Communau EzCom
Image
« Traductions d’extensions & styles pour phpBB 3.1.x & 3.2.x ».
ImageListes de toutes les extensions recensées pour phpBB 3.1.x & 3.2.x.
ImageListes de tous les styles recensés pour phpBB 3.1.x & 3.2.x.
Avatar de l’utilisateur
galixte
Floodeur universel
Floodeur universel
 
Messages: 9537
Enregistré le: 08 Mar 2004 à 02:40
Localisation: Sud de la France.

Re: Bases de données supportées et Version de PHP incorrects

Messagepar Psychomasse » 24 Nov 2016 à 23:58

J'avais essayé de remettre les fichiers, sans succès.
Bon... un ami a réussi à résoudre le soucis, mais cet enfoiré ne veut pas me dire comment, désolée ! :mrgreen:
Je repasserai donner la solution s'il se décide.
Avatar de l’utilisateur
Psychomasse
Posteur néophyte
Posteur néophyte
 
Messages: 16
Enregistré le: 04 Sep 2016 à 23:28
Localisation: derrière toi !


Retourner vers Installation

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité