[PHP7] problème de compatibilité en local.

Forum concernant les demandes de support pour tout problème d'installation d'un forum phpBB 3.1.x uniquement

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.
Partager sur FacebookPartager sur TwitterPartager sur Google+

[PHP7] problème de compatibilité en local.

Messagepar Do_done » 10 Fév 2016 à 16:27

Bonjour tout le monde,

Je vous explique mon problème.

J'aimerai modifier un thème de phpbb, mais en local sur linux.
J'installe la version 3.1 de phpbb, mais rien ni fait, j'ai toujours un problème.
L'étape finale de l'installation me donne une page vide avec "erreur 500".
Qui est normalement un problème de permission, je met toutes les permissions des fichiers et dossiers comme il faut, mais cette erreur persiste.

Les tables de phpmyadmin sont belles et bien créées, aucun messages d'erreur à ce niveau là.
Le forum est bien créer, quand je retourne sur l'index après avoir renommer le dossier «install», je peux me connecter et même écrire un post.

Cependant impossible de me connecter au ACP, il me met un message aussi un message d'erreur.

Un ami qui est également sur linux a réussi sans problème à l'installer en local.
Lui est avec php5.6.11 alors que moi sous php7.0.3.

Je me demande si phpbb3.1.x est tout simplement compatible avec php7 ?

Merci à vous.
Do_done
Posteur néophyte
Posteur néophyte
 
Messages: 1
Enregistré le: 10 Fév 2016 à 16:03

Re: [PHP7] problème de compatibilité en local.

Messagepar Touda » 10 Fév 2016 à 16:39

Hello,

Je peux seulement apporter une réponse avec ton problème de compatibilité.

https://www.phpbb.com/support/documents.php?mode=readme
Point 7.

phpBB 3.1.x takes advantage of new features added in PHP 5.3. We recommend that you upgrade to the latest stable release of PHP5 to run phpBB. The minimum version required is PHP 5.3.3 and the maximum supported version is any version prior to PHP 7.0.


Je comprend qu'il est compatible qu'avec les versions inférieur a 7.0 et égal/supérieur à 5.3.3.

Je me trompe peut être dans la traduction.
Avatar de l’utilisateur
Touda
Maître-posteur
Maître-posteur
 
Messages: 450
Enregistré le: 23 Sep 2011 à 14:43
Localisation: Clermont-Ferrand

Re: [PHP7] problème de compatibilité en local.

Messagepar Skouat » 10 Fév 2016 à 16:48

Bonjour,

En version plus explicite : PHP >= 5.3.3, PHP < 7.0-dev
Sources : https://www.phpbb.com/support/docs/en/3 ... uirements/

Do_done a écrit:Cependant impossible de me connecter au ACP, il me met un message aussi un message d'erreur.

idéalement, le mieux reste de communiquer les messages d'erreur car cela pourrait n'avoir aucun rapport avec une incompatibilité PHP 7.
Mes MODS

Ultima-World Hébergé par phpBB-Services
Code parrainage : 1241646554
Skouat
Traducteur
Traducteur
 
Messages: 13493
Enregistré le: 02 Avr 2008 à 19:47


Retourner vers Installation

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité