[Réglé] Fatal error lors de la rédaction ou la lecture d'un post

Forum concernant les demandes de support pour tout problème d'installation d'un forum phpBB 3.1.x uniquement

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.

[Réglé] Fatal error lors de la rédaction ou la lecture d'un post

Messagepar Psykoblack » 03 Fév 2016 à 22:39

Bonjour à vous l'équipe de PHPbb.
J'aurais un problème à vous soumettre je vous prie.

Je me suis procuré un forum PHPBB 3.1.7 récemment, que j'héberge moi-même sur une machine qui m'appartient, montée en réseau local.
L'installation s'est bien passé, la configuration n'a pas posé problème.
Le style "Prosilver" par défaut fonctionne bien, et la totalité des fonctions du forum aussi.

Le problème survient lors de l'utilisation d'un autre style version 3.1.7.
La plupart du style s'applique globalement aux pages, mais il survient une erreur lors de la rédaction ou la lecture d'un post.
Voici l'erreur :
http://hpics.li/82fbf65

Sous "Prosilver", je ne l'ai pas, c'est uniquement lors de la lecture de page sous un autre style. J'en ai éssayé plusieurs, et tous les autres révèlent cette erreur. Il n'y a que le style par défaut qui ne le fait pas.
J'ai tenté plusieurs compte aussi, membre comme admin, l'erreur survient.
Ce qui est bizarre, c'est que lors de la rédaction et de la validation du post, il se poste justement. Quand on revient sur le forum en lui même, le message a bien été posté, mais l'erreur s'est révélé lors de l'envoie du post au lieu de l'afficher.
Cependant, la lecture est impossible, puisque l'erreur s'affiche au moment de l'ouverture du post.
Je vous confirme utiliser une version 3.1.7 des styles.
Je vous confirme réaliser l'installation des styles de façon correcte. (enfin je suppose)

Avez-une idée de ce qui peut occasionner cela je vous prie, et surtout, comment régler le problème ?

Je vous remercie de votre attention et vous souhaite bonne journée.

Cordialement,

P.
Psykoblack
Posteur néophyte
Posteur néophyte
 
Messages: 7
Enregistré le: 22 Nov 2015 à 10:40

Re: Fatal error lors de la rédaction ou la lecture d'un post

Messagepar Manard » 04 Fév 2016 à 10:13

Bonjour,

Juste des pistes et questions, as-tu des extensions d'installées ? si oui , essaie de les adésactiver. As-tu fait une raz du cache en ne conservant que les fichers .htaccess et index.html ?

Quel style utilises-tu ? Ton forum est-il accessible d'internet, si oui, donne l'adresse ça peut aider à la résolution du problème.

Bonne journée

Bernard
Manard
Roi des posts
Roi des posts
 
Messages: 931
Enregistré le: 31 Mar 2012 à 09:24

Re: Fatal error lors de la rédaction ou la lecture d'un post

Messagepar Psykoblack » 04 Fév 2016 à 11:08

Bonjour Manard,

tout d'abord, merci beaucoup de ta réponse.

Voici donc des éléments additionnels:
- A propos des extensions, non, je n'en ai installé aucune, à aucun moment.
- A propos du RAZ, ça non plus j'en ai jamais fait. Je ne sais pas où ca se trouve, mais je chercherai et je tenterai le coup pour constater le résultat.
- Les styles utilisés ont été "blue-night" et "gray-3D" de mémoire.
- Je regrette mais je ne peux procurer l'URL de ce forum sans autorisation. Il est très personnel et très privé. Seuls certains invités clairement connus IRL peuvent y avoir accès.

Quoi qu'il en soit, je vais donc tenter la RAZ et d'autres styles.

edit:
Je viens d’essayer avec d'autres styles tels que "we_universal", "ne-blackgreen", "SE Square Left".
Tout fonctionne.
En fait j'ai l'impression que tout fonctionne si j'utilise des styles présents sur https://www.phpbb.com/go/customise/styles/3.1
Mais s'il s'agit de style d'origine extérieur, j'ai le problème.
Psykoblack
Posteur néophyte
Posteur néophyte
 
Messages: 7
Enregistré le: 22 Nov 2015 à 10:40

Re: Fatal error lors de la rédaction ou la lecture d'un post

Messagepar Manard » 04 Fév 2016 à 13:01

Bonjour,


Où télécharges-tu les styles "blue-night" et "gray-3D" ?

Bonne journée

Bernard
Manard
Roi des posts
Roi des posts
 
Messages: 931
Enregistré le: 31 Mar 2012 à 09:24

Re: Fatal error lors de la rédaction ou la lecture d'un post

Messagepar Psykoblack » 04 Fév 2016 à 13:35

En fait les styles qui fonctionnent mal sont des styles proposés par des utilisateurs, mais qui ne font pas partie de la base de données de phpBB:

styles-base-de-donnees-phpbb31/sujet205689.html
styles-base-de-donnees-phpbb31/sujet206491.html
Psykoblack
Posteur néophyte
Posteur néophyte
 
Messages: 7
Enregistré le: 22 Nov 2015 à 10:40

Re: Fatal error lors de la rédaction ou la lecture d'un post

Messagepar Manard » 04 Fév 2016 à 14:16

Bonjour,


C'est bizarre car ces deux styles ont été validés ici même, si Sub60 l'auteur des styles passe il saura peut-être t'aider.

Bonne journée

Bernard
Manard
Roi des posts
Roi des posts
 
Messages: 931
Enregistré le: 31 Mar 2012 à 09:24

Re: Fatal error lors de la rédaction ou la lecture d'un post

Messagepar sub60 » 04 Fév 2016 à 17:29

Hello,

Effectivement, le soucis provient de mes mise à jour, une mauvaise sélection surement,
désoler pour la gène occasionner :oops:

Dans viewtopic_body.html

Trouver (ligne 87 environ)
Code: Tout sélectionner
{poll_option.POLL_OPTION_CAPTION}</label><!-- ELSE -->{poll_option.POLL_OPTION_CAPTION}<!-- ENDIF --></dt>


Remplacer par
Code: Tout sélectionner
<dt><!-- IF S_CAN_VOTE --><label for="vote_{poll_option.POLL_OPTION_ID}">{poll_option.POLL_OPTION_CAPTION}</label><!-- ELSE -->{poll_option.POLL_OPTION_CAPTION}<!-- ENDIF --></dt>


Donc je revois tous mes styles impacter, et je les renvois à validation :?

@Psykoblack, merci d'avoir soulever le problème, et encore désoler pour le désagrément.
<< Comment poster au bon endroit sur phpbb-fr >>
Attention..!! les styles pour phpBB 3.0, ne sont pas compatible avec phpBB 3.1
Sur phpBB 3.1, pour rafraîchir le style il suffit de vider le cache du forum.
Si vous considérez votre requête comme résolue, merci d'ajouter l'attribut de sujet [Réglé]
Avatar de l’utilisateur
sub60
Floodeur universel
Floodeur universel
 
Messages: 9518
Enregistré le: 19 Juin 2006 à 15:14
Localisation: oise

Fatal error lors de la rédaction ou la lecture d'un post

Messagepar Psykoblack » 05 Fév 2016 à 19:31

Cher Sub 60,

Je viens de tenter de faire la correction comme tu m'as proposé.
Ca fonctionne !
Bien joué !

Merci plutôt à toi d'avoir fait le nécessaire auprès des utilisateurs de tes syles, tout à fait jolis d'ailleurs !
Bonne continuation et à bientôt.

Sujet soldé.

P.
Psykoblack
Posteur néophyte
Posteur néophyte
 
Messages: 7
Enregistré le: 22 Nov 2015 à 10:40


Retourner vers Installation

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 2 invités