[Réglé] [User Blog Mod 1.0.15] Problème d'installation

Ici sera assuré le support pour n'importe quel MOD non présent dans la base de données de phpBB-fr.

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com - Conditions générales de support des MODs de phpBB-fr.com

Merci de mettre le titre du MOD ainsi que sa version entre crochets, et un titre explicite afin de faciliter la recherche.
Exemple : [nom du mod + numéro de version] Titre explicite résumant le problème

Le lien de téléchargement du MOD est demandé pour toute demande de support.

Aucune demande de personnalisation des MODs n'est autorisée.

Re: [User Blog Mod 1.0.15] : Problème d'installation

Messagepar jackoli » 20 Juil 2012 à 12:53

Je suppose qu'en écrasant les fichiers PHPBB3 par ceux que je viens de telecharger puis refaire les modifs, c'est ok ? Car a part ces mods cités précédemment, je ne vois pas quels autres modifs ont été faites. Surtout coté style.
Avatar de l’utilisateur
jackoli
Apprenti-posteur
Apprenti-posteur
 
Messages: 118
Enregistré le: 30 Avr 2008 à 15:05

Re: [User Blog Mod 1.0.15] : Problème d'installation

Messagepar ABDev » 20 Juil 2012 à 13:23

Je ne pense pas que ça vienne des Styles, mais plutôt de la gestion de ces derniers.
Pour ce qui est de l'écrasement, en théorie ça devrait fonctionner. Mais ce n'est pas une option que je privilégie.

Voici comment je procéderais pour ma part :
- Sauvegarde des fichiers et de la base de données
- Suppression complète de tous les fichiers du FTP sauf le fichier config.php
- Transfert des fichiers de la version de base de phpBB3
- Nettoyage de la base de données avec Support Toolkit
- Installation des Styles (moins il y en a, mieux c'est)
- Installation des MODs (même remarque)
- Tests
- Apport des modifications personnelles

Pour ce dernier point, tu peux faire un Diff avec WinMerge ou Meld entre les fichiers de base de phpBB3 et ceux que tu auras préalablement sauvegardé.
Mais là, il faudra penser à vérifier souvent le bon fonctionnement du forum.
Pour se payer le luxe d'être feignant, il faut sans cesse faire travailler ses méninges ! (Korben)

On clique sur le bouton Répondre plutôt que le bouton Citer ...
Un problème avec une extension ? Pas de lien vers celle-ci ? Sujet ignoré !
Avatar de l’utilisateur
ABDev
Programmationateur
Programmationateur
 
Messages: 15782
Enregistré le: 12 Mai 2005 à 23:54

Re: [User Blog Mod 1.0.15] Problème d'installation

Messagepar jackoli » 20 Juil 2012 à 19:27

Voilà, c'est résolu.
Et en même temps ,trouvé où se situait/situe le souci !
C'est dans le fichier includes/function, une ligne rajoutée pour faire figurer les évènements de l'agenda qui empêchait le style UMIL de s'afficher. Une fois commenté, et un délai de 2 minutes du serveur dont je ne comprends toujours pas, le style UMIL s'est affiché.
Pas eu besoin d'écraser ou de tout supprimer. Juste revu les modifs une par une dans les fichiers (Gallerie, Calendrier et viré le mod fb)

Merci pour le temps dédié à mon "souci" :D
Avatar de l’utilisateur
jackoli
Apprenti-posteur
Apprenti-posteur
 
Messages: 118
Enregistré le: 30 Avr 2008 à 15:05

Re: [User Blog Mod 1.0.15] Problème d'installation

Messagepar ABDev » 20 Juil 2012 à 19:33

C'était quelle ligne à tout hasard ? Parce que j'avais aussi touché à ce fichier, et ça n'améliorait rien.
Pour se payer le luxe d'être feignant, il faut sans cesse faire travailler ses méninges ! (Korben)

On clique sur le bouton Répondre plutôt que le bouton Citer ...
Un problème avec une extension ? Pas de lien vers celle-ci ? Sujet ignoré !
Avatar de l’utilisateur
ABDev
Programmationateur
Programmationateur
 
Messages: 15782
Enregistré le: 12 Mai 2005 à 23:54

Re: [User Blog Mod 1.0.15] Problème d'installation

Messagepar jackoli » 20 Juil 2012 à 22:51

en tout début,
Code: Tout sélectionner
include($phpbb_root_path . 'includes/functions_calendar.' . $phpEx)
qui appelle les fonctions calendar (affichages, enregistrements) sur tout le site et forum*
et avant
Code: Tout sélectionner
// The following assigns all _common_ variables that may be used at any point in a template.
j'ai placé
Code: Tout sélectionner
// Generate calendar week view or next events if required ...
	calendar_display_calendar_on_index();
qui appelle l'affichage des évènements calendrier sur le site et forum dans le menu. si je commente ces deux lignes, après 2-3 minutes, cela refonctionne. Dans l'immédiat, cela ne fonctionne pas, même apres vidage du cache... :?
C'est la seule façon que j'ai trouvé pour faire fonctionner l'agenda du site. J'utilise phpBB3 depuis 2008 sur plusieurs forums.
*Pourquoi je fais un include ? car j'ai sous la main le fichier complet et ne souhaite pas modifier en profondeur les fichiers phpbb3. Maintenant, il y a peut-être une autre solution plus correcte.
Avatar de l’utilisateur
jackoli
Apprenti-posteur
Apprenti-posteur
 
Messages: 118
Enregistré le: 30 Avr 2008 à 15:05

Re: [User Blog Mod 1.0.15] Problème d'installation

Messagepar ABDev » 20 Juil 2012 à 23:06

Mmmhhh ne désactive pas l'accès FTP trop vite, j'y regarde à nouveau demain pour ça.
Pour se payer le luxe d'être feignant, il faut sans cesse faire travailler ses méninges ! (Korben)

On clique sur le bouton Répondre plutôt que le bouton Citer ...
Un problème avec une extension ? Pas de lien vers celle-ci ? Sujet ignoré !
Avatar de l’utilisateur
ABDev
Programmationateur
Programmationateur
 
Messages: 15782
Enregistré le: 12 Mai 2005 à 23:54

Re: [User Blog Mod 1.0.15] Problème d'installation

Messagepar jackoli » 22 Juil 2012 à 17:29

Oups, voilà c'est remis !
Ligne 29 pour l'include des fonctions calendar , ligne 4566 pour la déclaration de la fonction calendar_display_calendar_on_index() reprise dans l'include.
Pour info, j'ai laissé le stk sur serveur.
Juste une question, serait-ce à cause que ce template est hérité de prosilver que cela plante ? Car afterburner possède quelques templates modifiés, mais les templates non modifiés sont directement issus de prosilver. J'ai vu ça en modifiant un template prosilver qui n'était pas sur afterburner et la modif a eu lieu sur le site. J'ai un doute aussi coté MODx si celui ci modifie les prosilver au lieu de l'afterburner. Je vais d'ailleurs ouvrir un topic là dessus.
Avatar de l’utilisateur
jackoli
Apprenti-posteur
Apprenti-posteur
 
Messages: 118
Enregistré le: 30 Avr 2008 à 15:05

Précédente

Retourner vers MODs indépendants de la base

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité