[Réglé] Ajouter des icônes de sous-forums

Pour les recherches et les demandes de modifications de styles concernant votre forum phpBB3.

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com - Conditions générales de support graphique

Attention : pour éviter les bugs, votre style doit être mis à jour en même temps que votre forum, et ce, dans la dernière version disponible de phpBB !

[Réglé] Ajouter des icônes de sous-forums

Messagepar tachotchek » 30 Juil 2009 à 10:59

Bonjour,

Mon message va avoir un peu l'air d'un doublon mais on m'a demandé de le poster dans un nouveau sujet.

J'ai installé le thème AeroBlue (j'ai exposé mon problème à l'auteur, qui ne semble pas savoir) pour mon forum (pas encore visible pour les membres) qui utilise prosilver jusque là. Ce qui est bien pratique avec prosilver, c'est qu'on peut avoir des icônes de sous-forums, ce qui permet, lorsqu'il y a des nouveaux messages, d'aller directement dans les sous-forums concernés depuis l'index sans avoir à passer par le forum parent pour voir où se trouvent les nouveaux messages.
J'ai donc fait toutes les modifications telles qu'elles sont décrites ici : modifications-et-recherche-de-styles/sujet162455-15.html#p1242418 en prenant bien soin de remplacer .png par .gif partout où c'était nécessaire puisque mes icônes sont en .gif. Le problème est que les icônes ne s'affichent pas, bien qu'après modifications il y ait davantage d'espace entre le nom des sous-forums, espace a priori destiné à accueillir les icônes. J'ai pourtant rafraichi tout ce qui pouvait être rafraichi (template, thème, pack d'images, le cache entier) et j'ai bien vérifié à maintes reprise que je n'avais pas commis d'erreurs. Du coup j'ai voulu tester ces manipulations sur le thème subsilver2 et là, surprise, ça fonctionne ! Donc ce n'est pas moi qui yoyotte et ne sais pas faire, c'est bien que c'est le thème AeroBlue (pourtant dérivé de subsilver2) qui ne veut pas m'afficher les icônes (que j'ai bien placées dans le dossier adéquat, évidemment). Je précise que mon forum est à jour.

Quelqu'un peut-il m'aider ?
Je vous remercie beaucoup :)
Modifié en dernier par tachotchek le 30 Juil 2009 à 21:03, modifié 1 fois.
tachotchek
Apprenti-posteur
Apprenti-posteur
 
Messages: 129
Enregistré le: 11 Avr 2004 à 13:21

Re: Ajouter des icônes de sous-forums

Messagepar micka76 » 30 Juil 2009 à 16:39

Bonjour,

La partie de la stylesheet.css n'est pas tout a fait la même
mettez ceci a la place
Code: Tout sélectionner
a.subforum.read {
   background-image: url("{T_IMAGESET_PATH}/subforum_read.gif");
   background-repeat: no-repeat;
   background-position: 0 50%;
   position: relative;
   white-space: nowrap;
   padding: 0 0 0 12px;
}

a.subforum.unread {
   background-image: url("{T_IMAGESET_PATH}/subforum_unread.gif");
   background-repeat: no-repeat;
   background-position: 0 50%;
   position: relative;
   white-space: nowrap;
   padding: 0 0 0 12px;
}


A bientôt... :wink:
Voici un bon site sur l'aquariophilie ==> http://www.aquadebutant.com
Si à la Saint Valentin tu me tiens la main, vivement la Sainte Marguerite que tu me tienne la ....!!! :mrgreen:
Avatar de l’utilisateur
micka76
Graphiste
Graphiste
 
Messages: 8730
Enregistré le: 04 Oct 2007 à 12:14
Localisation: Bah entre toi et ta f.... !!!

Re: Ajouter des icônes de sous-forums

Messagepar tachotchek » 30 Juil 2009 à 21:03

Ohhhhh vous pouvez pas savoir comme je suis content que vous soyez passé par là aujourd'hui, je commençais à me dire que j'étais un peu neuneu ! Ça marche nickel, merci beaucoup !!! :D :P
Bonne soirée ! :D
tachotchek
Apprenti-posteur
Apprenti-posteur
 
Messages: 129
Enregistré le: 11 Avr 2004 à 13:21


Retourner vers Modifications et recherche de styles

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 3 invités