[Réglé] Affichage double du fil d'ariane

Pour les recherches et les demandes de modifications de styles concernant votre forum phpBB 3.2

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com - Conditions générales de support graphique

Attention : pour éviter les bogues, votre style doit être mis à jour en même temps que votre forum, et ce, dans la dernière version disponible de phpBB !

[Réglé] Affichage double du fil d'ariane

Messagepar babaaar0 » 03 Sep 2019 à 14:21

Bonjour, je rencontre un problème sur mon forum, en effet les catégories et forums s'affichent 2 fois dans le fil d'Ariane

Image

Si quelqu'un a une piste, merci d'avance :)
Modifié en dernier par babaaar0 le 03 Sep 2019 à 18:51, modifié 1 fois.
babaaar0
Posteur néophyte
Posteur néophyte
 
Messages: 6
Enregistré le: 03 Sep 2019 à 14:12

Re: Affichage double du fil d'ariane

Messagepar Steph » 03 Sep 2019 à 14:43

Salut,

Pour obtenir un support plus efficace, merci de préciser l'URL de votre forum, et de nous mettre à disposition un compte "test" sur votre forum.

Aussi il faut préciser la version de phpBB et donner le lien vers le style.

As tu le même constat avec le style prosilver ?
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 19103
Enregistré le: 29 Déc 2008 à 16:48
Localisation: Alsace / Bas-Rhin / France

Re: Affichage double du fil d'ariane

Messagepar babaaar0 » 03 Sep 2019 à 15:01

Hello, merci pour la réponse rapide.
L'URL du site: http://www.compagnonsducrepuscule.com
J'ai créé un profil "Test" MDP Test123
Phpbb en version 3.2.7, le style "PBwow" en version 3.2.7 également http://www.ezcom-fr.com/download/file.p ... 3b962456e3
Je viens de faire le test sous prosilver, l'affichage est normal.
babaaar0
Posteur néophyte
Posteur néophyte
 
Messages: 6
Enregistré le: 03 Sep 2019 à 14:12

Re: Affichage double du fil d'ariane

Messagepar Steph » 03 Sep 2019 à 15:08

Ok, y a t’il eu des modifications personnelles au niveau du style ?
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 19103
Enregistré le: 29 Déc 2008 à 16:48
Localisation: Alsace / Bas-Rhin / France

Re: Affichage double du fil d'ariane

Messagepar babaaar0 » 03 Sep 2019 à 15:08

Je viens de le réup en entier, le problème persiste.
J'ai juste ajouté le tooltip wowhead dans overall_header:
Code: Tout sélectionner
<script>var whTooltips = {colorLinks: true, iconizeLinks: true, renameLinks: true};</script>
<script src="https://wow.zamimg.com/widgets/power.js"></script>
, mais ça déconnait déjà avant que je le mette.
babaaar0
Posteur néophyte
Posteur néophyte
 
Messages: 6
Enregistré le: 03 Sep 2019 à 14:12

Re: Affichage double du fil d'ariane

Messagepar Sylveretour » 03 Sep 2019 à 18:06

Bonjour,

Ok, y a t’il eu des modifications personnelles au niveau du style ?

J'ai juste ajouté le tooltip wowhead dans overall_header:

Je peut déjà dire en 2 secondes sue des choses pas nettes on, été faite, la preuve:
Code: Tout sélectionner
<link href="./assets/css/font-awesome.min.css?assets_version=8" rel="stylesheet">
<link href="./styles/prosilver/theme/stylesheet.css?assets_version=1" rel="stylesheet">
<link href="./styles/prosilver/theme/en/stylesheet.css?assets_version=1" rel="stylesheet">
<link href="./styles/pbwow3/theme/stylesheet.css?assets_version=8" rel="stylesheet">
<link href="./styles/pbwow3/theme/fr/stylesheet.css?assets_version=8" rel="stylesheet">

?assets_version=1 pour prosilver et font-awesome alors que le reste contient ?assets_version=8

En tout début de source de page doit être présent:
Code: Tout sélectionner
<meta charset="utf-8" />
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1" />

Qui ne se trouve pas chez toi.

Tout en bas de page, on peut voir:
Code: Tout sélectionner
 PRIVACY_LINK | TERMS_LINK 

Preuve d'une mise à jour complètement loupée au niveau des fichiers de langue.
On peut donc en conclure que d'autres fichiers sont impactés.

dernier essais avec prosilver:
http://www.compagnonsducrepuscule.com/v ... tyle=1&f=4
et le bug dont il est sujet ne se produit pas.
C'est donc bien le style qui est en cause
Avatar de l’utilisateur
Sylveretour
Roi des posts
Roi des posts
 
Messages: 961
Enregistré le: 21 Nov 2017 à 19:24
Localisation: West Coast

Re: Affichage double du fil d'ariane

Messagepar babaaar0 » 03 Sep 2019 à 18:12

Ok, je vais essayer de trouver un autre style alors, ça doit être la solution la plus simple. Merci de ton aide en tout cas!
babaaar0
Posteur néophyte
Posteur néophyte
 
Messages: 6
Enregistré le: 03 Sep 2019 à 14:12

Re: Affichage double du fil d'ariane

Messagepar cocooncrash » 03 Sep 2019 à 18:20

ce n'est pas que le style, c'est aussi la mise a jour qui est loupée!!
decouvrez l'aide complete : ICI
découvrez les règles : La_bas

Pensez a ajouter le tag [réglé] en modifiant votre premier message s'il est résolu. Merci :wink:
Avatar de l’utilisateur
cocooncrash
Resp. des modérateurs
Resp. des modérateurs
 
Messages: 7958
Enregistré le: 07 Jan 2008 à 09:29
Localisation: dans un bocal en compagnie de nemo!!

Re: Affichage double du fil d'ariane

Messagepar Sylveretour » 03 Sep 2019 à 18:27

En effet pour la mise à jour loupée rappelée, puis, en regardant le code du style en cause, on peut voir:
Code: Tout sélectionner
<link href="{{ T_FONT_AWESOME_LINK }}" rel="stylesheet">
<link href="{{ ROOT_PATH }}styles/prosilver/theme/stylesheet.css?assets_version=1" rel="stylesheet">
<link href="{{ ROOT_PATH }}styles/prosilver/theme/en/stylesheet.css?assets_version=1" rel="stylesheet">

Puis dans navbar.html le code est dédoublé, ce qui provoque le bug rencontré.
Code: Tout sélectionner
<span class="crumb" {{ definition.MICRODATA }}{% if navlinks.MICRODATA %} {{ navlinks.MICRODATA }}{% endif %}><a href="{{ navlinks.U_VIEW_FORUM }}" itemtype="https://schema.org/Thing" itemprop="item"><span itemprop="name">{{ navlinks.FORUM_NAME }}</span></a><meta itemprop="position" content="{{ navlink_position }}{% set navlink_position = navlink_position + 1 %}" /></span>
			<span class="crumb" {$MICRODATA}<!-- IF navlinks.MICRODATA --> {navlinks.MICRODATA}<!-- ENDIF -->><a href="{navlinks.U_VIEW_FORUM}" itemprop="url"><span itemprop="title">{navlinks.FORUM_NAME}</span></a></span>

Ce style n'est donc pas du tout conforme et doit contenir d'autres bugs!

Les distributeurs de ces style doivent les retirer dès à présent de la distribution au public...
Avatar de l’utilisateur
Sylveretour
Roi des posts
Roi des posts
 
Messages: 961
Enregistré le: 21 Nov 2017 à 19:24
Localisation: West Coast

Re: Affichage double du fil d'ariane

Messagepar babaaar0 » 03 Sep 2019 à 18:42

cocooncrash a écrit:ce n'est pas que le style, c'est aussi la mise a jour qui est loupée!!

ok, il est possible d'y remédier?
babaaar0
Posteur néophyte
Posteur néophyte
 
Messages: 6
Enregistré le: 03 Sep 2019 à 14:12

Re: Affichage double du fil d'ariane

Messagepar cocooncrash » 03 Sep 2019 à 18:42

autre sujet donc autre forum avec une question sur la mise a jour.
decouvrez l'aide complete : ICI
découvrez les règles : La_bas

Pensez a ajouter le tag [réglé] en modifiant votre premier message s'il est résolu. Merci :wink:
Avatar de l’utilisateur
cocooncrash
Resp. des modérateurs
Resp. des modérateurs
 
Messages: 7958
Enregistré le: 07 Jan 2008 à 09:29
Localisation: dans un bocal en compagnie de nemo!!

Re: Affichage double du fil d'ariane

Messagepar babaaar0 » 03 Sep 2019 à 18:51

cocooncrash a écrit:autre sujet donc autre forum avec une question sur la mise a jour.

Ok, je verrai ça.

J'ai pu virer le doublon en supprimant le code en trop, ça marche je passe en réglé. Merci à tous pour votre aide!
babaaar0
Posteur néophyte
Posteur néophyte
 
Messages: 6
Enregistré le: 03 Sep 2019 à 14:12


Retourner vers [3.2.x] Modifications et recherche de styles

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité