[Réglé] we_universal_perso, image de fond disparue suite à mise à niveau 3.2

Pour les recherches et les demandes de modifications de styles concernant votre forum phpBB 3.2

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com - Conditions générales de support graphique

Attention : pour éviter les bogues, votre style doit être mis à jour en même temps que votre forum, et ce, dans la dernière version disponible de phpBB !

[Réglé] we_universal_perso, image de fond disparue suite à mise à niveau 3.2

Messagepar agame » 28 Mar 2017 à 11:07

Bonjour,
Voilà je suis sous we_universal_perso créé gentiment par cabot, qui lui es enfant de we-universal qui est enfant de prosilver.
Depuis la migration, je n'ai plus mon image de fond qui est ici:

Image

cf ce sujet

j'ai beau changer dans le common.css rien ne se passe...
html,
body {
background-image: url("./images/fond2.jpg");
margin: 0;
padding: 0;
font-family: Tahoma, Arial, Helvetica, sans-serif;
font-size: 12px;

}


quoi que je change d'ailleurs rien ne se passe.... peut être est-ce dans la structure de mes themes personnalisés ?

Code: Tout sélectionner
prosilver 	0 	Détails | Activer le style | Désinstaller | Aperçu 	
we_universal 	0 	Détails | Activer le style | Désinstaller | Aperçu 	
we_universal perso 	9 	Détails | Désactiver le style | Désinstaller | Aperçu


j'ai aussi cherché de ce côté là rien ne se passe...

Merci pour votre aide...
Modifié en dernier par agame le 28 Mar 2017 à 15:43, modifié 1 fois.
agame
Roi des posts
Roi des posts
 
Messages: 665
Enregistré le: 17 Avr 2006 à 21:08

Re: we_universal_perso, image de fond disparue suite à mise à niveau 3.2

Messagepar Steph » 28 Mar 2017 à 13:13

Salut,

Ce n'est pas du support pour la mise à jour, mais pour la modification du style.

Votre sujet a été déplacé par un membre de l'équipe.

Tu vides bien le cache après avoir envoyé les fichiers modifiés sur le serveur ?

Et pour le support, merci d'utiliser le forum en lieu et place de la messagerie privée.
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 18525
Enregistré le: 29 Déc 2008 à 15:48
Localisation: Alsace / Bas-Rhin / France

Re: we_universal_perso, image de fond disparue suite à mise à niveau 3.2

Messagepar Mazeltof » 28 Mar 2017 à 14:26

'jour ici,

Si le forum en question est celui lié dans ta signature, tu déclares sur html, body une couleur en background dans responsive.css.
Ton fichier responsive étant chargé après ton fichier stylesheet.css, ton image est écrasée par la couleur.

Dans styles/we_universal_perso/theme/reponsive.css trouve (vers la ligne 5) :
Code: Tout sélectionner
html, body {
    background: #F6F6F6;
}

remplace par :
Code: Tout sélectionner
html, body {
    background: url("./images/fond2.jpg");
}

:wink:
Image Image Image
Avatar de l’utilisateur
Mazeltof
Resp. des graphistes
Resp. des graphistes
 
Messages: 2974
Enregistré le: 09 Mar 2009 à 22:02
Localisation: Arras

Re: we_universal_perso, image de fond disparue suite à mise à niveau 3.2

Messagepar agame » 28 Mar 2017 à 15:42

@ steph bien sûr que je vide le cache... je me répete encore ici c'est suite à la mise à niveau et la mise à jour, je n'ai jamais touché au responsive.css ....
alors maintenant ça marche mais je ne comprends pas pourquoi avant la mise à niveau et avant la mise à jour we-universal ça marchait bien. Un style enfant perso n'est pas affecté par ces modifs il me semble ?
en tous cas merci.
agame
Roi des posts
Roi des posts
 
Messages: 665
Enregistré le: 17 Avr 2006 à 21:08

Re: we_universal_perso, image de fond disparue suite à mise à niveau 3.2

Messagepar Mazeltof » 28 Mar 2017 à 17:18

agame a écrit:je n'ai jamais touché au responsive.css

Peut être l'auteur de la mise à niveau du style a ajouté cette règle et vu que tu appelles le responsive.css via le stylesheet.css de we_universal pour ton style perso ...

Mais bon l'important est que ça fonctionne :wink:
Image Image Image
Avatar de l’utilisateur
Mazeltof
Resp. des graphistes
Resp. des graphistes
 
Messages: 2974
Enregistré le: 09 Mar 2009 à 22:02
Localisation: Arras

Re: we_universal_perso, image de fond disparue suite à mise à niveau 3.2

Messagepar agame » 28 Mar 2017 à 17:35

juste ! mais j'aime comprendre ces trucs qui prennent du temps ! en tous cas merci du tien ;-)

Il y a moyen de bloquer mon style perso ? ce n'est que du relooking, pas de template ! que ce genre de surprise n'arrive plus ?
agame
Roi des posts
Roi des posts
 
Messages: 665
Enregistré le: 17 Avr 2006 à 21:08

Re: we_universal_perso, image de fond disparue suite à mise à niveau 3.2

Messagepar Mazeltof » 28 Mar 2017 à 20:32

C'est juste de l'adaptation légère suite à une mise à niveau et un style enfant dépendra toujours du(es) style(s) dont il hérite. :wink:
Image Image Image
Avatar de l’utilisateur
Mazeltof
Resp. des graphistes
Resp. des graphistes
 
Messages: 2974
Enregistré le: 09 Mar 2009 à 22:02
Localisation: Arras

Re: we_universal_perso, image de fond disparue suite à mise à niveau 3.2

Messagepar cabot » 30 Mar 2017 à 07:13

Hello,

En 3.2, la feuille de style responsive.css n'est pas chargée de la même façon qu'en 3.1, il faut déclarer les règles CSS dans des medias queries.

Trouve :
Code: Tout sélectionner
html,
html, body {
    background: url("./images/fond2.jpg");
}
.post.reported .postbody:before {
	border-color: transparent transparent #007100 transparent;
}

.inventea-footer, .inventea-footer a {
     color: #F6F6F6;
}

Remplace par :
Code: Tout sélectionner
@media (max-width: 700px) {
	
	html, body {
		background: url("./images/fond2.jpg");
	}
	.post.reported .postbody:before {
		border-color: transparent transparent #007100 transparent;
	}
	.inventea-footer, .inventea-footer a {
		 color: #F6F6F6;
	}
	
}	
Image
Avatar de l’utilisateur
cabot
Equipe site
Equipe site
 
Messages: 26813
Enregistré le: 13 Fév 2011 à 19:42
Localisation: Rarement sur la plaque

Re: we_universal_perso, image de fond disparue suite à mise à niveau 3.2

Messagepar agame » 30 Mar 2017 à 08:15

ben ça marche pas j'ai de nouveau une page blanche, donc je remets en attendant ce qui marchait:

Code: Tout sélectionner
html, body {
    background: url("./images/fond2.jpg");
}
agame
Roi des posts
Roi des posts
 
Messages: 665
Enregistré le: 17 Avr 2006 à 21:08

Re: we_universal_perso, image de fond disparue suite à mise à niveau 3.2

Messagepar Mazeltof » 30 Mar 2017 à 08:58

Oups, j'avais pas percuté pour les petits écrans :?

avec la modif proposée par cabot Il faut aussi "corriger" le responsive.css de we_universal, sinon tu n'auras pas d'image de fond :wink:
(sans doute un oubli de l'auteur lié à la maj)
Image Image Image
Avatar de l’utilisateur
Mazeltof
Resp. des graphistes
Resp. des graphistes
 
Messages: 2974
Enregistré le: 09 Mar 2009 à 22:02
Localisation: Arras

Re: we_universal_perso, image de fond disparue suite à mise à niveau 3.2

Messagepar agame » 30 Mar 2017 à 09:05

ok merci ça marche !! Bonne journée
agame
Roi des posts
Roi des posts
 
Messages: 665
Enregistré le: 17 Avr 2006 à 21:08

Re: we_universal_perso, image de fond disparue suite à mise à niveau 3.2

Messagepar cabot » 30 Mar 2017 à 09:49

agame a écrit:ben ça marche pas j'ai de nouveau une page blanche

Parce que tu as fait une erreur en modifiant le fichier responsive.css du style parent (we univeral), vire ça :
Code: Tout sélectionner
	html, body {
		background: url("./images/fond2.jpg");
	}
	.post.reported .postbody:before {
		border-color: transparent transparent #007100 transparent;
	}
	.inventea-footer, .inventea-footer a {
		 color: #F6F6F6;
	}
	
}	
Image
Avatar de l’utilisateur
cabot
Equipe site
Equipe site
 
Messages: 26813
Enregistré le: 13 Fév 2011 à 19:42
Localisation: Rarement sur la plaque

Re: we_universal_perso, image de fond disparue suite à mise à niveau 3.2

Messagepar agame » 30 Mar 2017 à 11:16

ok ça fonctionne aussi merci !
agame
Roi des posts
Roi des posts
 
Messages: 665
Enregistré le: 17 Avr 2006 à 21:08

Re: we_universal_perso, image de fond disparue suite à mise à niveau 3.2

Messagepar cabot » 30 Mar 2017 à 11:43

Parfait, maintenant tu peux aussi supprimer ça dans le fichier responsive.css de ton style perso :
Code: Tout sélectionner
	html, body {
		background: url("./images/fond2.jpg");
	}

Et pendant que tu nettoies les fichiers, vire aussi ça dans stylesheet.css :
Code: Tout sélectionner
/* Modifs responsive.css
********************************/
html,
html, body {
    background: url("./images/fond2.jpg");
}
.post.reported .postbody:before {
	border-color: transparent transparent #007100 transparent;
}

.inventea-footer, .inventea-footer a {
     color: #F6F6F6;
}
Image
Avatar de l’utilisateur
cabot
Equipe site
Equipe site
 
Messages: 26813
Enregistré le: 13 Fév 2011 à 19:42
Localisation: Rarement sur la plaque

Re: we_universal_perso, image de fond disparue suite à mise à niveau 3.2

Messagepar agame » 30 Mar 2017 à 12:02

rôôôô.... tu m'as changé les couleur du footer.... je remets:
.inventea-footer, .inventea-footer a {
color: #F6F6F6;

??


ouhhhhh lalaaaa je mets tout comme le dernier message , même mon dashboard a change !!!
agame
Roi des posts
Roi des posts
 
Messages: 665
Enregistré le: 17 Avr 2006 à 21:08

Suivante

Retourner vers [3.2.x] Modifications et recherche de styles

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité