[Réglé] Intégration style Wordpress/phpBB3.2.0

Pour les recherches et les demandes de modifications de styles concernant votre forum phpBB 3.2

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com - Conditions générales de support graphique

Attention : pour éviter les bogues, votre style doit être mis à jour en même temps que votre forum, et ce, dans la dernière version disponible de phpBB !
Partager sur FacebookPartager sur TwitterPartager sur Google+

[Réglé] Intégration style Wordpress/phpBB3.2.0

Messagepar Valium » 13 Fév 2017 à 04:32

Salut la communauté ! :)

J'ai recemment migré mon site vers un autre hebergement, la team ayant changé le nom j'ai donc refait entièrement le site avec le nouveau nom et les nouvelles couleurs.
J'en ai profité pour mettre a jour le forum dans sa nouvelle version.

Mais au moment d'ajuster mon thème je rencontre deux problèmes majeurs :

1 - Les dropdown menus des boutons du type "Aller a" sont automatiquements actifs.

2 - Les icones css comme celles breadcrumbs du bas ou des boutons ne sont pas trouvées/affichées alors que certaines marchent.

Je vous met ci dessous un screenshot pour que vous voyez le problème.

Image
(Il me reste encore énormement d'ajustements css à faire au niveau du forum :mrgreen: )

J'ai bien changé toutes les anciennes URL dans mes fichiers overall_header et overall_footer et je ne sais pas comment faire ou si je dois changer de thème... :? Voici le lien vers le forum :

http://waitforit.fr/forum/

Merci d'avance pour votre précieuse aide :oops: !
Modifié en dernier par Valium le 15 Fév 2017 à 15:52, modifié 1 fois.
Avatar de l’utilisateur
Valium
Posteur néophyte
Posteur néophyte
 
Messages: 44
Enregistré le: 04 Jan 2016 à 21:33
Localisation: Le Sud selon Nino Ferrer

Re: Problèmes suite à une Migration + Mise à jour

Messagepar Mazeltof » 13 Fév 2017 à 12:08

'jour ici,

Cet aspect est généralement visible lors de la mise à jour de phpBB 3.2.0 il suffit de vider le cache du navigateur (ctrl+F5 ou F5) pour que ça rentre dans l'ordre.

Cela dit, la base de ton style est une version Basic 3.1.6 signé Arty, qui lui n'est pas compatible avec la version 3.2.0 de phpBB (d'ailleurs on ne voit pas le copy: style by Arty, habituellement au bas de ses styles :? )
Image Image Image
Avatar de l’utilisateur
Mazeltof
Graphiste
Graphiste
 
Messages: 1320
Enregistré le: 09 Mar 2009 à 22:02
Localisation: Arras

Re: Problèmes suite à une Migration + Mise à jour

Messagepar cocooncrash » 13 Fév 2017 à 15:13

Sans copyright du style, au regret de bloquer la demande de support plus en avant.


ps: sujet reouvert après contact par mp avec le membre.
decouvrez l'aide complete : ICI
découvrez les règles : La_bas

Pensez a ajouter le tag [réglé] en modifiant votre premier message s'il est résolu. Merci :wink:
Avatar de l’utilisateur
cocooncrash
Resp. des modérateurs
Resp. des modérateurs
 
Messages: 7222
Enregistré le: 07 Jan 2008 à 08:29
Localisation: dans un bocal en compagnie de nemo!!

Re: Problèmes suite à une Migration + Mise à jour

Messagepar Valium » 14 Fév 2017 à 15:50

Je suis vraiment désolé pour cette histoire de copyright...
A l'époque où vous m'aviez aidé à faire mon integration j'avais enlevé les copyrights phpBB et vous m'aviez tappé sur les doigts (ce que j'ai très bien compris). Et au moment de les remettre j'ai oublié la petite ligne qui mentionnait Arty pour leur thème basic (ce n'était pas volontaire).

Bref,

Du coup changement de programme, je me suis lancé dans l'opération longue et perilleuse de refaire mon propre thème en créant un thème enfant hérité directement de prosilver (comme ça plus de soucis).

J'ai très bien reussit à refaire mon integration (j'ai eu un bon prof, merci cabot :P ) mais j'ai du refaire énormement d'ajustement CSS car le CSS de mon site à completement déformé prosilver du coup je me retrouve avec un css perso assez chiadé dans le thème mais c'est pas grave.. L'important étant la partie visible x)

Mais j'ai toujours le problème de certaines icones CSS qui n'apparaissent pas comme le icon fa-file ou le icon external-link-square ?

Aurais-je oublié des lignes dans mon intégration et/ou un problème d'ordre dans les appels ?

Merci d'avance :D
Avatar de l’utilisateur
Valium
Posteur néophyte
Posteur néophyte
 
Messages: 44
Enregistré le: 04 Jan 2016 à 21:33
Localisation: Le Sud selon Nino Ferrer

Re: Problèmes suite à une Migration + Mise à jour

Messagepar cabot » 14 Fév 2017 à 17:05

Hello,

C'est mal barré ton affaire, tu pars avec un style en 3.1 comme base de travail sur un forum 3.2. :o

La première des choses à faire pour éviter les conflits est de porter le style en 3.2.
Sachant que c'est un style d'Arty, bon courage. :mrgreen:

Edit : ah mais nan, c'est pas un style d'Arty, c'est un bricolage perso.
Tu as quand même un conflit JS, je vais y jeter un oeil.
Image
Avatar de l’utilisateur
cabot
Resp. des graphistes
Resp. des graphistes
 
Messages: 26302
Enregistré le: 13 Fév 2011 à 19:42
Localisation: Rarement sur la plaque

Re: Problèmes suite à une Migration + Mise à jour

Messagepar Valium » 14 Fév 2017 à 17:29

Yep, comme je l'ai dit plus haut, j'ai abandonné mon child Basic et je suis entrain d'en refaire un à partir du prosilver.
Mais est-ce que le thème à été mis à jour en même temps que mon forum ?
Avatar de l’utilisateur
Valium
Posteur néophyte
Posteur néophyte
 
Messages: 44
Enregistré le: 04 Jan 2016 à 21:33
Localisation: Le Sud selon Nino Ferrer

Re: Problèmes suite à une Migration + Mise à jour

Messagepar tomberaid » 14 Fév 2017 à 18:50

Hello
Tu fais appel dans overall_header.html à un fichier fontfaces.css qui rend inactives certaines icônes précédemment appelées par le fichier font-awesome.min.css.
Ce fichier te sert-il vraiment pour ton style ?
À la base c'est un fichier pour Wordpress puisque le chemin mène dans le dossier de celui-ci :
Code: Tout sélectionner
http://waitforit.fr/wp-content/themes/tempera/fonts/fontfaces.css
.

Cordialement
Image
Avatar de l’utilisateur
tomberaid
Roi des posts
Roi des posts
 
Messages: 648
Enregistré le: 17 Juin 2009 à 23:27

Re: Problèmes suite à une Migration + Mise à jour

Messagepar Valium » 14 Fév 2017 à 19:06

Bien vu tomberaid, les icones sont réapparues !

Je vais continuer à progresser sur la creation de mon template et ma montagne de css. :lol:
Je reviendrai vers vous si je rencontre d'autre problèmes, en attendant je vous remercie tous pour votre aide et je passe le sujet en resolu !
Avatar de l’utilisateur
Valium
Posteur néophyte
Posteur néophyte
 
Messages: 44
Enregistré le: 04 Jan 2016 à 21:33
Localisation: Le Sud selon Nino Ferrer

Re: Problèmes suite à une Migration + Mise à jour

Messagepar cabot » 14 Fév 2017 à 19:12

Ouep, il faut t'en passer et modifier deux ou trois classes, notamment pour l'icône du scroll top (fonctionnalité que tu n'as pas pour le moment à cause d'un conflit JS ^^).

Je checke les 2 principaux fichiers, je te donne mes impressions au fur et à mesure.

Ouvre overall_header.html
Supprime :
Code: Tout sélectionner
		<section id="container" class="one-column">
	
			<div id="content" role="main">

Et supprime les balises fermantes correspondantes dans ton overall_footer :
Code: Tout sélectionner
				</div><!-- #content -->
			
		</section><!-- #container -->

Retour au overall_header, trouve :
Code: Tout sélectionner
<link rel="stylesheet" type="text/css" href="http://waitforit.fr/wp-content/themes/tempera/style.css?ver=4.4.1" />
<link media="all" type="text/css" href="http://waitforit.fr/wp-content/themes/tempera/fonts/fontfaces.css" id="tempera-fonts-css" rel="stylesheet">

Remplace par :
Code: Tout sélectionner
<link rel="stylesheet" type="text/css" href="http://waitforit.fr/wp-content/themes/tempera/style.css?assets_version={T_ASSETS_VERSION}">
<link href="https://fonts.googleapis.com/css?family=Coda|Kanit|Roboto|Russo+One" rel="stylesheet"> 

Trouve :
Code: Tout sélectionner
<link href='https://fonts.googleapis.com/css?family=Roboto' rel='stylesheet' type='text/css'>
<link href='https://fonts.googleapis.com/css?family=Coda' rel='stylesheet' type='text/css'>
<link href='https://fonts.googleapis.com/css?family=Kanit' rel='stylesheet' type='text/css'>
<link href='https://fonts.googleapis.com/css?family=Russo One' rel='stylesheet' type='text/css'>
	
<link href="{T_THEME_PATH}/tempera.css?assets_version={T_ASSETS_VERSION}" rel="stylesheet">
<link rel="stylesheet" type="text/css" href="http://waitforit.fr/wp-content/themes/tempera/styles/style-mobile.css?ver=4.4.1" />

Remplace par :
Code: Tout sélectionner
<link href="http://waitforit.fr/forum/styles/waitforit3.2.0/theme/tempera.css?assets_version={T_ASSETS_VERSION}" rel="stylesheet">
<link rel="stylesheet" href="http://waitforit.fr/wp-content/themes/tempera/styles/style-mobile.css?assets_version={T_ASSETS_VERSION}">

Trouve :
Code: Tout sélectionner
<div id="toTop" style="margin-left: 1300px; opacity: 0; margin-right: 1300px;"><i class="icon-back2top"></i> </div>

Remplace par :
Code: Tout sélectionner
<div id="toTop"><i class="icon fa-chevron-up"></i></div>

Ouvre overall_footer.html, supprime :
Code: Tout sélectionner
<script type="text/javascript" src="http://waitforit.fr/wp-content/themes/tempera/js/frontend.js?ver=1.4"></script>

Supprime :
Code: Tout sélectionner
<script>
	tempera_mobilemenu_init();
	var cryout_toTop_offset = 1150;
</script>

Trouve :
Code: Tout sélectionner
</body>

Ajoute avant :
Code: Tout sélectionner
<script type='text/javascript' src='http://waitforit.fr/wp-content/themes/tempera/js/frontend.js?assets_version={T_ASSETS_VERSION}'></script>
<script>
var tempera_settings = {"mobile":"1","fitvids":"1"};
var cryout_toTop_offset = 1150;
</script>

Pis tu vas me faire le plaisir d'indenter ton code, hein, parce que là c'est tout pourri. Image
Image
Avatar de l’utilisateur
cabot
Resp. des graphistes
Resp. des graphistes
 
Messages: 26302
Enregistré le: 13 Fév 2011 à 19:42
Localisation: Rarement sur la plaque

Re: Problèmes suite à une Migration + Mise à jour

Messagepar Valium » 15 Fév 2017 à 03:06

Hey !
Bonne idée d'avoir réouvert le sujer car en effet il me reste quelques questions sur lesquelles j'ai besoin de m'éclaircir x)

Cabot, j'ai appliqué toutes les modifs que tu m'as dit. Ca marche niquel et c'est propre ! J'ai a peu près compris la nature de ces modifs (dis moi si je me gourre): supprimer deux bloc de mon wp inutiles ? mettre de l'ordre dans la priorité des appels de styles (ex je savais pas qu'on pouvait combiner les appels de fonts) et supprimer au passage la ligne que tomberaid m'as dit de virer ?

En tout cas ca a l'air de fonctionner et en plus mon scroll toTop du site marche !
Il me reste quelques questions CSS comme celle de la proprieté responsive de l'entete des posts (postprofile, etc...) avec l'avatar, les icones.
Surtout le dropdown menu en dessous de l'avatar au lien "Contact". Il est coupé par les limites de mon thème et n'accepte pas vraiment les valeurs de type z-index.
Il y aussi le champ de la reponse rapide qui dépasse sur la droite lorsque je suis sur mobile (j'ai pensé a la desactivé suivant un certain format pour pas me faire chyé). Mais tout ca est lié à ces conflits CSS avec mon tempera de wp qu'il faudrait que j'identifie non ?x)

En tout cas cab' je suis d'ac avec toi sur la propreté du code et j'essaie d'avoir un code indenté en général pour moi même m'y retrouver mais je t'avoue que sur mon tempera.css j'ai pas nettoyé ma copie de certains codes du site en pensant que l'intégration allait foirer. La je suis en mode sachant fou savant rien haha.

En tout cas je commence a entre-voir le bout
Avatar de l’utilisateur
Valium
Posteur néophyte
Posteur néophyte
 
Messages: 44
Enregistré le: 04 Jan 2016 à 21:33
Localisation: Le Sud selon Nino Ferrer

Re: Problèmes suite à une Migration + Mise à jour

Messagepar cabot » 15 Fév 2017 à 13:38

Supprime toutes les règles inutiles dans tempera.css. Ça va régler le plus gros, voire la totalité, des problèmes et alléger considérablement le fichier.

Quand je parlais d'indentation du code, je pensais surtout à celui ajouté dans le HTML. ^^

ps : merci de modifier le titre qui n'a aucun rapport avec la demande. Quelque chose genre "Intégration style Wordpress/phpBB" conviendrait plus au sujet. :wink:
Image
Avatar de l’utilisateur
cabot
Resp. des graphistes
Resp. des graphistes
 
Messages: 26302
Enregistré le: 13 Fév 2011 à 19:42
Localisation: Rarement sur la plaque

Re: Intégration style Wordpress/phpBB3.2.0

Messagepar Valium » 15 Fév 2017 à 16:34

Je suis entrain de nettoyer tempera.css mais c'est assez compliqué d'identifier les valeurs inutiles... :|
Je viens de remarquer que mon footer n'apparait pas comme il le devrait. Il y a une erreur de fermeture de div dans overall-footer mais j'arrive pas a voir laquelle xD
Avatar de l’utilisateur
Valium
Posteur néophyte
Posteur néophyte
 
Messages: 44
Enregistré le: 04 Jan 2016 à 21:33
Localisation: Le Sud selon Nino Ferrer

Re: Intégration style Wordpress/phpBB3.2.0

Messagepar cabot » 15 Fév 2017 à 17:39

Tu n'as pas supprimé les balises ouvrantes dans le overall_header :
Code: Tout sélectionner
		<section id="container" class="one-column">
	
			<div id="content" role="main">

De plus il y a un problème dans la structure du document car tu as ajouté des caractères après la ligne qui charge style-mobile.css, il faut les virer :
Code: Tout sélectionner
<link href="http://waitforit.fr/wp-content/themes/tempera/styles/style-mobile.css?assets_version={T_ASSETS_VERSION}" rel="stylesheet">fto
Image
Avatar de l’utilisateur
cabot
Resp. des graphistes
Resp. des graphistes
 
Messages: 26302
Enregistré le: 13 Fév 2011 à 19:42
Localisation: Rarement sur la plaque

Re: Intégration style Wordpress/phpBB3.2.0

Messagepar Valium » 15 Fév 2017 à 17:56

Hell Yeah ca le fait merci ! :twisted:

J'ai tout nettoyé mon tempera.css et j'ai viré tout les codes qui servaient a rien ou qui deformaient le style prosilver.

J'ai trouvé le souci de mes posts, les règles css du style wordpress prenaient le dessus sur la balise .post avec un overflow:hidden entre autres mais j'ai du forcer ces règles avec des !important.

Sinon j'ai rétabli le float:right du .postprofile mais j'aimerai quand même que les avatars soient sur la gauche.
Avatar de l’utilisateur
Valium
Posteur néophyte
Posteur néophyte
 
Messages: 44
Enregistré le: 04 Jan 2016 à 21:33
Localisation: Le Sud selon Nino Ferrer

Re: Intégration style Wordpress/phpBB3.2.0

Messagepar cabot » 15 Fév 2017 à 19:13

Tu n'as pas besoin de forcer les propriétés avec !important, il est préférable de respecter la cascade.

Jette un oeil dans tes MP, j'ai nettoyé un peu le style.
Il te reste à ajouter tes images dans le répertoire theme/images/, et a continuer à bricoler.
Image
Avatar de l’utilisateur
cabot
Resp. des graphistes
Resp. des graphistes
 
Messages: 26302
Enregistré le: 13 Fév 2011 à 19:42
Localisation: Rarement sur la plaque

Suivante

Retourner vers [3.2.x] Modifications et recherche de styles

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité