[Réglé] Favicon affichée uniquement dur l'index du forum

Pour les recherches et les demandes de modifications de styles concernant votre forum phpBB 3.1

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com - Conditions générales de support graphique

Attention : pour éviter les bogues, votre style doit être mis à jour en même temps que votre forum, et ce, dans la dernière version disponible de phpBB !
Partager sur FacebookPartager sur TwitterPartager sur Google+

[Réglé] Favicon affichée uniquement dur l'index du forum

Messagepar Pollux33 » 10 Jan 2017 à 13:38

Bonjour,


tout nouvel utilisateur de PHPBB j'ai un petit problème avec le favicon de mon forum

En effet, celui-ci n'apparait que sur la page index du forum.

Auriez vous une petite idée ?

https://www.lecoindudrone-forum.fr/phpBB33/index.php
Avatar de l’utilisateur
Pollux33
Posteur néophyte
Posteur néophyte
 
Messages: 23
Enregistré le: 02 Jan 2017 à 23:07

Re: Favicon affichée uniquement dur l'index du forum

Messagepar cabot » 10 Jan 2017 à 14:17

Hello,

J'ai divisé le sujet sous lequel tu avais posté ton message car ton problème n'a rien à voir avec le sujet d'origine.

La favicon ne s'affiche que sur l'index de ton forum car le code est bizarrement modifié. :mrgreen:
Toute cette partie de code renvoyée au début du document sur l'index avant <!DOCTYPE html> est en trop :
Code: Tout sélectionner
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>

<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<meta name="viewport" content="width=device=width, initial-scale=1.5">
<meta http-equiv="Content-Language" content="fr">
<title>FORUM des passionnes DJI</title>
<meta name="Description" lang="fr" content="Le forum des passionnés des drones DJI - ce forum totalement indépendant est un lieu de partage et d echange pour les passionnés de l image, du traitement des photos et du montage vidéo">
<meta name="Identifier-url" content="https://www.lecoindudrone-forum.fr/phpBB33/">

<link rel="icon" type="image/png" href="https://www.lecoindudrone-forum.fr/phpBB33/favicon.png" />
</head>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-89999686-1', 'auto');
  ga('send', 'pageview');

</script>
<!DOCTYPE html>

Commence par vider le cache du forum pour voir si ça règle le problème.

Qu'as-tu fait comme modif ?
As-tu installé une extension particulière pour modifier les fichiers ?
Image
Avatar de l’utilisateur
cabot
Equipe site
Equipe site
 
Messages: 26717
Enregistré le: 13 Fév 2011 à 20:42
Localisation: Rarement sur la plaque

Re: Favicon affichée uniquement dur l'index du forum

Messagepar Pollux33 » 10 Jan 2017 à 14:22

bonjour,


merci pour cette réponse rapide.

Comme dit plus haut, je n'y connais pas grand chose... et, ne sachant pas comment positionner les meta tags, j'ai écrit toute la partie du head en html et indiqué le chemin du favicon dans ce head.

Je n'ai rien trouvé pour le référencement, ni pour positionner la partie description et nom du forum.
Là est surement tout mon problème.

Après avoir vidé le cache, rien ne change.
Avatar de l’utilisateur
Pollux33
Posteur néophyte
Posteur néophyte
 
Messages: 23
Enregistré le: 02 Jan 2017 à 23:07

Re: Favicon affichée uniquement dur l'index du forum

Messagepar cabot » 10 Jan 2017 à 14:29

Oui mais ce que je ne comprends pas c'est que ton fichier overall_header.html ne présente pas de modifications, de plus ce fichier est utilisé sur toutes les pages du forum et ne devrait pas être différent d'une page à l'autre à moins d'ajouter des conditions particulières.

Comment as-tu modifié ce fichier ?
Image
Avatar de l’utilisateur
cabot
Equipe site
Equipe site
 
Messages: 26717
Enregistré le: 13 Fév 2011 à 20:42
Localisation: Rarement sur la plaque

Re: Favicon affichée uniquement dur l'index du forum

Messagepar Pollux33 » 10 Jan 2017 à 14:46

Le problème c'est que nous sommes deux administrateurs et que chacun fait un peus son boulot sans en informer l'autre.

Je viens de rajouter les lignes de déclaration du favicon comme dit sur ce tuto : http://forums.phpbb-fr.com/documentation/styles/ajouter-un-favicon-a-votre-forum-a110-view.html dans le fichier overall_header.html

est ce ce fichier dans lequel il faut décrire le titre, description etc. ???

<!DOCTYPE html>
<html dir="{S_CONTENT_DIRECTION}" lang="{S_USER_LANG}">
<head>
<meta charset="utf-8" />
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<link rel="shortcut icon" href="{ROOT_PATH}images/favicon.png" type="image/x-icon" />
<link rel="icon" href="{ROOT_PATH}images/favicon.png" type="image/x-icon" />
<meta name="viewport" content="width=device-width, initial-scale=1" /></head><body id="phpbb" class="nojs notouch section-{SCRIPT_NAME} {S_CONTENT_DIRECTION} {BODY_CLASS}">
{META}
<title><!-- IF UNREAD_NOTIFICATIONS_COUNT -->({UNREAD_NOTIFICATIONS_COUNT}) <!-- ENDIF --><!-- IF not S_VIEWTOPIC and not S_VIEWFORUM -->{SITENAME} - <!-- ENDIF --><!-- IF S_IN_MCP -->{L_MCP} - <!-- ELSEIF S_IN_UCP -->{L_UCP} - <!-- ENDIF -->{PAGE_TITLE}<!-- IF S_VIEWTOPIC or S_VIEWFORUM --> - {SITENAME}<!-- ENDIF --></title>
Avatar de l’utilisateur
Pollux33
Posteur néophyte
Posteur néophyte
 
Messages: 23
Enregistré le: 02 Jan 2017 à 23:07

Re: Favicon affichée uniquement dur l'index du forum

Messagepar cabot » 10 Jan 2017 à 16:27

Oui mais avant de continuer à modifier ce fichier, il faut régler le problème de code retourné dans le navigateur qui ne correspond pas au contenu du fichier et qui n'est pas le même selon la page affichée.

On va faire bœuf, désinstalle le style et réinstalle-le.
Image
Avatar de l’utilisateur
cabot
Equipe site
Equipe site
 
Messages: 26717
Enregistré le: 13 Fév 2011 à 20:42
Localisation: Rarement sur la plaque

Re: Favicon affichée uniquement dur l'index du forum

Messagepar Pollux33 » 10 Jan 2017 à 17:05

On va faire bœuf, désinstalle le style et réinstalle-le.

C'est à dire ? qu'est ce que je désinstalle au juste ? (désolé je suis vraiment novice)
Avatar de l’utilisateur
Pollux33
Posteur néophyte
Posteur néophyte
 
Messages: 23
Enregistré le: 02 Jan 2017 à 23:07

Re: Favicon affichée uniquement dur l'index du forum

Messagepar cabot » 10 Jan 2017 à 17:08

Tu désinstalles le style actuel via le panneau d'admin, tu respires un grand coup, et tu le réinstalles. :)
Image
Avatar de l’utilisateur
cabot
Equipe site
Equipe site
 
Messages: 26717
Enregistré le: 13 Fév 2011 à 20:42
Localisation: Rarement sur la plaque

Re: Favicon affichée uniquement dur l'index du forum

Messagepar Pollux33 » 10 Jan 2017 à 17:32

Je crois que c'est fait...

et ?
Avatar de l’utilisateur
Pollux33
Posteur néophyte
Posteur néophyte
 
Messages: 23
Enregistré le: 02 Jan 2017 à 23:07

Re: Favicon affichée uniquement dur l'index du forum

Messagepar cabot » 10 Jan 2017 à 18:37

Et le problème est toujours présent, cette partie de code qui n'a rien à faire là se trouve toujours dans le code renvoyé au navigateur :
Code: Tout sélectionner
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>

<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<meta name="viewport" content="width=device=width, initial-scale=1.5">
<meta http-equiv="Content-Language" content="fr">
<title>FORUM des passionnes DJI</title>
<meta name="Description" lang="fr" content="Le forum des passionnés des drones DJI - ce forum totalement indépendant est un lieu de partage et d echange pour les passionnés de l image, du traitement des photos et du montage vidéo">
<meta name="Identifier-url" content="https://www.lecoindudrone-forum.fr/phpBB33/">

<link rel="icon" type="image/png" href="https://www.lecoindudrone-forum.fr/phpBB33/favicon.png" />
</head>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-89999686-1', 'auto');
  ga('send', 'pageview');

</script>

Et tant que vous n'avez pas réglé ce problème, il est inutile de chercher à aller plus loin car le forum est instable.
Image
Avatar de l’utilisateur
cabot
Equipe site
Equipe site
 
Messages: 26717
Enregistré le: 13 Fév 2011 à 20:42
Localisation: Rarement sur la plaque

Re: Favicon affichée uniquement dur l'index du forum

Messagepar Pollux33 » 10 Jan 2017 à 18:56

Je viens de nettoyer le fichier overall_header.html

voici la configuration du site

Image
Avatar de l’utilisateur
Pollux33
Posteur néophyte
Posteur néophyte
 
Messages: 23
Enregistré le: 02 Jan 2017 à 23:07

Re: Favicon affichée uniquement dur l'index du forum

Messagepar Pollux33 » 10 Jan 2017 à 19:20

Je viens de supprimer et reinstaller le THEME...

est-ce mieux ?

Bon, le THEME ne fonctionne plus il m'a fallu repartir sur celui par défaut...
Avatar de l’utilisateur
Pollux33
Posteur néophyte
Posteur néophyte
 
Messages: 23
Enregistré le: 02 Jan 2017 à 23:07

Re: Favicon affichée uniquement dur l'index du forum

Messagepar cabot » 10 Jan 2017 à 19:51

Il semblerait que le problème ne vienne pas du style puisque l'erreur est toujours là, vous avez dû modifier un autre fichier ou installé une extension permettant de le faire.
Image
Avatar de l’utilisateur
cabot
Equipe site
Equipe site
 
Messages: 26717
Enregistré le: 13 Fév 2011 à 20:42
Localisation: Rarement sur la plaque

Re: Favicon affichée uniquement dur l'index du forum

Messagepar Pollux33 » 10 Jan 2017 à 22:56

Je ne sais plus quoi faire...
Avatar de l’utilisateur
Pollux33
Posteur néophyte
Posteur néophyte
 
Messages: 23
Enregistré le: 02 Jan 2017 à 23:07

Re: Favicon affichée uniquement dur l'index du forum

Messagepar galixte » 10 Jan 2017 à 23:46

En téléchargeant le style depuis cette page : https://www.phpbb.com/community/app.php ... h_fresh_2/, on peut trouver dans le fichier overall_header.html ceci en début de fichier :
Code: Tout sélectionner
<!DOCTYPE html>
<html dir="{S_CONTENT_DIRECTION}" lang="{S_USER_LANG}">
<head>
<meta charset="utf-8" />

<meta http-equiv="X-UA-Compatible" content="IE=edge">

<meta name="viewport" content="width=device-width, initial-scale=1" />

{META}
Dans la source de sa page je ne vois l’occurrence qu’une fois.

Il y a manifestement des extensions d’activées sur ton forum, telles que : ELONW, abbc3, Google analytics, collapsiblecategories, boardrules, smiliesscrollbox, background & profilgauche.
Modifié en dernier par galixte le 10 Jan 2017 à 23:51, modifié 1 fois.
Communau EzCom
Image
« Traductions d’extensions & styles pour phpBB 3.1.x & 3.2.x ».
ImageListes de toutes les extensions recensées pour phpBB 3.1.x & 3.2.x.
ImageListes de tous les styles recensés pour phpBB 3.1.x & 3.2.x.
Avatar de l’utilisateur
galixte
Floodeur universel
Floodeur universel
 
Messages: 9535
Enregistré le: 08 Mar 2004 à 02:40
Localisation: Sud de la France.

Suivante

Retourner vers [3.1.x] Modifications et recherche de styles

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité