[Réglé] Extension pour enlever "Aucune" dans les icônes de sujet

Pour les recherches et les demandes de modifications de styles concernant votre forum phpBB 3.1

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com - Conditions générales de support graphique

Attention : pour éviter les bogues, votre style doit être mis à jour en même temps que votre forum, et ce, dans la dernière version disponible de phpBB !

[Réglé] Extension pour enlever "Aucune" dans les icônes de sujet

Messagepar Darloup » 01 Avr 2016 à 02:20

Bonjour,

Je suis à la recherche d'une extension gérant les icônes de sujet. Je m'explique :

Mon forum étant bilingue (français - espagnol), j'ai ajouté des icônes de langue :

Image

La personne qui envoie un message doit donc choisir entre français, espagnol, ou français/espagnol pour indiquer la langue utilisée pour composer le message.

Mon problème est que l'option "Aucune" apparaît avant mes icônes de langue et est sélectionnée par défaut.

L'expérience m'a montré que moins de 5% des usagers sélectionnent une icône de langue <soupir>. J'aimerais donc que l'option "Aucune" disparaisse.

Cela ne me dérange pas que l'icône "Français" soit sélectionnée par défaut...

Merci d'avance !

Cordialement,

Henry
Modifié en dernier par Darloup le 16 Nov 2016 à 13:16, modifié 5 fois.
Avatar de l’utilisateur
Darloup
Roi des posts
Roi des posts
 
Messages: 543
Enregistré le: 14 Mar 2009 à 21:49
Localisation: Barranquilla (Colombie)

Re: Extension pour enlever "Aucune" dans les icônes de sujet

Messagepar cabot » 02 Avr 2016 à 12:57

Hello,

On ne peut pas faire une extension car il n'y a pas les évènements nécessaires mais tu peux modifier le fichier posting_editor.html, trouve :
Code: Tout sélectionner
		<dd>
			<label for="icon"><input type="radio" name="icon" id="icon" value="0" checked="checked" tabindex="1" /> <!-- IF S_SHOW_TOPIC_ICONS -->{L_NO_TOPIC_ICON}<!-- ELSE -->{L_NO_PM_ICON}<!-- ENDIF --></label>
			<!-- BEGIN topic_icon --><label for="icon-{topic_icon.ICON_ID}"><input type="radio" name="icon" id="icon-{topic_icon.ICON_ID}" value="{topic_icon.ICON_ID}" {topic_icon.S_ICON_CHECKED} tabindex="1" /><img src="{topic_icon.ICON_IMG}" width="{topic_icon.ICON_WIDTH}" height="{topic_icon.ICON_HEIGHT}" alt="{topic_icon.ICON_NAME}" title="" /></label> <!-- END topic_icon -->
		</dd>

Remplace par :
Code: Tout sélectionner
		<dd>
			<!-- IF S_PRIVMSGS --><label for="icon"><input type="radio" name="icon" id="icon" value="0" checked="checked" tabindex="1" /> <!-- IF S_SHOW_TOPIC_ICONS -->{L_NO_TOPIC_ICON}<!-- ELSE -->{L_NO_PM_ICON}<!-- ENDIF --></label><!-- ENDIF -->
			<!-- BEGIN topic_icon --><label for="icon-{topic_icon.ICON_ID}"><input type="radio" name="icon" id="icon-{topic_icon.ICON_ID}" value="{topic_icon.ICON_ID}" <!-- IF not S_PRIVMSGS and S_NEW_MESSAGE and topic_icon.ICON_ID eq 1 -->checked="checked"<!-- ELSE -->{topic_icon.S_ICON_CHECKED}<!-- ENDIF --> tabindex="1" /><img src="{topic_icon.ICON_IMG}" width="{topic_icon.ICON_WIDTH}" height="{topic_icon.ICON_HEIGHT}" alt="{topic_icon.ICON_NAME}" title="" /></label> <!-- END topic_icon -->
		</dd>
J'ai considéré que l'icône ayant l'ID 1 est sélectionnée par défaut (topic_icon.ICON_ID eq 1) et j'ai laissé le choix "aucune" pour les MP, je pense que ça devrait le faire.

Si ça ne fonctionne pas il faudra connaitre 1/l'ID de l'icône 2/sa position dans la liste
Avatar de l’utilisateur
cabot
Equipe site
Equipe site
 
Messages: 26830
Enregistré le: 13 Fév 2011 à 20:42
Localisation: Rarement sur la plaque

Re: Extension pour enlever "Aucune" dans les icônes de sujet

Messagepar Darloup » 03 Avr 2016 à 02:47

Bonjour cabot,

Un GRAND merci pour ton retour !

J'ai mis en place les changements et l'option "Aucune" a maintenant disparu ! :D

Un dernière question :

Pour l'instant, rien n'est coché par défaut. Ceci veut dire que si un membre ne coche pas une icône de langue, rien n’apparaîtra (comme icône de langue).

Que faut-il faire pour que :

1) Un membre ne puisse rien envoyer s'il n'a pas coché une icône de langue

ou bien

2) La première icône de langue (le français) soit cochée par défaut.

Avec mes remerciements anticipés,

Cordialement,

Henry
Avatar de l’utilisateur
Darloup
Roi des posts
Roi des posts
 
Messages: 543
Enregistré le: 14 Mar 2009 à 21:49
Localisation: Barranquilla (Colombie)

Re: Extension pour enlever "Aucune" dans les icônes de sujet

Messagepar cabot » 03 Avr 2016 à 08:40

La première icône devrait être sélectionnée par défaut.
cabot a écrit:Si ça ne fonctionne pas il faudra connaitre 1/l'ID de l'icône 2/sa position dans la liste
:wink:

Pour obtenir un support plus efficace, merci de préciser l'URL de votre forum, et de nous mettre à disposition un compte "test" sur votre forum.
Avatar de l’utilisateur
cabot
Equipe site
Equipe site
 
Messages: 26830
Enregistré le: 13 Fév 2011 à 20:42
Localisation: Rarement sur la plaque

Re: Extension pour enlever "Aucune" dans les icônes de sujet

Messagepar FoFa » 03 Avr 2016 à 11:48

Hello,

cabot a écrit:Pour obtenir un support plus efficace, merci de préciser l'URL de votre forum, et de nous mettre à disposition un compte "test" sur votre forum.

support-utilisation-phpbb31/sujet207590.html#p1624239

:mrgreen: :mrgreen: :mrgreen:
De retour parmi vous :wink:
FoFa
Resp. des supporters
Resp. des supporters
 
Messages: 10606
Enregistré le: 15 Nov 2008 à 19:04
Localisation: Auxonne

Re: Extension pour enlever "Aucune" dans les icônes de sujet

Messagepar sub60 » 03 Avr 2016 à 12:12

Salut,

heu.. Pour rappel voir le cadre rouge juste au dessus :roll:
en retraite sur le woueb :mrgreen:
Avatar de l’utilisateur
sub60
Floodeur universel
Floodeur universel
 
Messages: 9519
Enregistré le: 19 Juin 2006 à 15:14
Localisation: oise

Re: Extension pour enlever "Aucune" dans les icônes de sujet

Messagepar FoFa » 03 Avr 2016 à 12:18

sub60 a écrit:Salut,

heu.. Pour rappel voir le cadre rouge juste au dessus :roll:


Votre sujet a été déplacé par un membre de l'équipe.

Origine : recherche d'extensions
De retour parmi vous :wink:
FoFa
Resp. des supporters
Resp. des supporters
 
Messages: 10606
Enregistré le: 15 Nov 2008 à 19:04
Localisation: Auxonne

Re: Extension pour enlever "Aucune" dans les icônes de sujet

Messagepar cabot » 03 Avr 2016 à 13:08

Pour le coup c'est une modif de style :wink:

Dans le code de remplacement, trouve :
Code: Tout sélectionner
topic_icon.ICON_ID eq 1

Remplace 1 par 15
Avatar de l’utilisateur
cabot
Equipe site
Equipe site
 
Messages: 26830
Enregistré le: 13 Fév 2011 à 20:42
Localisation: Rarement sur la plaque

Re: Extension pour enlever "Aucune" dans les icônes de sujet

Messagepar FoFa » 03 Avr 2016 à 13:11

cabot a écrit:Pour le coup c'est une modif de style :wink:

Exact :oops:
De retour parmi vous :wink:
FoFa
Resp. des supporters
Resp. des supporters
 
Messages: 10606
Enregistré le: 15 Nov 2008 à 19:04
Localisation: Auxonne

Re: Extension pour enlever "Aucune" dans les icônes de sujet

Messagepar Darloup » 03 Avr 2016 à 23:33

Bonjour,

Un grand merci cabot - cela marche parfaitement ! :D

Cordialement,

Henry

P.S. Nouvelles

Désolé de rouvrir ce fil, mais j'aurais besoin d'un dernier petit réglage :oops:

En effet, tout fonctionne parfaitement lorsque l'on poste un nouveau message (trois icônes de langue avec la première (français) cochée par défaut) mais, si l'on répond à un message, la première icône (français) n'est pas cochée.

Que faut-il donc faire (et dans quel fichier ?) afin que la première icône (français) soit cochée par défaut lorsque l'on répond à un message ?

Merci d'avance !

Cordialement,

Henry
Avatar de l’utilisateur
Darloup
Roi des posts
Roi des posts
 
Messages: 543
Enregistré le: 14 Mar 2009 à 21:49
Localisation: Barranquilla (Colombie)

Re: Extension pour enlever "Aucune" dans les icônes de sujet

Messagepar cabot » 04 Avr 2016 à 08:48

C'est le comportement "normal" par défaut, lorsque tu ajoutes une icône à un sujet, elle ne s'affiche pas dans tous les messages pour éviter les requêtes inutiles et la surcharge d'images, de plus je pense que tu vas lasser les utilisateurs en les forçant à modifier une icône lors de chaque réponse, sans compter que cette signalisation trouve toute son utilité sur la liste des sujets mais ne sert à rien lorsqu'on lit les messages.
Avatar de l’utilisateur
cabot
Equipe site
Equipe site
 
Messages: 26830
Enregistré le: 13 Fév 2011 à 20:42
Localisation: Rarement sur la plaque

Re: Extension pour enlever "Aucune" dans les icônes de sujet

Messagepar Darloup » 14 Nov 2016 à 09:29

Bonjour cabot,

Désolé d'avoir à revenir vers toi sur ce sujet mais, depuis que je suis passé de la version 3.1.09 à la version 3.1.10 de phpBB ou bien depuis que j'ai changé mon style vers OrangeBBEs (qui hérite pourtant de Prosilver), l'icône de langue de français (la première) n'est plus cochée par défaut comme dans le passé suite à tes modifications et ce uniquement lorsque je réponds à un post. Elle est bien cochée lorsque je poste un nouveau message. À moins, bien sûr, que cette première icône n'ait jamais été cochée lors d'une réponse (je ne me suis jamais rendu compte).

J'ai bien vérifié mon fichier posting_editor.html qui montre bien :

Code: Tout sélectionner
<dd>
			<!-- IF S_PRIVMSGS --><label for="icon"><input type="radio" name="icon" id="icon" value="0" checked="checked" tabindex="1" /> <!-- IF S_SHOW_TOPIC_ICONS -->{L_NO_TOPIC_ICON}<!-- ELSE -->{L_NO_PM_ICON}<!-- ENDIF --></label><!-- ENDIF -->
			<!-- BEGIN topic_icon --><label for="icon-{topic_icon.ICON_ID}"><input type="radio" name="icon" id="icon-{topic_icon.ICON_ID}" value="{topic_icon.ICON_ID}" <!-- IF not S_PRIVMSGS and S_NEW_MESSAGE and topic_icon.ICON_ID eq 15 -->checked="checked"<!-- ELSE -->{topic_icon.S_ICON_CHECKED}<!-- ENDIF --> tabindex="1" /><img src="{topic_icon.ICON_IMG}" width="{topic_icon.ICON_WIDTH}" height="{topic_icon.ICON_HEIGHT}" alt="{topic_icon.ICON_NAME}" title="" /></label> <!-- END topic_icon -->
		</dd>


Avec topic_icon.ICON_ID eq 15

Quelle peut être la source de ce problème lors d'une réponse à un post ?

Merci d'avance - comme toujours !

Cordialement,

Henry
Avatar de l’utilisateur
Darloup
Roi des posts
Roi des posts
 
Messages: 543
Enregistré le: 14 Mar 2009 à 21:49
Localisation: Barranquilla (Colombie)

Re: Extension pour enlever "Aucune" dans les icônes de sujet

Messagepar cabot » 14 Nov 2016 à 11:45

La réponse donnée dans mon précédent message est toujours d'actualité. :wink:
Avatar de l’utilisateur
cabot
Equipe site
Equipe site
 
Messages: 26830
Enregistré le: 13 Fév 2011 à 20:42
Localisation: Rarement sur la plaque

Re: Extension pour enlever "Aucune" dans les icônes de sujet

Messagepar Darloup » 16 Nov 2016 à 03:59

Oups, désolé, j'avais totalement oublié ton point :oops:
Avatar de l’utilisateur
Darloup
Roi des posts
Roi des posts
 
Messages: 543
Enregistré le: 14 Mar 2009 à 21:49
Localisation: Barranquilla (Colombie)

Re: Extension pour enlever "Aucune" dans les icônes de sujet

Messagepar cabot » 16 Nov 2016 à 09:33

Si vous considérez votre requête comme résolue, merci d'ajouter l'attribut de sujet [Réglé]
Avatar de l’utilisateur
cabot
Equipe site
Equipe site
 
Messages: 26830
Enregistré le: 13 Fév 2011 à 20:42
Localisation: Rarement sur la plaque


Retourner vers [3.1.x] Modifications et recherche de styles

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 2 invités