[Réglé] Décalage sous IE

Pour les recherches et les demandes de modifications de styles concernant votre forum phpBB 3.1

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com - Conditions générales de support graphique

Attention : pour éviter les bogues, votre style doit être mis à jour en même temps que votre forum, et ce, dans la dernière version disponible de phpBB !
Partager sur FacebookPartager sur TwitterPartager sur Google+

[Réglé] Décalage sous IE

Messagepar dje8269 » 18 Juin 2015 à 06:39

Bonjour ,

Suite a différentes manipulation, je me suis rendu compte , un peu tard que sous IE mon forum buggait complètement . j'ai bien essayé de comparer des feuilles avec une sauvegarde, mais j'a rien trouvé qui m'arrrengait . Je suppose qu'il s=q'uil s'agit d'une genre de <div> qui aurait disparu .

Le probléme apparait pas sur toutes les pages ; si vous cliquez sur un post , il apparait bien des fois .

Si qqun a une idée je suis preneur , car la je séche
Modifié en dernier par dje8269 le 21 Juin 2015 à 20:29, modifié 1 fois.
Mon Forum : Fantas-Pic
Mon theme actuel : Perso tiré de prosilver
Identifiant Test : test
Mdp : azerty
:!: Allez dans la zone de test en bas du forum !
dje8269
Roi des posts
Roi des posts
 
Messages: 987
Enregistré le: 23 Fév 2010 à 19:46

Re: Décalage sous IE

Messagepar dje8269 » 19 Juin 2015 à 18:58

Bonsoir ,

Personne n'as d'idée ?

est ce que remplacé tout mes dossiers par ma sauvegarde est une solution viable ?

Merci
Mon Forum : Fantas-Pic
Mon theme actuel : Perso tiré de prosilver
Identifiant Test : test
Mdp : azerty
:!: Allez dans la zone de test en bas du forum !
dje8269
Roi des posts
Roi des posts
 
Messages: 987
Enregistré le: 23 Fév 2010 à 19:46

Re: Décalage sous IE

Messagepar cabot » 19 Juin 2015 à 19:40

Hello,

Tu ne donnes aucune précision, c'est compliqué d'avoir une idée. :|

Quel est le problème d'affichage rencontré ?
Dans quelle circonstance ?
Quel message ou sujet ?
Image
Avatar de l’utilisateur
cabot
Equipe site
Equipe site
 
Messages: 26717
Enregistré le: 13 Fév 2011 à 19:42
Localisation: Rarement sur la plaque

Re: Décalage sous IE

Messagepar dje8269 » 19 Juin 2015 à 20:00

Je pensais qu'on pouvais voir les bugs . Au temps pour moi .

voici une image que ce soit sur IE9 ou IE8 .

Image

Quand on clic sur un post ou sur se connecter par exemple le décalage disparait et tout rentre dans l'ordre .
Quand on clic sur FAQ par exemple il reste .

Je sais pas trop quoi dire de plus .
Mon Forum : Fantas-Pic
Mon theme actuel : Perso tiré de prosilver
Identifiant Test : test
Mdp : azerty
:!: Allez dans la zone de test en bas du forum !
dje8269
Roi des posts
Roi des posts
 
Messages: 987
Enregistré le: 23 Fév 2010 à 19:46

Re: Décalage sous IE

Messagepar galixte » 19 Juin 2015 à 20:05

Oh ie8, ie9 c’est du passé… :mrgreen:
Communau EzCom
Image
« Traductions d’extensions & styles pour phpBB 3.1.x & 3.2.x ».
ImageListes de toutes les extensions recensées pour phpBB 3.1.x & 3.2.x.
ImageListes de tous les styles recensés pour phpBB 3.1.x & 3.2.x.
Avatar de l’utilisateur
galixte
Floodeur universel
Floodeur universel
 
Messages: 10068
Enregistré le: 08 Mar 2004 à 01:40
Localisation: Sud de la France.

Re: Décalage sous IE

Messagepar dje8269 » 19 Juin 2015 à 20:34

Lol, oui mais pas pour tout le monde. Je l'ai au travail, alors beaucoup d'autre personnes doivent l'avoir aussi , je ne peux pas les négligés à ce point
Mon Forum : Fantas-Pic
Mon theme actuel : Perso tiré de prosilver
Identifiant Test : test
Mdp : azerty
:!: Allez dans la zone de test en bas du forum !
dje8269
Roi des posts
Roi des posts
 
Messages: 987
Enregistré le: 23 Fév 2010 à 19:46

Re: Décalage sous IE

Messagepar cabot » 19 Juin 2015 à 21:07

Clairement, on se doit de continuer à apporter des solutions pour IE8 tant que le navigateur est toujours supporté par crosoft et utilisé par des particuliers ou des entreprises.

Je n'ai pas réussi à reproduire le bug donné en exemple sur ton screen, cela-dit j'ai testé avec le mode émulation de mon navigateur, du coup je ne pourrai que te conseiller de vider le cache du navigateur qui présente le problème.
Image
Avatar de l’utilisateur
cabot
Equipe site
Equipe site
 
Messages: 26717
Enregistré le: 13 Fév 2011 à 19:42
Localisation: Rarement sur la plaque

Re: Décalage sous IE

Messagepar dje8269 » 19 Juin 2015 à 21:09

D'accord je vais essayer

Rien n'y fait . ni sur I8 ni sur IE9 .
Mon Forum : Fantas-Pic
Mon theme actuel : Perso tiré de prosilver
Identifiant Test : test
Mdp : azerty
:!: Allez dans la zone de test en bas du forum !
dje8269
Roi des posts
Roi des posts
 
Messages: 987
Enregistré le: 23 Fév 2010 à 19:46

Re: Décalage sous IE

Messagepar cabot » 20 Juin 2015 à 09:29

Ok, je viens de recréer le problème.

La réponse est la même que celle donnée ici et qui a été ignorée :
Cela n'a rien à voir avec les modifications du style mais avec les paramètres d'affichage de compatibilité de ton navigateur.
Image
Avatar de l’utilisateur
cabot
Equipe site
Equipe site
 
Messages: 26717
Enregistré le: 13 Fév 2011 à 19:42
Localisation: Rarement sur la plaque

Re: Décalage sous IE

Messagepar dje8269 » 20 Juin 2015 à 09:52

J'avoue ne pas comprendre, ta réponse ! dois je déplacer le sujet ? j'ai appuyer sur le bouton affiche de compatibilité sans succes .
Le probléme est apparus suite des modifications je pense , avant sa fonctionnait bien .
Mon Forum : Fantas-Pic
Mon theme actuel : Perso tiré de prosilver
Identifiant Test : test
Mdp : azerty
:!: Allez dans la zone de test en bas du forum !
dje8269
Roi des posts
Roi des posts
 
Messages: 987
Enregistré le: 23 Fév 2010 à 19:46

Re: Décalage sous IE

Messagepar cabot » 20 Juin 2015 à 10:17

Ben écoute tu fais comme tu veux, perso je n'ai pas réussi à avoir le même affichage que celui de ton screen sauf en ajoutant ton site dans la liste de ceux à afficher en mode compatibilité. Donc tant que tu n'auras pas vérifié cette liste qui devrait être vide à moins que tu aies déniché des perles du web codés à la truelle et nécessitant ce mode, on n'avancera pas.
Image
Avatar de l’utilisateur
cabot
Equipe site
Equipe site
 
Messages: 26717
Enregistré le: 13 Fév 2011 à 19:42
Localisation: Rarement sur la plaque

Re: Décalage sous IE

Messagepar dje8269 » 20 Juin 2015 à 10:32

Ne t'enerve pas. Je comprends tout simplement pas , ce que tu veux que je fasse !
En vidant tout ce que j'ai trouvé a vider je suis tombé la dessus :
Image

La liste est vide, si c'est celle la dont tu parle .
Mon Forum : Fantas-Pic
Mon theme actuel : Perso tiré de prosilver
Identifiant Test : test
Mdp : azerty
:!: Allez dans la zone de test en bas du forum !
dje8269
Roi des posts
Roi des posts
 
Messages: 987
Enregistré le: 23 Fév 2010 à 19:46

Re: Décalage sous IE

Messagepar galixte » 20 Juin 2015 à 10:42

Salut,

en testant avec ieTester : http://www.my-debugbar.com/wiki/IETester/HomePage, j’obtiens le même affichage que djedje8269, pour ie8 et ie9.

Si j’utilise ie11 en activant l’outil de développement, et que j’active l’affichage pour ie8 et ie9, l’affichage est correct. Par contre en ie7 et ie5, surtout, cela ressemble au même affichage que djedje8269.

dje8269, tu devrais tester depuis ton travail cela aura plus de crédibilité que tous ces outils de simulations d’affichage.
Communau EzCom
Image
« Traductions d’extensions & styles pour phpBB 3.1.x & 3.2.x ».
ImageListes de toutes les extensions recensées pour phpBB 3.1.x & 3.2.x.
ImageListes de tous les styles recensés pour phpBB 3.1.x & 3.2.x.
Avatar de l’utilisateur
galixte
Floodeur universel
Floodeur universel
 
Messages: 10068
Enregistré le: 08 Mar 2004 à 01:40
Localisation: Sud de la France.

Re: Décalage sous IE

Messagepar cabot » 20 Juin 2015 à 10:48

On va tester un truc, ajoute ça dans le head :
Code: Tout sélectionner
<!--[if IE]>
<meta http-equiv="X-UA-Compatible" content="IE=edge" />
<![endif]-->


J'ai viré ieTester depuis un bout de temps car les outils de dev intégrés au nouvel IE me paraissaient suffisant, et du coup ça m'embêterait de devoir le réinstaller. :/
Image
Avatar de l’utilisateur
cabot
Equipe site
Equipe site
 
Messages: 26717
Enregistré le: 13 Fév 2011 à 19:42
Localisation: Rarement sur la plaque

Re: Décalage sous IE

Messagepar dje8269 » 20 Juin 2015 à 11:02

Je suis au travail ! :oops:

On va tester un truc, ajoute ça dans le head :

Code: Tout sélectionner
<!--[if IE]>
<meta http-equiv="X-UA-Compatible" content="IE=edge" />
<![endif]-->


J'ai donc mis ceci , dans le overall_header , vidé le cache , ca n'as pas bougé . J'ai vu qu'il manquait des petit traits sur le if et end if , j'ai essayé en les rajoutant car je sais pas si c'etait fais exprès , rien non plus .

Code: Tout sélectionner
<!--[if IE]-->
<meta http-equiv="X-UA-Compatible" content="IE=edge" />
<!--[endif]-->


Je trouve ca bizarre car , quand on rentre dans un sujet , l'affichage redevient normal sans probléme .
Mon Forum : Fantas-Pic
Mon theme actuel : Perso tiré de prosilver
Identifiant Test : test
Mdp : azerty
:!: Allez dans la zone de test en bas du forum !
dje8269
Roi des posts
Roi des posts
 
Messages: 987
Enregistré le: 23 Fév 2010 à 19:46

Suivante

Retourner vers [3.1.x] Modifications et recherche de styles

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 2 invités