[Réglé] Décalage sous IE

Pour les recherches et les demandes de modifications de styles concernant votre forum phpBB 3.1

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com - Conditions générales de support graphique

Attention : pour éviter les bogues, votre style doit être mis à jour en même temps que votre forum, et ce, dans la dernière version disponible de phpBB !

Re: Décalage sous IE

Messagepar cabot » 20 Juin 2015 à 12:05

Place le code que je t'ai indiqué dans le head, c'est à dire entre <head> et </head>.
Avatar de l’utilisateur
cabot
Equipe site
Equipe site
 
Messages: 26833
Enregistré le: 13 Fév 2011 à 20:42
Localisation: Rarement sur la plaque

Re: Décalage sous IE

Messagepar galixte » 20 Juin 2015 à 12:10

Sous ieTester ie9 plante une fois sur deux, tu aurais des script js ?
Communau EzCom
Image
« Traductions d’extensions & styles pour phpBB 3.1.x & 3.2.x ».
ImageListes de toutes les extensions recensées pour phpBB 3.1.x & 3.2.x.
ImageListes de tous les styles recensés pour phpBB 3.1.x & 3.2.x.

Image Tu as un forum et tu veux aussi un site web ? Regarde par ici.
Avatar de l’utilisateur
galixte
Floodeur universel
Floodeur universel
 
Messages: 10525
Enregistré le: 08 Mar 2004 à 02:40
Localisation: Sud de la France.

Re: Décalage sous IE

Messagepar cabot » 20 Juin 2015 à 12:19

Hmpfff, je viens de voir un truc...

Tu fais une redirection vers le forum #2 dans le fichier index_body.html, avant l'include du overall_header :
Code: Tout sélectionner
<!-- debut ################ script permettant de rediriger l'internaute ######### -->
<script type="text/javascript">
window.location = "http://www.fantaspic.fr/viewforum.php?f=2";
</script>
<!-- ############################################################################ -->

<!-- INCLUDE overall_header.html -->

Ce qui fait que le code est situé en dehors du document.

=> Commence par le placer dans le overall_header en le conditionnant avec <!-- IF S_INDEX -->, il y a de fortes chances que ça résolve le problème.
Avatar de l’utilisateur
cabot
Equipe site
Equipe site
 
Messages: 26833
Enregistré le: 13 Fév 2011 à 20:42
Localisation: Rarement sur la plaque

Re: Décalage sous IE

Messagepar dje8269 » 20 Juin 2015 à 12:40

=> Commence par le placer dans le overall_header en le conditionnant avec <!-- IF S_INDEX -->, il y a de fortes chances que ça résolve le problème.

Sorry mais j'ai pas compris ce que je dois faire . c'est la redirection que je dois placée dans les conditions , ou le bout de code que tu m's donné ?

tu aurais des script js

Je sais pas
Mon Forum : Fantas-Pic
Mon theme actuel : Perso tiré de prosilver
Identifiant Test : test
Mdp : azerty
:!: Allez dans la zone de test en bas du forum !
dje8269
Empereur des posts
Empereur des posts
 
Messages: 1000
Enregistré le: 23 Fév 2010 à 20:46

Re: Décalage sous IE

Messagepar cabot » 20 Juin 2015 à 12:47

La redirection, puisque tu as placé ce bout de code en dehors du document...

La portion de code que je t'ai indiqué ne fait qu'interdire le mode compatibilité sous IE.
Avatar de l’utilisateur
cabot
Equipe site
Equipe site
 
Messages: 26833
Enregistré le: 13 Fév 2011 à 20:42
Localisation: Rarement sur la plaque

Re: Décalage sous IE

Messagepar dje8269 » 20 Juin 2015 à 13:04

Voila .

J'ai changé dans index_body.html

Code: Tout sélectionner
<!-- IF S_INDEX -->
<!-- debut ################ script permettant de rediriger l'internaute ######### -->
<script type="text/javascript">
window.location = "http://www.fantaspic.fr/viewforum.php?f=2";
</script>
<!-- ############################################################################ -->
<!-- ENDIF -->


Dans overall_header.html j'ai :

Code: Tout sélectionner
<head>

<!--[if IE]>
<meta http-equiv="X-UA-Compatible" content="IE=edge" />
<![endif]-->
.......
.......
.......
</head>


J'ai vider le cache dans le PCA , et celui du navigateur sans succes
Mon Forum : Fantas-Pic
Mon theme actuel : Perso tiré de prosilver
Identifiant Test : test
Mdp : azerty
:!: Allez dans la zone de test en bas du forum !
dje8269
Empereur des posts
Empereur des posts
 
Messages: 1000
Enregistré le: 23 Fév 2010 à 20:46

Re: Décalage sous IE

Messagepar cabot » 20 Juin 2015 à 13:13

Mais non ! Inutile de mettre cette condition dans index_body puisqu'elle conditionne justement le fait que ce soir l'index qui est appelé. ^^

Il faut virer ce code de redirection du fichier, surtout que l'as placé avant l'include du overall_header, ça veut dire qu'il est interprété avant le doctype, il ne peut pas y avoir de html avant ce doctype et c'est très certainement la cause du problème.

Supprime cette redirection du fichier, place-la dans overall_header.html et supprime aussi la méta puisqu'elle ne servira à rien.
Avatar de l’utilisateur
cabot
Equipe site
Equipe site
 
Messages: 26833
Enregistré le: 13 Fév 2011 à 20:42
Localisation: Rarement sur la plaque

Re: Décalage sous IE

Messagepar dje8269 » 20 Juin 2015 à 13:32

J'en suis rendu donc ici :

dans le fichier index_body.html , y'as plus de modif . sauf la redirection qui a été supprimée .

dans le fichier overall_header.html on retrouve seulement notre re-direction :



Code: Tout sélectionner
<head>

<!-- IF S_INDEX -->
<!-- debut ################ script permettant de rediriger l'internaute ######### -->
<script type="text/javascript">
window.location = "http://www.fantaspic.fr/viewforum.php?f=2";
</script>
<!-- ############################################################################ -->
<!-- ENDIF -->
...
...
</head>


Rien .... après avoir vidé le cache de tout , je remarque que le texte "Acces rapide" apparait furtivement avant de disparaitre genre 1 secondes après . Si ca peut aider ;

cette histoire de redirection à toujours présente bien avant le problème ( si ca peut aider)
Mon Forum : Fantas-Pic
Mon theme actuel : Perso tiré de prosilver
Identifiant Test : test
Mdp : azerty
:!: Allez dans la zone de test en bas du forum !
dje8269
Empereur des posts
Empereur des posts
 
Messages: 1000
Enregistré le: 23 Fév 2010 à 20:46

Re: Décalage sous IE

Messagepar cabot » 20 Juin 2015 à 13:56

Deux choses :

  1. Il semblerait qu'il y ait un caractère non attendu avant la déclaration du doctype, peut-être un pb d'encodage car on ne voit rien dans le fichier.
    Remplace :
    Code: Tout sélectionner
    <!DOCTYPE html>
    
    <html dir="{S_CONTENT_DIRECTION}" lang="{S_USER_LANG}">
    <head>
    
    <!-- IF S_INDEX -->
    <!-- debut ################ script permettant de rediriger l'internaute ######### -->
    <script type="text/javascript">
    window.location = "http://www.fantaspic.fr/viewforum.php?f=2";
    </script>
    <!-- ############################################################################ -->
    <!-- ENDIF -->
    
    
    <meta charset="utf-8" />

    Par :
    Code: Tout sélectionner
    <!DOCTYPE html>
    <html dir="{S_CONTENT_DIRECTION}" lang="{S_USER_LANG}">
    <head>
    <meta charset="utf-8" />

  2. Il est préférable de déplacer le script de redirection plus bas dans le head.
    Trouve :
    Code: Tout sélectionner
    </head>

    Ajoute avant :
    Code: Tout sélectionner
    <!-- IF S_INDEX -->
    <script type="text/javascript">
    window.location = "http://www.fantaspic.fr/viewforum.php?f=2";
    </script>
    <!-- ENDIF -->
Avatar de l’utilisateur
cabot
Equipe site
Equipe site
 
Messages: 26833
Enregistré le: 13 Fév 2011 à 20:42
Localisation: Rarement sur la plaque

Re: Décalage sous IE

Messagepar dje8269 » 20 Juin 2015 à 14:13

Fichier transféré , toujours rien . c'est un truc de fou . caches vidés aussi

je remarque aussi que le logo du forum, est décalé un peu en bas , il y a un espace . Si ca peut aider ;
Mon Forum : Fantas-Pic
Mon theme actuel : Perso tiré de prosilver
Identifiant Test : test
Mdp : azerty
:!: Allez dans la zone de test en bas du forum !
dje8269
Empereur des posts
Empereur des posts
 
Messages: 1000
Enregistré le: 23 Fév 2010 à 20:46

Re: Décalage sous IE

Messagepar cabot » 20 Juin 2015 à 15:16

Le problème est toujours présent, utilise un fichier neuf et fais tes reports de modifs dedans.
Avatar de l’utilisateur
cabot
Equipe site
Equipe site
 
Messages: 26833
Enregistré le: 13 Fév 2011 à 20:42
Localisation: Rarement sur la plaque

Re: Décalage sous IE

Messagepar dje8269 » 20 Juin 2015 à 15:43

olalalalla . je met tout le style d'origine et je remplace les fichiers un à un c'est bien ca ?

Allez c'est partis
Mon Forum : Fantas-Pic
Mon theme actuel : Perso tiré de prosilver
Identifiant Test : test
Mdp : azerty
:!: Allez dans la zone de test en bas du forum !
dje8269
Empereur des posts
Empereur des posts
 
Messages: 1000
Enregistré le: 23 Fév 2010 à 20:46

Re: Décalage sous IE

Messagepar dje8269 » 20 Juin 2015 à 15:51

Je crois que j'ai du faire une connerie chef !

Aprés avoir virer tout les templates que j'avais modifiés et mis dans mon style electronique . le probléme est encore présent .

Je me souviens avoir bidouiller des truc hors templates genre des dossiers a la racine , sans le noter quelques part , en pensant que je n'aurais jamais a les changer ; Impossible de me souvenir lequels .

PS ; j'ai désactiver les extension installées au passage ;
Mon Forum : Fantas-Pic
Mon theme actuel : Perso tiré de prosilver
Identifiant Test : test
Mdp : azerty
:!: Allez dans la zone de test en bas du forum !
dje8269
Empereur des posts
Empereur des posts
 
Messages: 1000
Enregistré le: 23 Fév 2010 à 20:46

Re: Décalage sous IE

Messagepar Manard » 20 Juin 2015 à 15:59

Bonjour,


J'espère que tu auras fait une sauvegarde avant de tout effacer... Sinon tu vas pouvoir éplucher tous les posts que tu as faits pour tout reprendre.

Bonne après-midi et bon courage, mais pas de précipitation.

Bernard
Manard
Empereur des posts
Empereur des posts
 
Messages: 1015
Enregistré le: 31 Mar 2012 à 09:24

Re: Décalage sous IE

Messagepar cabot » 20 Juin 2015 à 16:00

Si tu ne sais pas ce que tu as modifié dans le php, c'est pas moi qui vais pouvoir te le dire. :wink:

=> remplace les fichiers php par des neufs dans la même version.
Avatar de l’utilisateur
cabot
Equipe site
Equipe site
 
Messages: 26833
Enregistré le: 13 Fév 2011 à 20:42
Localisation: Rarement sur la plaque

PrécédenteSuivante

Retourner vers [3.1.x] Modifications et recherche de styles

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité