Extension phpbbgallery - mise à niveau de la base de données.

Support pour n'importe quelle extension non présente dans notre base de données
Aucune demande de personnalisation des extensions n'est autorisée.

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com - Conditions générales de support des extensions de phpBB-fr.com

Merci de mettre le nom de l'extension ainsi que sa version entre crochets, et un titre explicite afin de faciliter la recherche.
Exemple : [nom de l'extension + numéro de version] Titre explicite résumant le problème

Le lien de téléchargement de l'extension est demandé pour toute demande de support.

Aucune demande de personnalisation des extensions n'est autorisée.

Re: Extension phpbbgallery - mise à niveau de la base de données.

Messagepar jcg11 » 09 Mar 2019 à 11:44

Bonjour,

J'avais oublié de signaler ces erreurs lors de la MaJ ou la conversion de 1.0.4 => 1.0.6 (en réalité V1.0.5 ??)

Mise à Jour

Code: Tout sélectionner
FOUNDER_NEEDED

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/install/install_update.php
LINE: 55
CALL: trigger_error()

FILE: [ROOT]/install/index.php
LINE: 186
CALL: install_update->main()

FILE: [ROOT]/install/index.php
LINE: 58
CALL: module->load()

Convertir phpBB2
Code: Tout sélectionner
FOUNDER_NEEDED

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/install/install_convert.php
LINE: 58
CALL: trigger_error()

FILE: [ROOT]/install/index.php
LINE: 186
CALL: install_convert->main()

FILE: [ROOT]/install/index.php
LINE: 58
CALL: module->load()


Convertir TS Gallery
Code: Tout sélectionner
Erreur générale
FOUNDER_NEEDED

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/install/install_convert_ts.php
LINE: 56
CALL: trigger_error()

FILE: [ROOT]/install/index.php
LINE: 186
CALL: install_convert_ts->main()

FILE: [ROOT]/install/index.php
LINE: 58
CALL: module->load()


:wink:
PHPBB V3.2.5 - PHP Version 7.2.15 - Hébergé chez 1And1
jcg11
Apprenti-posteur
Apprenti-posteur
 
Messages: 134
Enregistré le: 07 Déc 2004 à 16:41
Localisation: Carcassonne(11)

Re: Extension phpbbgallery - mise à niveau de la base de données.

Messagepar jcg11 » 15 Mar 2019 à 17:41

Bonjour,

Un petit UP au cas où..

Merci.
:wink:
PHPBB V3.2.5 - PHP Version 7.2.15 - Hébergé chez 1And1
jcg11
Apprenti-posteur
Apprenti-posteur
 
Messages: 134
Enregistré le: 07 Déc 2004 à 16:41
Localisation: Carcassonne(11)

Re: Extension phpbbgallery - mise à niveau de la base de données.

Messagepar jcg11 » 11 Avr 2019 à 15:23

Bonjour,

Un petit UP au cas où..

Merci.
:wink:
PHPBB V3.2.5 - PHP Version 7.2.15 - Hébergé chez 1And1
jcg11
Apprenti-posteur
Apprenti-posteur
 
Messages: 134
Enregistré le: 07 Déc 2004 à 16:41
Localisation: Carcassonne(11)

Re: Extension phpbbgallery - mise à niveau de la base de données.

Messagepar jcg11 » 18 Mai 2019 à 19:13

Bonjour,

Un petit UP au cas où..

Merci.
:wink:
PHPBB V3.2.5 - PHP Version 7.2.15 - Hébergé chez 1And1
jcg11
Apprenti-posteur
Apprenti-posteur
 
Messages: 134
Enregistré le: 07 Déc 2004 à 16:41
Localisation: Carcassonne(11)

Re: Extension phpbbgallery - mise à niveau de la base de données.

Messagepar galixte » 20 Mai 2019 à 02:21

Salut,

tu as raison la version annoncée comme 1.0.6 n’est en fait que la version 1.0.5.1.

En fouillant sur le dépôt de fichiers GitHub, je pense enfin l’avoir trouvé cette version 1.0.6 : https://github.com/phpbbgallery/phpbb-g ... p-jack.zip.

Ah oui, c’est bien « Mise à jour » qui faut choisir, « CONVERT » ça effectue l’installation/la mise à jour + une conversion et c’est uniquement à faire lorsque l’on vient de phpBB2 ou de TS Gallery.

Bonne chance.
Communau EzCom
Image
« Traductions d’extensions & styles pour phpBB 3.1.x & 3.2.x ».
ImageListes de toutes les extensions recensées pour phpBB 3.1.x & 3.2.x.
ImageListes de tous les styles recensés pour phpBB 3.1.x & 3.2.x.

Image Tu as un forum et tu veux aussi un site web ? Regarde par ici.
Avatar de l’utilisateur
galixte
Floodeur universel
Floodeur universel
 
Messages: 10525
Enregistré le: 08 Mar 2004 à 02:40
Localisation: Sud de la France.

Re: Extension phpbbgallery - mise à niveau de la base de données.

Messagepar jcg11 » 22 Mai 2019 à 15:59

Salut,

J'ai bien téléchargé et installé la version 1.0.6 avec des difficultés, "AutoMod" refusait l'installation car "PhpBB Gallery" était déjà installé en version 1.0.5.1. Il a fallu que je supprime cette version pour pouvoir installer la version 1.0.6.

J'ai tenté de passer à la version 1.1.8, "AutoMod" me faisait le même coup, après, je ne sais ce que j'ai bricolé, plus rien ne fonctionnait dans la galerie, plus de photos.

J'ai restauré les anciens fichiers et je vais recommencer à zéro.

Merci pour l'aide.
:wink:
PHPBB V3.2.5 - PHP Version 7.2.15 - Hébergé chez 1And1
jcg11
Apprenti-posteur
Apprenti-posteur
 
Messages: 134
Enregistré le: 07 Déc 2004 à 16:41
Localisation: Carcassonne(11)

Re: Extension phpbbgallery - mise à niveau de la base de données.

Messagepar galixte » 23 Mai 2019 à 04:13

Oui mieux vaut repartir de la 1.0.4.
Communau EzCom
Image
« Traductions d’extensions & styles pour phpBB 3.1.x & 3.2.x ».
ImageListes de toutes les extensions recensées pour phpBB 3.1.x & 3.2.x.
ImageListes de tous les styles recensés pour phpBB 3.1.x & 3.2.x.

Image Tu as un forum et tu veux aussi un site web ? Regarde par ici.
Avatar de l’utilisateur
galixte
Floodeur universel
Floodeur universel
 
Messages: 10525
Enregistré le: 08 Mar 2004 à 02:40
Localisation: Sud de la France.

Re: Extension phpbbgallery - mise à niveau de la base de données.

Messagepar jcg11 » 23 Mai 2019 à 11:17

Salut,

L'installation de la version 1.0.6 c'est bien passée. A priori, tout fonctionne.

J'ai voulu faire l'installation de la 1.1.8 et "AutoMOD" me signale
Informations
AutoMOD a détecté que ce MOD est déjà installé et ne peut pas continuer.

Il s'agit de "PhpBB Gallery"

Comment passer outre :?:

:wink:
PHPBB V3.2.5 - PHP Version 7.2.15 - Hébergé chez 1And1
jcg11
Apprenti-posteur
Apprenti-posteur
 
Messages: 134
Enregistré le: 07 Déc 2004 à 16:41
Localisation: Carcassonne(11)

Re: Extension phpbbgallery - mise à niveau de la base de données.

Messagepar galixte » 24 Mai 2019 à 03:08

Salut,

pourquoi veux-tu installer la version 1.1.8 ? Tu dois mettre à jour la version 1.0.4 vers la version 1.0.6 puis mettre à jour la version 1.0.6 vers la version 1.1.8.
Communau EzCom
Image
« Traductions d’extensions & styles pour phpBB 3.1.x & 3.2.x ».
ImageListes de toutes les extensions recensées pour phpBB 3.1.x & 3.2.x.
ImageListes de tous les styles recensés pour phpBB 3.1.x & 3.2.x.

Image Tu as un forum et tu veux aussi un site web ? Regarde par ici.
Avatar de l’utilisateur
galixte
Floodeur universel
Floodeur universel
 
Messages: 10525
Enregistré le: 08 Mar 2004 à 02:40
Localisation: Sud de la France.

Re: Extension phpbbgallery - mise à niveau de la base de données.

Messagepar jcg11 » 24 Mai 2019 à 10:57

Hello,

La version 1.0.4 est mis à jour vers la version 1.0.6. Là, c'est OK

Pour faire la conversion vers 1.1.8, il faut quand même mettre les fichiers qui vont servir à cette conversion ??? C'est pour cela que je voulais installer cette version. Sinon, je ne vois comment faire ???

:wink:
PHPBB V3.2.5 - PHP Version 7.2.15 - Hébergé chez 1And1
jcg11
Apprenti-posteur
Apprenti-posteur
 
Messages: 134
Enregistré le: 07 Déc 2004 à 16:41
Localisation: Carcassonne(11)

Re: Extension phpbbgallery - mise à niveau de la base de données.

Messagepar galixte » 24 Mai 2019 à 11:10

Il me parait clair que ce n’est pas une conversion mais une mise à jour du MOD aussi AutoMod se charge de l’effectuer donc il ne devrait pas y avoir de manipulation manuel des fichiers.
Modifié en dernier par galixte le 24 Mai 2019 à 19:22, modifié 1 fois.
Communau EzCom
Image
« Traductions d’extensions & styles pour phpBB 3.1.x & 3.2.x ».
ImageListes de toutes les extensions recensées pour phpBB 3.1.x & 3.2.x.
ImageListes de tous les styles recensés pour phpBB 3.1.x & 3.2.x.

Image Tu as un forum et tu veux aussi un site web ? Regarde par ici.
Avatar de l’utilisateur
galixte
Floodeur universel
Floodeur universel
 
Messages: 10525
Enregistré le: 08 Mar 2004 à 02:40
Localisation: Sud de la France.

Re: Extension phpbbgallery - mise à niveau de la base de données.

Messagepar jcg11 » 24 Mai 2019 à 17:40

Re,

Suis désolé, mais je ne comprends pas ce qu'il faut faire car je n'ai aucune option pour mettre à niveau avec "AutoMOD"
Version de la galerie installée 1.0.6

Image

Dans "AutoMOD", je sélectionne le fichier phpbb_gallery_1_1_8.zip

Image

Ensuite j’effectue le transfert pour arriver sur la page d'installation et non de mise à niveau

Image

N'ayant pas d'autres solution, je clique sur "Installer" et là il bloque et toujours pas de possibilité de mettre à niveau.

Image

A noter que dans le répertoire .\store\mods\
J'ai bien le mode .\store\mods\phpbb_gallery_1_1_8\

A partir de là, je suis tout à fait bloqué.

Encore merci pour l'aide.
:wink:
PHPBB V3.2.5 - PHP Version 7.2.15 - Hébergé chez 1And1
jcg11
Apprenti-posteur
Apprenti-posteur
 
Messages: 134
Enregistré le: 07 Déc 2004 à 16:41
Localisation: Carcassonne(11)

Re: Extension phpbbgallery - mise à niveau de la base de données.

Messagepar galixte » 24 Mai 2019 à 23:04

J’ai tenté de reproduire ton problème, dans les grandes lignes :
  1. je suis parti en local sous PHP 5.3.25 d’un forum phpBB 3.0.8 (que je nommerai A) car adapté à phpBB Gallery 1.0.6.
    1. j’ai supprimé le répertoire ./install./,
    2. j’ai donc installé AutoMod 1.0.2 + traduction FR,
    3. j’ai supprimé le répertoire ./install./,
    4. j’ai installé phpBB Gallery 1.0.6 (puisque tu parviens à mettre à jour vers cette version, inutile donc de partir d’une version plus ancienne),
    5. j’ai supprimé le répertoire ./install./,
    6. j’ai ajusté les permissions, créé un album envoyé des photos dedans,
    7. j’ai mis à jour ce forum phpBB 3.0.8 vers phpBB 3.0.10 au moyen de cette archive : https://ftp.phpbb-fr.com/public/traduct ... .10_FR.zip en mode fusion des fichiers, pas de problème constaté,
    8. j’ai supprimé le répertoire ./install./ ;
  2. en parallèle, toujours en local sous PHP 5.3.25, j’ai installé un autre forum (nommé B) phpBB 3.0.10,
    1. suivi d’AutoMod 1.0.2 + trad FR,
    2. j’ai supprimé le répertoire ./install./,
    3. puis de phpBB Gallery 1.1.6 + trad FR ;
    4. je n’ai pas supprimé le répertoire ./install./ ;
    5. j’ai supprimé le contenu du répertoire ./cache/ sauf ./cache/.htaccess et ./cache/index.htm ;
  3. j’ai copié tout le contenu du forum B dans le forum A sauf ./config.php ;
  4. je me suis rendu à l’adresse http://domain.tld/forumA/install/ du forum A, onglet « Mise à jour », pour effectuer la mise à jour de la version 1.0.6 vers 1.1.6 de phpBB Gallery du forum A. Il te proposera de supprimer des fichiers devenus inutiles, n’hésite pas à effectuer cette tâche ;
  5. dans le PCA du forum A onglet « AUTOMOD » j’ai installé la traduction de phpBB Gallery 1.1.6 FR ;
  6. purge du cache et c’est tout bon.
Modifié en dernier par galixte le 28 Mai 2019 à 20:17, modifié 3 fois.
Communau EzCom
Image
« Traductions d’extensions & styles pour phpBB 3.1.x & 3.2.x ».
ImageListes de toutes les extensions recensées pour phpBB 3.1.x & 3.2.x.
ImageListes de tous les styles recensés pour phpBB 3.1.x & 3.2.x.

Image Tu as un forum et tu veux aussi un site web ? Regarde par ici.
Avatar de l’utilisateur
galixte
Floodeur universel
Floodeur universel
 
Messages: 10525
Enregistré le: 08 Mar 2004 à 02:40
Localisation: Sud de la France.

Re: Extension phpbbgallery - mise à niveau de la base de données.

Messagepar jcg11 » 25 Mai 2019 à 15:12

Salut,

Voilà ce que j'ai sur le forum que j'appellerai aussi Forum A

PHP Version 5.6.25 - Version du forum: 3.0.14 - phpBB Gallery Version 1.0.6 ce qui est semblable à ton Forum A à part la version.
(Pour rappel: Il reste toujours des restes de PhpBB SEO mais qui n'ont aucune incidence)

Maintenant, comment dois-je créer un Forum B ? Doit-il être vierge (nouvelle installation) ou est-ce une copie du Forum A ?


Merci.
:wink:
PHPBB V3.2.5 - PHP Version 7.2.15 - Hébergé chez 1And1
jcg11
Apprenti-posteur
Apprenti-posteur
 
Messages: 134
Enregistré le: 07 Déc 2004 à 16:41
Localisation: Carcassonne(11)

Re: Extension phpbbgallery - mise à niveau de la base de données.

Messagepar galixte » 26 Mai 2019 à 04:53

Le forum B est vierge oui, c’est une nouvelle installation.

Comme tu peux le voir dans ma démarche il sert juste à récupérer les fichiers modifiés de phpBB contenant le MOD phpBB Gallery v1.1.6 afin de les copier dans le forum A pour n’avoir qu’à effectuer la mise à jour de la version 1.0.6 vers 1.1.6 afin que les tables de ce MOD soient à jour et qu’enfin tu puisses les convertir par la suite avec l’extension de même nom lorsque ton forum tournera sous phpBB 3.2.x.

Si tu ne fais pas cette démarche tu vas devoir appliquer manuellement les mises à jour du MOD phpBB Gallery 1.0.6 vers 1.1.0 puis 1.1.0 ver 1.1.1 etc. ce qui est beaucoup plus long et n’est pas sans risque de générer des erreurs du fait que cela s’effectue manuellement, telles que : TROUVER, APRÈS, AJOUTER, TROUVER, REMPLACER PAR, etc. c’est fastidieux. ;)
Communau EzCom
Image
« Traductions d’extensions & styles pour phpBB 3.1.x & 3.2.x ».
ImageListes de toutes les extensions recensées pour phpBB 3.1.x & 3.2.x.
ImageListes de tous les styles recensés pour phpBB 3.1.x & 3.2.x.

Image Tu as un forum et tu veux aussi un site web ? Regarde par ici.
Avatar de l’utilisateur
galixte
Floodeur universel
Floodeur universel
 
Messages: 10525
Enregistré le: 08 Mar 2004 à 02:40
Localisation: Sud de la France.

PrécédenteSuivante

Retourner vers Support des extensions non présentes dans notre base de données

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité