[Sujets Récents pour JS 1.0.1] Affichage correct en local - ne s'affiche pas en ligne

Support pour n'importe quelle extension non présente dans notre base de données
Aucune demande de personnalisation des extensions n'est autorisée.

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com - Conditions générales de support des extensions de phpBB-fr.com

Merci de mettre le nom de l'extension ainsi que sa version entre crochets, et un titre explicite afin de faciliter la recherche.
Exemple : [nom de l'extension + numéro de version] Titre explicite résumant le problème

Le lien de téléchargement de l'extension est demandé pour toute demande de support.

Aucune demande de personnalisation des extensions n'est autorisée.
Partager sur FacebookPartager sur TwitterPartager sur Google+

[Sujets Récents pour JS 1.0.1] Affichage correct en local - ne s'affiche pas en ligne

Messagepar lady Marmotte » 19 Sep 2015 à 13:53

Bien le bonjour !

Je viens ici, comme vous vous en doutez, pour un conseil ou une idée qui, visiblement, m'échappe. Je ne suis - de loin pas - très avancée en php, niveau compréhension de base dirais-je, si ça se trouve c'est quelque chose de très bête (pour vous). Je vous expose le cas, après avoir testé par moi-même tout ce que je pouvais avoir comme idée :

Mon site est celui-ci.
Mon forum est celui-ci, en version 3.1.3 (oui je sais, il faut que je fasse la MAJ, c'est prévu sous peu).
L'extension est là-bas.
Le forum du support créateur est là (en russe, sinon j'aurais posté là bas mais... le russe et moi, ce n'est pas encore ça, navrée :s).

J'ai donc installé l'extension qui affiche les derniers sujets postés en en tête de forum, de base, mais surtout qui permet avec un javascript, de l'afficher également sur une page externe (la seule chose qui m'intéresse, vous ne verrez pas l'extension affichée sur le forum).

J'ai donc installé le MOD correctement, puis ajouté le code sur mon site en page d'index dans la colonne des news de droite, ici en local depuis mon forum en local également, ce qui fonctionne à la perfection :

Code: Tout sélectionner
      <div class="info_index">
        <p>Les 3 derniers posts du forum :
<script type="text/javascript" src="http://localhost/baeforum/app.php/recent.php"></script>
</p>
      </div>

Visuellement, après un peu de mise en page, ça donne ça :
Image

Hors, sans rien changer au code nul part, extension installée sur mon forum en ligne avec les mêmes options admin qu'en local, le site identique à la virgule près, lorsque j'insère le code en ligne cela ne m'affiche rien. Pourtant, le MOD fonctionne sur le forum sans aucun soucis et si j'ouvre le lien des derniers sujets, ils sont présents mais le site ne les importe pas on dirait :
Code: Tout sélectionner
      <div class="info_index">
        <p>Les 3 derniers posts du forum :
<script type="text/javascript" src="http://www.apresleclipse.net/baeforum/app.php/recent.php">
</p>
      </div>

Je précise encore que j'ai fais le test avec une nouvelle page vierge de tout autre code que le minimum vital et le résultat est identique, le lien local fonctionne, celui en ligne, non. Que la page soie elle même en local ou en ligne.

Enfin, j'ai testé l'extension Récent Topic de votre base de donnée, mais elle n'a pas d'option externe. A ma connaissance actuellement, Sujets récents pour JS est la seule que j'ai trouvé.

Je crois avoir donnés toutes les infos que j'ai, si cela est incomplet ou incorrect, je m'en excuse par avance, et vous remercie pour avoir lu :)
lady Marmotte
Posteur néophyte
Posteur néophyte
 
Messages: 17
Enregistré le: 07 Fév 2006 à 00:53

Re: [Sujets Récents pour JS 1.0.1] Affichage correct en local - ne s'affiche pas en ligne

Messagepar Zoddo » 19 Sep 2015 à 14:31

Bonjour,

Est-ce qu'une erreur s'affiche dans la console du navigateur ? (accessible en tapant F12)
[Doc] Installer une extension - [Extension] Post Models - [Recrutement] Équipe des Extensions
Si vous considérez votre requête comme résolue, merci d'ajouter l'attribut de sujet [Réglé]
Zoddo
Resp. Extensions
Resp. Extensions
 
Messages: 5790
Enregistré le: 16 Mar 2011 à 17:44
Localisation: /root/

Re: [Sujets Récents pour JS 1.0.1] Affichage correct en local - ne s'affiche pas en ligne

Messagepar galixte » 19 Sep 2015 à 18:46

Salut,

est-il possible qu’en indiquant le chemin relatif cela fonctionne ?
Code: Tout sélectionner
      <div class="info_index">
        <p>Les 3 derniers posts du forum :
<script type="text/javascript" src=./baeforum/app.php/recent.php">
</p>
      </div>
Voire en activant la réécriture des URL (URL rewriting) dans le PCA, onglet GÉNÉRAL, « paramètres du serveur », aussi le code serait :
Code: Tout sélectionner
      <div class="info_index">
        <p>Les 3 derniers posts du forum :
<script type="text/javascript" src=./baeforum/recent.php">
</p>
      </div>
Communau EzCom
Image
« Traductions d’extensions & styles pour phpBB 3.1.x & 3.2.x ».
ImageListes de toutes les extensions recensées pour phpBB 3.1.x & 3.2.x.
ImageListes de tous les styles recensés pour phpBB 3.1.x & 3.2.x.
Avatar de l’utilisateur
galixte
Floodeur universel
Floodeur universel
 
Messages: 9883
Enregistré le: 08 Mar 2004 à 01:40
Localisation: Sud de la France.

Re: [Sujets Récents pour JS 1.0.1] Affichage correct en local - ne s'affiche pas en ligne

Messagepar lady Marmotte » 20 Sep 2015 à 13:52

Bien le bonjour et merci pour vos réflexions !

1° Le chemin relatif ne change rien visiblement, je viens de tester l'exemple avec la réécriture de l'url complète et l'option activée dans le PCA, j'avais aussi testé avec le chemin sans la page app.php dans l'adresse (j'ignore d'ailleurs son utilité, puisque cela fonctionne sans en local, mais l'extension me donne l'adresse ainsi)

2° Pour ce qui est des erreurs, j'ai eu du mal à trouver (mes divers scripts "tout faits" en page d'index ayant une quantité de remarques), en faisant une page dédiée avec uniquement le script des derniers sujets du forum cela m'indique effectivement quelque chose que je vous rapporte ici, je n'arrive pas à décrypter par contre :s

Depuis la page : http://www.apresleclipse.net/Sanstitre-2.php
Code: Tout sélectionner
GET http://www.apresleclipse.net/Sanstitre-2.php [HTTP/1.1 200 OK 40ms]
GET http://www.apresleclipse.net/baeforum/recent.php [HTTP/1.1 200 OK 160ms]
SyntaxError: missing ) after argument

Et si je suis le lien de l'erreur de syntaxe cela me renvoie à mes derniers sujets, soit une erreur en bas de page :
document.writeln('<ul class="recent">\n');
document.writeln('<li class="title"><a href="http://www.apresleclipse.net/baeforum/viewtopic.php?t=5331">Nouvelle version du site, c'est officiel !</a> [<a href="http://www.apresleclipse.net/baeforum/viewtopic.php?p=15918#15918">8</a>]</li>\n');
document.writeln('<li class="content">Comme vous l\'aurez (peut-être !) vu (ou pas!), la toute nouvelle version du site (aussi nommée V3) est en ligne ! Je vous invite à aller jeter un oeil&hellip;\n');
document.writeln('</li>\n');
document.writeln('<li class="title"><a href="http://www.apresleclipse.net/baeforum/viewtopic.php?t=192">la fin d'un rève</a> [<a href="http://www.apresleclipse.net/baeforum/viewtopic.php?p=15917#15917">43</a>]</li>\n');
document.writeln('<li class="content">Voilà je créé ce topic pour une simple question.<br />Que se passera t\'il à l\'avènement du rêve de Griffith ?<br />Il atteindra son rêve, c\'est une chose pratiq&hellip;\n');
document.writeln('</li>\n');
document.writeln('<li class="title"><a href="http://www.apresleclipse.net/baeforum/viewtopic.php?t=5334">Scan ? Ou en sont ils ?</a></li>\n');
document.writeln('<li class="content">Ils en sont ou dans les scan ?<br /> Le dernier que j\'ai vu c\'est sur japscan! <br />Y\'en a d\'autre ? Si oui pour quand ? Venez pv si vous voulez parler <!-- s&hellip;\n');
document.writeln('</li>\n');
document.writeln('</ul>\n');

lady Marmotte
Posteur néophyte
Posteur néophyte
 
Messages: 17
Enregistré le: 07 Fév 2006 à 00:53

Re: [Sujets Récents pour JS 1.0.1] Affichage correct en local - ne s'affiche pas en ligne

Messagepar herpo44 » 25 Sep 2015 à 15:25

Salut, je me permet un message malgré mon niveau moins élevé que vous mais j'avais eu un souci de non affichage avec récent topic et personne n'avait su m'aider...
Finalement il s'agissait tout simplement des permission à régler dans "permission des groupe"...
Jettes y un œil au cas où ;)
Avatar de l’utilisateur
herpo44
Posteur habitué
Posteur habitué
 
Messages: 272
Enregistré le: 29 Juin 2012 à 16:43

Re: [Sujets Récents pour JS 1.0.1] Affichage correct en local - ne s'affiche pas en ligne

Messagepar galixte » 25 Sep 2015 à 19:55

Salut,

Recent Topics et Recents Topic JS ne sont pas les mêmes extensions. ;)
Communau EzCom
Image
« Traductions d’extensions & styles pour phpBB 3.1.x & 3.2.x ».
ImageListes de toutes les extensions recensées pour phpBB 3.1.x & 3.2.x.
ImageListes de tous les styles recensés pour phpBB 3.1.x & 3.2.x.
Avatar de l’utilisateur
galixte
Floodeur universel
Floodeur universel
 
Messages: 9883
Enregistré le: 08 Mar 2004 à 01:40
Localisation: Sud de la France.

Re: [Sujets Récents pour JS 1.0.1] Affichage correct en local - ne s'affiche pas en ligne

Messagepar herpo44 » 25 Sep 2015 à 23:03

oui mais l'erreur aurait pu etre la même...
C'est pour faire avancer le shimilibilick :mrgreen:
Avatar de l’utilisateur
herpo44
Posteur habitué
Posteur habitué
 
Messages: 272
Enregistré le: 29 Juin 2012 à 16:43

Re: [Sujets Récents pour JS 1.0.1] Affichage correct en local - ne s'affiche pas en ligne

Messagepar galixte » 25 Sep 2015 à 23:23

je comprends bien ta démarche, mais il n’y a pas de permission pour cette extension. ;)
Communau EzCom
Image
« Traductions d’extensions & styles pour phpBB 3.1.x & 3.2.x ».
ImageListes de toutes les extensions recensées pour phpBB 3.1.x & 3.2.x.
ImageListes de tous les styles recensés pour phpBB 3.1.x & 3.2.x.
Avatar de l’utilisateur
galixte
Floodeur universel
Floodeur universel
 
Messages: 9883
Enregistré le: 08 Mar 2004 à 01:40
Localisation: Sud de la France.

Re: [Sujets Récents pour JS 1.0.1] Affichage correct en local - ne s'affiche pas en ligne

Messagepar herpo44 » 26 Sep 2015 à 08:14

Dans recent topic non plus d'ailleurs, j'ai dit des conneries :lol:
Avatar de l’utilisateur
herpo44
Posteur habitué
Posteur habitué
 
Messages: 272
Enregistré le: 29 Juin 2012 à 16:43

Re: [Sujets Récents pour JS 1.0.1] Affichage correct en local - ne s'affiche pas en ligne

Messagepar galixte » 26 Sep 2015 à 18:19

Excellent :lol:
Communau EzCom
Image
« Traductions d’extensions & styles pour phpBB 3.1.x & 3.2.x ».
ImageListes de toutes les extensions recensées pour phpBB 3.1.x & 3.2.x.
ImageListes de tous les styles recensés pour phpBB 3.1.x & 3.2.x.
Avatar de l’utilisateur
galixte
Floodeur universel
Floodeur universel
 
Messages: 9883
Enregistré le: 08 Mar 2004 à 01:40
Localisation: Sud de la France.


Retourner vers Support des extensions non présentes dans notre base de données

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité