[3.1.x] Mise à niveau de phpBB 3.0.x vers 3.1.x Intermédiaire

Partager sur FacebookPartager sur TwitterPartager sur Google+

[3.1.x] Mise à niveau de phpBB 3.0.x vers 3.1.x

Tutoriel pour mettre à niveau votre forum 3.0.x vers 3.1.x


Mise à niveau de phpBB 3.0.x vers 3.1.x

:!: Mise en garde
  • Avant de commencer, sauvegardez votre base de données et l'ensemble des fichiers contenus dans le répertoire de votre forum.

    Note : Si vous utilisez un client FTP, assurez-vous d'utiliser le mode de transfert Binaire. Pour plus d'informations reportez-vous à la notice de votre logiciel.

  • phpBB 3.1 n'est pas compatible avec phpBB 3.0.
  • Les MODs et styles de phpBB 3.0 ne sont pas compatibles avec phpBB 3.1
    A savoir :
    • Certains MOD (3.0) ont été convertis en extension (3.1). Dans certains cas, ces dernières peuvent prendre en charge la récupération des anciennes données.
        Base de données des extensions de phpbb.com (en anglais)
    • Concernant les styles, il faudra les refaire ou attendre qu'ils soient disponibles en téléchargement.
        Base de données des styles de phpbb.com (en anglais)
    Si vous ne trouvez pas l'extension correspondant à votre MOD, vous devriez utiliser l'outil STK afin de nettoyer votre base de données (ou le faire manuellement) et ainsi repartir avec un forum plus "propre".
    Attention ! À ce jour, l'outil STK n'est pas compatible phpBB 3.1. Il vous faut donc utiliser cet outil tant que votre forum est en version 3.0.14 ou inférieure.
Prérequis pour phpBB 3.1 :
  • Un serveur Web supportant PHP
    • Version minimum : >= 5.3.3
    • Version maximum : < 7
  • L'un des systèmes de base de données SQL suivants :
    • MySQL 3.23 ou supérieur (MySQLi supporté)
    • MariaDB 5.1 ou supérieur
    • MS SQL Server 2000 ou supérieur (via ODBC)
    • MS SQL Server 2005 ou supérieur (via le connecteur SQLSRV)
    • Oracle
    • PostgreSQL 8.3+
    • SQLite 2
    • SQLite 3
  • La fonction getimagesize() doit être activée.
  • L'extension PHP JSON doit être activée.

    Note : Certains serveurs d'hébergeur ne sont pas compatibles avec phpBB 3.1. Une liste non exhaustive est à votre disposition.

:arrow: Pour passer de phpBB 3.0.x à phpBB 3.1.x :

Avant de commencer :
  • Assurez-vous que votre forum est au minimum en version 3.0.0.
    De préférence ayez votre forum dans la dernière version stable.
  • Utilisez STK afin de nettoyer votre base de données.
    N'hésitez pas à faire plusieurs nettoyages de votre base de données avant de procéder à la mise à niveau.

Mettre à niveau phpBB :
  1. Téléchargez et décompressez l'archive du pack complet phpBB 3.1.x
  2. Supprimez du pack :
    • Le fichier config.php
    • le répertoire images/
    • le répertoire files/
    • le répertoire store/
  3. Depuis votre serveur, supprimez le contenu du répertoire racine de votre forum excepté :
    • le fichier config.php
    • le répertoire images/
    • le répertoire files/
    • le répertoire store/
  4. Transférez sur votre serveur le contenu du pack complet de phpBB 3.1 dans le répertoire racine contenant votre forum.
  5. Depuis votre navigateur exécutez le fichier install/database_update.php.
    Attention ! Selon l'hébergement où se trouve le forum et la taille de la base de données, cette action peut durer plusieurs minutes, voire plusieurs heures.
  6. Supprimez le répertoire install/.
Si vous pensez que la migration ne s'est pas bien déroulée, n'hésitez pas à ouvrir un sujet dans le forum Mises à jour/Conversions


:arrow: Pour passer votre forum en français :
Bien qu'il existe le pack de mise à jour automatique, nous vous préconisons de procéder à la mise à niveau de votre forum en procédant comme suit :
  1. Téléchargez et décompressez le pack de langue française.
  2. Transférez les deux répertoires mentionnés ci-dessous dans le répertoire racine de votre forum phpBB :
    • /language
    • /styles
  3. Accédez au panneau d'administration « Administration Control Panel » puis allez dans l'onglet « Customise ».
    Cliquez sur « Language packs », puis procédez à l'installation du pack de langue en cliquant sur « Install ».

Profitez d'un forum phpBB 3.1.x et en français !
03/04/2016 - modifié par Skouat pour indiquer la version maxi de php
23/05/2015 - modifié par Skouat pour mettre à jour la version de stk
01/05/2015 - modifié par Skouat pour ajouter un lien vers les hébergeurs non compatible avec phpbb 3.1
08/04/2015 - modifié par Skouat pour mettre l’article à jour
Avatar de l’utilisateur
Jester
Administrateur
Administrateur
 
Rédigé le: 31 Oct 2014 à 11:49
Articles: 7
Noter cet article: 123456 Votants: 19
Mots-clés: Mise, niveau, phpBB, 3.0.x, 3.1.x, ascraeus

Retourner vers Mise à jour