Est-ce vraiment nécessaire de passer en phpbb3 ?

Pour discuter de phpBB3 - Pas de support sur cette section !
Pour du support veuillez vous rendre sur les sections de support 3.1 et 3.2

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Attention, aucun support n'est donné dans cette section.
Partager sur FacebookPartager sur TwitterPartager sur Google+

Est-ce vraiment nécessaire de passer en phpbb3 ?

Messagepar Nippy » 15 Nov 2007 à 08:26

Bonjour,
Je me demandais si c'est vraiment indispensable de passer à la nouvelle version de phpbb. ça me semble beaucoup trop contraignant, car je n'ai aucune envie de perdre mes thèmes et mes mods et de devoir tout refaire. Je trouve ça un peu décevant d'ailleurs, je viens tout juste de réinstaller mon forum et voilà qu'il faudrait encore tout recommencer ? N'y at-il pas moyen de ne pas tout perdre en migrant ? :? Peut-on garder la version phpbb2 ?
Merci !
Image
Nippy
Apprenti-posteur
Apprenti-posteur
 
Messages: 138
Enregistré le: 29 Juil 2005 à 11:47

Re: Est-ce vraiment nécessaire de passer en phpbb3 ?

Messagepar mathieu23 » 15 Nov 2007 à 08:32

Bonjour Nippy ,

Personne ne t'oblige à passer à la version 3.0 lorsqu'elle sera sortie. Tu es libre de faire comme bon te semble mais dès lors d'avoir pleinement conscience des risques sécuritaires que tu feras courir à ton forum et, si tu gardais ta version 2.0.22., pour avoir voulu conserver tes mods et tes thèmes tu trouveras un matin ton forum avec une base de données vide après le passage d'un hackeur.

Un forum doit être continuellement en mouvement pour vivre mais pas seulement dans sa partie visible et accessible aux membres. Il doit l'être autant du côté de son administration avec la mise à jour continuelle des correctifs de sécurité ou corrections de bug.

Bonne journée à toi et à bientôt :wink:
mathieu23
Floodeur universel
Floodeur universel
 
Messages: 15061
Enregistré le: 01 Sep 2004 à 20:08

Re: Est-ce vraiment nécessaire de passer en phpbb3 ?

Messagepar Nippy » 15 Nov 2007 à 15:37

Merci pour ta réponse.
Je suis un peu embêtée surtout pour les thèmes, j'ai pris exemple sur le thème MylManga que j'ai modifié pour correspondre à mon forum. Malheureusement, le thème n'est pas compatible phpbb3 et je me demande comment je vais pouvoir faire pour le remettre tel qu'il était en version phpbb3. Est-ce possible ?
Image
Nippy
Apprenti-posteur
Apprenti-posteur
 
Messages: 138
Enregistré le: 29 Juil 2005 à 11:47

Re: Est-ce vraiment nécessaire de passer en phpbb3 ?

Messagepar Miles Cellar » 15 Nov 2007 à 16:19

Possible, mais avec beaucoup beaucoup de travail. Il serait même moins long et plus facile de recréer entièrement un thème basé sous prosilver par exemple (et ce serait plus "propre" au niveau du code ;) ).
AUTHOR OF THE FRENCH AND AMERICAN ENGLISH LANGUAGE PACK FOR PHPBB
GET THE LATEST LANGUAGE PACK NEWS…
Avatar de l’utilisateur
Miles Cellar
Roi des posts
Roi des posts
 
Messages: 738
Enregistré le: 14 Aoû 2004 à 00:22
Localisation: Paris, France

Re: Est-ce vraiment nécessaire de passer en phpbb3 ?

Messagepar lolovoisin » 15 Nov 2007 à 18:48

Bonsoir Nippy,

Peut être pourrais-tu essayer de voir là ou tu as téléchargé ce thème si son auteur a prévue une version pour phpbb3 ?

Ça coute rien de lui demander :wink:
Ceux qui échouent trouvent des excuses, ceux qui réussissent trouvent les moyens
Quand un homme a faim, mieux vaut lui apprendre à pêcher que de lui donner un poisson.
PAS DE SUPPORT PAR MP !!

tutophpbb3 + astuce + tutos debian
Avatar de l’utilisateur
lolovoisin
Rugbix ³
Rugbix ³
 
Messages: 39778
Enregistré le: 04 Mai 2006 à 12:16
Localisation: Dans la BDD ...

Re: Est-ce vraiment nécessaire de passer en phpbb3 ?

Messagepar Lareine » 15 Nov 2007 à 19:05

Quelques idées avant la modification du style subsilvser2 pour phpBB3.

http://sjpphpbb.net/phpbb3/viewtopic.php?f=20&t=264
Ip-Paï - J-Music, Visual Image, Manga, JapAnime Image ...
Le Mercredi de 17H00 à 18H00 sur Fréquence Mutine 103.8 FM Brest
Diffusée aussi en Streaming sur: http://ippai.free.fr/ippaifm.php - http://ippai.free.fr/forum/
Avatar de l’utilisateur
Lareine
Posteur habitué
Posteur habitué
 
Messages: 219
Enregistré le: 08 Déc 2004 à 07:49

Re: Est-ce vraiment nécessaire de passer en phpbb3 ?

Messagepar bil81 » 15 Nov 2007 à 20:43

mathieu23 a écrit:Bonjour Nippy ,
tu trouveras un matin ton forum avec une base de données vide après le passage d'un hackeur.






Un forum en 2.0.22 peut être parfaitement sécurisé, pas besoin de phpbb3 pour ça
bil81
Apprenti-posteur
Apprenti-posteur
 
Messages: 112
Enregistré le: 05 Juin 2006 à 23:06

Re: Est-ce vraiment nécessaire de passer en phpbb3 ?

Messagepar Elglobo » 16 Nov 2007 à 10:30

bil81 a écrit:Un forum en 2.0.22 peut être parfaitement sécurisé, pas besoin de phpbb3 pour ça

Actuellement, vis à vis des moyens existants, Ok.
Mais qui sait prédire l'avenir et prévoir ce que seront capables de mettre à disposition les futures versions de PHP, de serveur, etc. ?

L'intêret d'utiliser un script toujours supporté par l'auteur, plutôt qu'un script qui ne l'est plus, est que le jour ou tu te rends que ce script est faillible vis à vis de telle nouvelle chose (Version de PHP, de l'OS, etc.) tu pourras demander à voir évoluer ce script en fonction de cet élément nouveau, alors que le script qui n'est plus supporté ne le sera pas, et tu te retrouveras donc bloqué.

Essaye demander à ceux qui utilisaient phpBB génération 1, ce qu'il en pensent, il pensait eux aussi à l'époque sur le script était sécurisé, mais qu'en est il maintenant ? On connait la réponse.

@+ ;)
phpBB-Services.com: L'hébergement et l'assistance de votre forum phpBB en toute tranquillité.
Avatar de l’utilisateur
Elglobo
Floodeur universel
Floodeur universel
 
Messages: 14943
Enregistré le: 13 Oct 2004 à 16:28

Re: Est-ce vraiment nécessaire de passer en phpbb3 ?

Messagepar mathieu23 » 16 Nov 2007 à 10:32

Bonjour bil81,

Merci de ne pas déformer mes propos qui sont très exactement ceux-ci :

Mathieu23 a écrit:Personne ne t'oblige à passer à la version 3.0 lorsqu'elle sera sortie. Tu es libre de faire comme bon te semble mais dès lors d'avoir pleinement conscience des risques sécuritaires que tu feras courir à ton forum et, si tu gardais ta version 2.0.22., pour avoir voulu conserver tes mods et tes thèmes tu trouveras un matin ton forum avec une base de données vide après le passage d'un hackeur.


Je parle de version 3.0. lorsqu'elle sera sortie, ce qui n'est pas le cas pour l'instant et je parle de refus de suivre la mise à jour de phpBB. Si tu penses qu'une version 2.0.22. restera ad vitam eternam infaillible je pense que tu te trompes allègrement. D'ailleurs une version 2.0.22. peut parfaitement aujourd'hui être hackée si elle contient des mods possédant des failles sécuritaires.

Bonne journée et à bientôt :wink:
mathieu23
Floodeur universel
Floodeur universel
 
Messages: 15061
Enregistré le: 01 Sep 2004 à 20:08


Retourner vers Discussions sur phpBB3

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité