[Réglé] Différence Chrome/Mozilla/IExplorer

Ce forum aborde toutes les questions qu'un codeur ou webmaster pourrait se poser, et n'ayant aucun rapport direct avec phpBB.
Tout ce qui peut concerner la récupération des sessions de phpBB sur votre site, doit se faire dans cette section.

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

[Réglé] Différence Chrome/Mozilla/IExplorer

Messagepar Jno » 26 Fév 2012 à 01:31

[balises img supprimées par Cocooncrash]


Bonjour,

J'ai insérer un formulaire dans mon header avec ce code :
Code: Tout sélectionner
	<div id="menubar">
		<table width="100%" cellspacing="0">
		<tr>
			<td class="genmed">
				<!-- IF not S_IS_BOT -->
				
				<!--<li class="icon-pages"><a href="{U_CALENDAR}">{L_CALENDAR}</a></li>-->
				
				<a href="{U_LOGIN_LOGOUT}"><img src="{T_THEME_PATH}/images/icon_mini_login.gif" width="12" height="13" alt="*" /> {L_LOGIN_LOGOUT}</a>&nbsp;<!-- ENDIF -->
				<!-- IF U_RESTORE_PERMISSIONS --> &nbsp;<a href="{U_RESTORE_PERMISSIONS}"><img src="{T_THEME_PATH}/images/icon_mini_login.gif" width="12" height="13" alt="*" /> {L_RESTORE_PERMISSIONS}</a><!-- ENDIF -->
				<!-- IF S_BOARD_DISABLED and S_USER_LOGGED_IN --> &nbsp;<span style="color: red;">{L_BOARD_DISABLED}</span><!-- ENDIF -->
				<!-- IF not S_IS_BOT -->
					<!-- IF S_USER_LOGGED_IN -->
						<!-- IF S_DISPLAY_PM --> &nbsp;<a href="{U_PRIVATEMSGS}"><img src="{T_THEME_PATH}/images/icon_mini_message.gif" width="12" height="13" alt="*" /> {PRIVATE_MESSAGE_INFO}<!-- IF PRIVATE_MESSAGE_INFO_UNREAD -->, {PRIVATE_MESSAGE_INFO_UNREAD}<!-- ENDIF --></a><!-- ENDIF -->
					<!-- ELSEIF S_REGISTER_ENABLED --> &nbsp;<a href="{U_REGISTER}"><img src="{T_THEME_PATH}/images/icon_mini_register.gif" width="12" height="13" alt="*" /> {L_REGISTER}</a>
					<!-- ENDIF -->
				<!-- ENDIF -->
			</td>
			<td class="genmed" align="{S_CONTENT_FLOW_END}">
				<a href="{U_PORTAL}"><img src="{T_THEME_PATH}/images/portal/portal_links.png" width="12" height="13" alt="*" /> {L_PORTAL}</a>&nbsp; &nbsp;
				<a href="{U_INDEX}"><img src="{T_THEME_PATH}/images/portal/portal_link_us.png" width="12" height="13" alt="*" /> {L_INDEX}</a>
				
				<br/><br/>
				<table>
					<tr>
						<td>
							<!-- IF S_DISPLAY_ALBUMS -->
							<form action="{U_ALBUMS}" method="post">
								<input type="image" src="{T_THEME_PATH}/images/icon_mini_album.gif" class="albums_class"></td><td>
								<input type="submit" value="Albums Photos" class="albums_class">
								<input hidden name="albums" value="">
							</form>
							&nbsp;
							<!-- ENDIF -->
						</td>
						<td>
							<a href="{U_FAQ}"><img src="{T_THEME_PATH}/images/icon_mini_faq.gif" width="12" height="13" alt="*" /> {L_FAQ}</a>
							<!-- IF S_DISPLAY_SEARCH -->&nbsp; &nbsp;<a href="{U_SEARCH}"><img src="{T_THEME_PATH}/images/icon_mini_search.gif" width="12" height="13" alt="*" /> {L_SEARCH}</a><!-- ENDIF -->
							<!-- IF not S_IS_BOT -->
							<!-- IF S_DISPLAY_MEMBERLIST -->&nbsp; &nbsp;<a href="{U_MEMBERLIST}"><img src="{T_THEME_PATH}/images/icon_mini_members.gif" width="12" height="13" alt="*" /> {L_MEMBERLIST}</a><!-- ENDIF -->
							<!-- IF S_USER_LOGGED_IN -->&nbsp; &nbsp;<a href="{U_PROFILE}"><img src="{T_THEME_PATH}/images/icon_mini_profile.gif" width="12" height="13" alt="*" /> {L_PROFILE}</a><!-- ENDIF -->
						<!-- ENDIF -->
						</td>
					</tr>
				</table>
			</td>
		</tr>
		</table>
	</div>

Pour la partie concernée, cherchez :
Code: Tout sélectionner
<!-- IF S_DISPLAY_ALBUMS -->


Voici ce que ça donne sur Google Chrome et Mozilla (la version souhaitée) :
http://img839.imageshack.us/img839/6035/chromelo.png


Par contre, sur Internet Explorer, ça donne ça :
http://img62.imageshack.us/img62/5293/iexplo.png
Modifié en dernier par Jno le 26 Fév 2012 à 17:17, modifié 1 fois.
Jno
Posteur néophyte
Posteur néophyte
 
Messages: 10
Enregistré le: 23 Fév 2012 à 14:19

Re: Différence Chrome/Mozilla/IExplorer

Messagepar cocooncrash » 26 Fév 2012 à 10:09

Bonjour Jno,

Nous te remercions de ne pas poster des images de grande taille/de gros poids afin de ne pas alourdir/modifier l'affichage normal des pages.(supérieure à 500 pixels), ou de gros poids (supérieur à 150ko).

Bonne journée et à bientôt :wink: .
decouvrez l'aide complete : ICI
découvrez les règles : La_bas

Pensez a ajouter le tag [réglé] en modifiant votre premier message s'il est résolu. Merci :wink:
Avatar de l’utilisateur
cocooncrash
Resp. des modérateurs
Resp. des modérateurs
 
Messages: 7929
Enregistré le: 07 Jan 2008 à 09:29
Localisation: dans un bocal en compagnie de nemo!!

Re: Différence Chrome/Mozilla/IExplorer

Messagepar Jno » 26 Fév 2012 à 11:33

Désolé, merci pour l'informartion.

En fait, j'ai l'impression que c'est le <input hidden> qui est mal géré par IE.

Sur mon androïd, j'ai le même problème alors que c'est Chrome...

Avez-vous une idée de solution ?
Jno
Posteur néophyte
Posteur néophyte
 
Messages: 10
Enregistré le: 23 Fév 2012 à 14:19

Re: Différence Chrome/Mozilla/IExplorer

Messagepar Ariaswari » 26 Fév 2012 à 11:59

Bonjour,

Pour les champs cachés, la syntaxe est <input type="hidden" name="" value="" /> et non <input hidden name="albums" value="">.
Ancien supporter
« Douter de tout ou tout croire, ce sont deux solutions également commodes, qui l'une et l'autre nous dispensent de réfléchir (Henri Poincaré) »
Avatar de l’utilisateur
Ariaswari
Grand-maître des floodeurs
Grand-maître des floodeurs
 
Messages: 2738
Enregistré le: 18 Oct 2007 à 20:43

Re: Différence Chrome/Mozilla/IExplorer

Messagepar Jno » 26 Fév 2012 à 17:18

OK Merci
Jno
Posteur néophyte
Posteur néophyte
 
Messages: 10
Enregistré le: 23 Fév 2012 à 14:19


Retourner vers Coding, Webmastering et Sécurité informatique

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 3 invités