Petit soucies avec "é" "à" "è"

Ce forum aborde toutes les questions qu'un codeur ou webmaster pourrait se poser, et n'ayant aucun rapport direct avec phpBB.
Tout ce qui peut concerner la récupération des sessions de phpBB sur votre site, doit se faire dans cette section.

Modérateur: Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Petit soucies avec "é" "à" "è"

Messagepar Zeran » 19 Nov 2008 à 12:14

Bonjour,

Ne conaissant pas le php , j'ai cherché un script pour avec un formulaire qui envoie un e-mail avec des données. Le seul probléme que j'ai c'est que quand il y a des "é" "â" "à" "è" ca les remplasse par des "@A"" ( enfin c'est un exemple ) j'aiùerai savoir qu'elle est le bout de code qui pourrai marcher pour que les "é" s'affiche correctement

<?php
$TO = "test@test.fr";

$h = "From: " . $TO;

$message = "";

while (list($key, $val) = each($HTTP_POST_VARS)) {
$message .= "$key : $val\n";
}
$message = utf8_decode($message);
mail($TO, $Sujet, $message, $h);

Header("Location: merci.html");

?>

merci d'avance
Image
Zeran
Posteur néophyte
Posteur néophyte
 
Messages: 54
Enregistré le: 11 Oct 2007 à 23:58

Re: Petit soucies avec "é" "à" "è"

Messagepar abble » 20 Nov 2008 à 19:48

salut
le language employé dans ton script est "utf-8"
si tu écris en "iso" dans tes mails, tu auras ce genre de désagrément
http://www.commentcamarche.net/contents/html/htmlcarac.php3
il faut donc soit écrire tes mails en employant les caractéres spéciaux dans le lien ci-dessus soit changer le language du script
Styles phpBB3 uniques et sur mesure :
Cosa Nostra Design
abble
Floodeur universel
Floodeur universel
 
Messages: 11882
Enregistré le: 04 Oct 2004 à 09:34
Localisation: Entre la pierre et la plume...

Re: Petit soucies avec "é" "à" "è"

Messagepar GhostKiller » 20 Nov 2008 à 20:33

pourtant c'est le iso qui inclus les caractères àèé non ???
Image
GhostKiller
Posteur néophyte
Posteur néophyte
 
Messages: 52
Enregistré le: 18 Avr 2007 à 20:16

Re: Petit soucies avec "é" "à" "è"

Messagepar abble » 20 Nov 2008 à 21:32

oui mais ton script lit du utf-8 :
Code: Tout sélectionner
$message = utf8_decode


donc si il voit "é" "à" "è" il met des caracteres bizarres à la place
Styles phpBB3 uniques et sur mesure :
Cosa Nostra Design
abble
Floodeur universel
Floodeur universel
 
Messages: 11882
Enregistré le: 04 Oct 2004 à 09:34
Localisation: Entre la pierre et la plume...

Re: Petit soucies avec "é" "à" "è"

Messagepar Zeran » 20 Nov 2008 à 22:45

je comprend pas vraiment ou es que je pourai mettre c'est code de caréctére dans le php
Image
Zeran
Posteur néophyte
Posteur néophyte
 
Messages: 54
Enregistré le: 11 Oct 2007 à 23:58


Retourner vers Coding, Webmastering et Sécurité informatique

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 2 invités