Packs pour phpBB 3.2.2 disponibles !

Annonces et informations relatives à la communauté phpBB et à phpBB-fr.com

Modérateur: Chefs d'équipes

Packs pour phpBB 3.2.2 disponibles !

Messagepar Jester » 14 Jan 2018 à 14:45

Bonjour,

Nos packs pour la version 3.2.2 de phpBB sont disponibles sur notre page Téléchargements.

Nous vous conseillons vivement de mettre à jour vos forums pour des raisons de sécurité dans cette dernière version.

____________________________________

:arrow: Comme publié par phpBB.com, un message d'erreur peut arriver lors de la mise à jour :
https://www.phpbb.com/community/viewtop ... &t=2453611

Si vous rencontrez ce problème :

PHP Fatal error: Uncaught Error: Call to a member function fetch_array() on resource in phpbb/db/migration/data/v32x/fix_user_styles.php:42


Ouvrez phpbb/db/migration/data/v32x/fix_user_styles.php

Trouvez :

Code: Tout sélectionner
		$enabled_styles = $result->fetch_array();


et remplacez par :

Code: Tout sélectionner
		$enabled_styles = array();
		while ($row = $this->db->sql_fetchrow($result))
		{
			$enabled_styles[] = (int) $row['style_id'];
		}


-----------------------

Si vous avez ce message :

PHP Fatal error: Call to a member function get() on null in phpbb/db/migration/data/v32x/merge_duplicate_bbcodes.php on line 49


Ouvrez phpbb/db/migration/data/v32x/merge_duplicate_bbcodes.php

Trouvez :

Code: Tout sélectionner
class merge_duplicate_bbcodes extends \phpbb\db\migration\migration


et remplacez par :

Code: Tout sélectionner
class merge_duplicate_bbcodes extends \phpbb\db\migration\container_aware_migration


------------------------

Si vous rencontrez des soucis avec l'affichage des fichiers attachés :

Ouvrez phpBB/includes/functions_posting.php

Trouvez :

Code: Tout sélectionner
foreach ($attachment_data as $count => $attach_row)


et ajoutez sur la ligne précédente :

Code: Tout sélectionner
$attachrow_template_vars = [];


et supprimez :

Code: Tout sélectionner
$attachrow_template_vars = array();


Après la modification des fichiers de migrations, il faut impérativement supprimer le cache du forum.

Sur le FTP, dans cache/ supprimer le répertoire installer
"Quand le Troll parle, l'homme avisé l'écoute."
Personnaliser son forum - La documentation de phpBB-fr.com - Les téléchargements
N'oubliez pas de modifier votre message en ajoutant le tag [Réglé] quand votre sujet est résolu.
Avatar de l’utilisateur
Jester
Administrateur
Administrateur
 
Messages: 34565
Enregistré le: 01 Jan 2005 à 01:00
Localisation: Là, pas loin...

Re: Packs pour phpBB 3.2.2 disponibles !

Messagepar Steph » 20 Jan 2018 à 15:23

Si lors de la mise à jour vers 3.2.2 vous rencontrez le message d'erreur suivant malgré que vous ayez effectué les modifications indiquées ci-dessus.

Délai d’attente de la demande dépassé

L’assistant d’installation n’a pas répondu dans les délais attendus, vous pouvez essayer d’actualiser la page, ce qui peut provoquer une corruption des données. Nous vous suggérons soit d’augmenter le paramètre « timeout » de votre serveur, soit d’essayer d’utiliser le mode « CLI » (ligne de commande).

Installation des données : \phpbb\db\migration\data\v32x\merge_duplicate_bbcodes.


Message erreur - merge_duplicate_bbcodes.png
(9.84 Kio) Pas encore téléchargé


Lors de la mise à jour les BBCodes personnalisés sont vérifiés, l'erreur est dû au fait que vous avez surement deux BBCodes qui sont dupliqués, exemple bbcode1 et bbcode1=.

Pour le moment, une solution est de supprimer ou renommer une des deux variantes dans l'administration > onglet "Messages" > menu latéral gauche "BBCodes" et de rafraîchir la page pour continuer la mise à jour.
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 18275
Enregistré le: 29 Déc 2008 à 16:48
Localisation: Alsace / Bas-Rhin / France


Retourner vers Annonces et informations

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité