phpBB3 Release Candidate 2 (RC2) disponible

Annonces et informations relatives à la communauté phpBB et à phpBB-fr.com

Modérateur: Chefs d'équipes

Partager sur FacebookPartager sur TwitterPartager sur Google+

phpBB3 Release Candidate 2 (RC2) disponible

Messagepar tonillo » 24 Juin 2007 à 21:13

Acyd Burn a écrit:Bonjour,
Nous sommes ravis de vous annoncer la sortie de phpBB3 RC2. C'est la deuxième version candidate qui est appelée à devenir la version GOLD si aucun bug n'est découvert. Bien sûr, il se peut qu'il y ai encore d'autres versions candidates.

Le support est donné sur les versions candidates, aussi bien sur les packs de langues, que sur les modifications et sur les styles. Nous ne fournirons de support qu'aux personnes ayant une nouvelle installation ou une mise à jour depuis la RC1, nous ne fournirons pas de support pour les conversions depuis des versions BETA.

Durant les dernières semaines, le convertisseur a vu nombre de ces bugs résolus et a été mis à jour, ceci garantissant une conversion plus efficace et plus stable depuis les versions antérieures.

http://www.phpbb.com/support/documents. ... &version=3


Pour garder notre ligne de conduite concernant le support, nous ne supporterons pas les installations de type :
  • Mises à jour depuis les versions beta vers phpBB3 RC1 ou plus
  • Conversions depuis phpBB2.0.x vers phpBB3 beta
  • Installations de phpBB3 versions beta
Nous supporterons les installations de type :
  • Mises à jour depuis une version phpBB3 RC1 vers les versions supérieures
  • Conversions depuis phpBB2.0.x vers phpBB3 RC1 ou plus
  • Nouvelles installations de phpBB3 RC1 ou plus

Une courte explication sur la conversion est fournie dans le fichier INSTALL.html (dans le rep docs), veuillez le lire attentivement. Si vous ne voulez pas faire d'erreur, nous vous suggérons d'attendre une prochaine version avant de procéder à la conversion complète de votre installations 2.0.x

Si vous avez un pack de langue installé, vérifiez de l'avoir mis à jour aprés avoir mis à jour le pack de langue en Anglais. Vous pouvez également avoir des messages d'avertissement php, ne reportez pas les bugs concernant ces messages d'erreurs si votre pack de langues n'est pas à jour.

Minimum nécessaire

phpBB3 a besoin des éléments suivants pour fonctionner :
  • Un serveur Web ou un compte mutualisé chez un hébergeur, acceptant le PHP.
  • Un système de base de données SQL, un des suivants :
    • MySQL 3.23 ou plus récent (MySQLi supporté)
    • PostgreSQL 7.3+
    • SQLite 2.8.2+
    • Firebird 2.0+
    • MS SQL Server 2000 ou plus récent (directement ou par ODBC)
    • Oracle
  • PHP 4.3.3+ (>=4.3.3, >4.4.x, >5.x.x, >6.0-dev (compatible)) supportant votre système de base de données
  • La fonction getimagesize() doit être activée
  • La présence des modules suivants vous permettrons d'accéder à des fonctions additionnelles, mais ils ne sont pas obligatoires.
    • Support de la compression zlib
    • Support du FTP à distance
    • Support du XML
    • Support d'Imagemagick
    • Support GD
La présence de chacun de ces modules facultatifs sera vérifiée pendant le procédé d'installation.

Sécurité

Les failles de sécurité trouvées doivent être rapportées sur notre outil de rapports de failles de sécurité, comme vous en avez l'habitude.

Packs disponibles

Comme c'est la première fois que notre outil de mise à jour automatique est utilisé sur des milliers d'installations, nous recommandons l'utilisation du package "fichiers modifiés seulement" si vous rencontrez des difficultés, particulièrement si vous aviez modifié votre installation.

Avec cette version, il y a 4 packs disponibles :
  • Pack complet
    Contient les sources entières de phpBB3 et les fichiers de langue en Anglais.
  • Fichiers modifiés seulement
    Contient seulement les fichiers qui ont été modifiés depuis les versions précédentes de phpBB3. Ce package contient les fichiers modifiés pour la mise à jour de chaque version.
  • Mise à jour manuelle
    Contient les modifications de chaques fichiers depuis les versions précédentes de phpBB3.
  • Mise à jour automatique
    Pack pour la mise à jour automatique, contenant les changements par rapport à la version précédente.
Sélectionnez le package qui semble le plus adapté à votre installation.

Assurez-vous de lire le fichier INSTALL et README dans docs/ avant d'effectuer une installation, mise à jour ou conversions!
L'archive de mise à jour automatique ne contient pas le fichier includes/utf/data/recode_cjk.php. Si vous utilisez un encodage SJIS ou une variante, vous devez remplacer ce fichier manuellement par la version fournie dans le pack complet.



Téléchargement/Documentation


Passez d'agréables moments avec cette version,
Les équipes de phpBB.


Le pack officiel est disponible dans la section téléchargement de phpBB.com :
http://www.phpbb.com/downloads/development.php


Bien cordialement,
L'équipe de phpBB-fr.com
...
Avatar de l’utilisateur
tonillo
Grand-maître des floodeurs
Grand-maître des floodeurs
 
Messages: 4628
Enregistré le: 06 Juin 2005 à 08:39

Retourner vers Annonces et informations

 


  • Articles en relation
    Réponses
    Vues
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 2 invités